summaryrefslogtreecommitdiff
path: root/devel/qt5-designer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/qt5-designer/Makefile')
-rw-r--r--devel/qt5-designer/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/devel/qt5-designer/Makefile b/devel/qt5-designer/Makefile
index 23680fb04add..d6efdf9590c2 100644
--- a/devel/qt5-designer/Makefile
+++ b/devel/qt5-designer/Makefile
@@ -8,10 +8,9 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt 5 graphical user interface designer
-USE_QT5= assistant_run core gui network printsupport quick uiplugin \
+USE_QT= assistant_run core gui network printsupport quick uiplugin \
widgets xml buildtools_build
-QT_DIST= tools
-USES= qmake
+USES= qmake qt-dist:5,tools
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
DESKTOP_ENTRIES="Qt 5 Designer" "" \
@@ -26,7 +25,8 @@ OPTIONS_DEFINE= WEBKIT
OPTIONS_SUB= yes
WEBKIT_DESC= Build WebKit-based WebView widget
WEBKIT_QMAKE_ON= CONFIG+=use_webkit
-WEBKIT_USE= QT5=webkit
+WEBKIT_USES= qt-dist:5,tools
+WEBKIT_USE= QT=webkit
post-patch:
# uiplugin is built in x11-toolkits/qt5-uiplugin.