summaryrefslogtreecommitdiff
path: root/devel/log4cxx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/log4cxx/Makefile')
-rw-r--r--devel/log4cxx/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/devel/log4cxx/Makefile b/devel/log4cxx/Makefile
index ac53c52272e3..4bc2b44eb5fb 100644
--- a/devel/log4cxx/Makefile
+++ b/devel/log4cxx/Makefile
@@ -28,7 +28,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/include/boost/regex.hpp:${PORTSDIR}/devel/boost
CXXFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
.endif
-USE_AUTOTOOLS= automake:15 autoconf:253 libtool:13
+USE_AUTOTOOLS= automake:15 autoconf:253 libtool:15
AUTOMAKE_ARGS= --add-missing
LIBTOOL_VARS= --force --automake
@@ -52,6 +52,7 @@ IGNORE= does not compile on FreeBSD 4.x (missing swprintf in libc)
pre-configure:
@(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${ACLOCAL})
+ @${REINPLACE_CMD} -e '/^_LT_AC_SHELL_INIT/d' ${WRKSRC}/aclocal.m4
post-patch:
@${REINPLACE_CMD} "s#\$$(DESTDIR)\$$(htmldir)#${DOCSDIR}/html#" ${WRKSRC}/docs/Makefile.am