summaryrefslogtreecommitdiff
path: root/devel/libstash/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libstash/Makefile')
-rw-r--r--devel/libstash/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/libstash/Makefile b/devel/libstash/Makefile
new file mode 100644
index 000000000000..8bcd64e4f23e
--- /dev/null
+++ b/devel/libstash/Makefile
@@ -0,0 +1,35 @@
+# New ports collection Makefile for: libstash
+# Date created: 22 August 2000
+# Whom: jasone
+#
+# $FreeBSD$
+#
+
+PORTNAME= libstash
+PORTVERSION= 1.0.0
+CATEGORIES= devel
+DISTNAME= canonware-1.0.0
+MASTER_SITES= http://www.canonware.com/download/canonware/
+
+MAINTAINER= jasone@FreeBSD.org
+
+BUILD_DEPENDS= cook:${PORTSDIR}/devel/cook
+
+USE_AUTOCONF= yes
+GNU_CONFIGURE= yes
+
+MAN3= libstash_dbg.3s libstash_pezz.3s libstash_rwl.3s \
+ libstash.3s libstash_dch.3s libstash_pool.3s libstash_sema.3s \
+ libstash_bhp.3s libstash_mem.3s libstash_ql.3s libstash_thd.3s \
+ libstash_buf.3s libstash_mq.3s libstash_qr.3s libstash_treen.3s \
+ libstash_ch.3s libstash_mtx.3s libstash_qs.3s libstash_tsd.3s \
+ libstash_cnd.3s libstash_out.3s libstash_res.3s
+MANCOMPRESSED= no
+
+do-build:
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} cook libstash)
+
+do-install:
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} cook libstash_install)
+
+.include <bsd.port.mk>