summaryrefslogtreecommitdiff
path: root/devel/cocktail/files/patch-front-m2c-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cocktail/files/patch-front-m2c-Makefile')
-rw-r--r--devel/cocktail/files/patch-front-m2c-Makefile76
1 files changed, 0 insertions, 76 deletions
diff --git a/devel/cocktail/files/patch-front-m2c-Makefile b/devel/cocktail/files/patch-front-m2c-Makefile
deleted file mode 100644
index 0f3225dec5ae..000000000000
--- a/devel/cocktail/files/patch-front-m2c-Makefile
+++ /dev/null
@@ -1,76 +0,0 @@
---- /usr/ports/devel/cocktail/work/cocktail-9309//./front/m2c/Makefile Tue Feb 15 14:23:22 1994
-+++ ./front/m2c/Makefile Thu Aug 5 18:49:00 2004
-@@ -1,35 +1,33 @@
--LIB = $(HOME)/lib
--OPT = -O
--CC = cc
-
-- # C library (reuse)
--REUSE = ../../reuse/m2c
-+.include "../../Makefile.inc"
-
-- # C libraries
--CLIBS = $(REUSE)/libreuse.a
--
-- # options for C compiler
--CFLAGS = -w -I$(REUSE) $(OPT)
--
--M2FLAGS = -c
-+ROOTDIR = ../..
-+CFLAGS += -I$(INCDIR)
-+CLIBS += $(REUSELIB)
-
- OBJS = Actions.o Character.o Checks.o Errors.o Limits.o \
-- Listing.o Oper.o Pars.o Parser.o Path.o Rules.o Scanner.o \
-+ Listing.o Oper.o Parser.o Path.o Rules.o Scanner.o \
- SysError.o TokenTab.o Tokens.o WriteTok.o
-
- libfront.a : $(OBJS)
- ar ruc libfront.a $(OBJS)
- ranlib libfront.a
-
--install: ErrorTab libfront.a $(LIB)/lalr
-- cp ErrorTab $(LIB)/lalr
-- chmod a+r $(LIB)/lalr/ErrorTab
-+install: ErrorTab libfront.a $(DESTLIB)/lalr
-+ cp ErrorTab $(DESTLIB)/lalr
-+ chmod a+r $(DESTLIB)/lalr/ErrorTab
-
- # installation directories
-
--$(LIB)/lalr: $(LIB)
-- sh -c "if test ! -d $(LIB)/lalr; then mkdir -p $(LIB)/lalr; else true; fi"
-+$(DESTLIB)/lalr: $(DESTLIB)
-+ sh -c "if test ! -d $(DESTLIB)/lalr; then mkdir -p $(DESTLIB)/lalr; else true; fi"
-+
-+test: Pars
-
-+clean:
-+ -rm -f $(STDCLEAN)
-+ -rm -f *.o
-+ -rm -f libfront.a Pars
-
- # HEAD
-
-@@ -193,21 +191,3 @@
- Character.o \
- $(CLIBS)
-
--# TAIL
--
--clean :
-- rm -f core *.o
--
--CLEAN :
-- rm -f core *.o libfront.a
--
--.SUFFIXES: .md .mi .h .c .o
--
--.mi.c:
-- mtc2 $(M2FLAGS) $*.mi;
--
--.md.h:
-- mtc2 $(M2FLAGS) $*.md;
--
--.c.o:
-- $(CC) $(CFLAGS) -c $*.c