summaryrefslogtreecommitdiff
path: root/deskutils/py-khard/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/py-khard/Makefile')
-rw-r--r--deskutils/py-khard/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/deskutils/py-khard/Makefile b/deskutils/py-khard/Makefile
index 71f92fa84f05..eaf9fc8b2648 100644
--- a/deskutils/py-khard/Makefile
+++ b/deskutils/py-khard/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}atomicwrites>=0.1.7:devel/py-atomicwrites@${
${PYTHON_PKGNAMEPREFIX}vdirsyncer>=0:deskutils/py-vdirsyncer@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}vobject>=0.9.5:deskutils/py-vobject@${PY_FLAVOR}
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${PY_FLAVOR} \
+ ${PY_SPHINX} \
${RUN_DEPENDS}
USES= python:3.5+ gmake
@@ -35,6 +35,12 @@ PLIST_FILES= share/zsh/site-functions/_khard \
SUB_FILES= pkg-message
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|sphinx-build|${LOCALBASE}/bin/sphinx-build-${PYTHON_VER}|g' \
+ -e 's|sphinx-apidoc|${LOCALBASE}/bin/sphinx-apidoc-${PYTHON_VER}|g' \
+ ${WRKSRC}/doc/Makefile
+
do-build:
(cd ${WRKSRC}/doc && ${MAKE_CMD} man)