summaryrefslogtreecommitdiff
path: root/deskutils/copyq/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/copyq/Makefile')
-rw-r--r--deskutils/copyq/Makefile32
1 files changed, 19 insertions, 13 deletions
diff --git a/deskutils/copyq/Makefile b/deskutils/copyq/Makefile
index 4614ae200178..d6893d33aab4 100644
--- a/deskutils/copyq/Makefile
+++ b/deskutils/copyq/Makefile
@@ -1,30 +1,36 @@
# $FreeBSD$
PORTNAME= copyq
-PORTVERSION= 2.7.1
-PORTREVISION= 1
+PORTVERSION= 3.6.1
DISTVERSIONPREFIX= v
CATEGORIES= deskutils
-MAINTAINER= kris@ixsystems.com
+MAINTAINER= ports@FreeBSD.org
COMMENT= Qt5 based clipboard manager
-LICENSE= GPLv3
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= qmake qt:5
-USE_XORG= x11 xfixes xtst
-USE_QT= core gui network svg multimedia imageformats \
- buildtools_build x11extras concurrent widgets xml \
- script
-USE_GL= gl
+USES= cmake:outsource qt:5
+USE_XORG= ice sm x11 xext xfixes xtst
+USE_QT= core gui network script svg widgets x11extras xml \
+ buildtools_build linguist_build qmake_build \
+ imageformats_run
USE_GITHUB= yes
GH_ACCOUNT= hluk
GH_PROJECT= CopyQ
-PLIST_FILES= bin/copyq
+CMAKE_ARGS= -DMANPAGE_INSTALL_PREFIX:PATH=${MANPREFIX}/man/man1
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/copyq ${STAGEDIR}${PREFIX}/bin
+OPTIONS_DEFINE= PLUGINS WEBKIT
+OPTIONS_DEFAULT= PLUGINS WEBKIT
+OPTIONS_SUB= yes
+
+PLUGINS_CMAKE_BOOL= WITH_PLUGINS
+
+WEBKIT_USE= qt=webkit
+WEBKIT_CMAKE_BOOL= WITH_WEBKIT
+WEBKIT_IMPLIES= PLUGINS
.include <bsd.port.mk>