summaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile2
-rw-r--r--converters/php81-iconv/Makefile7
-rw-r--r--converters/php81-mbstring/Makefile7
-rw-r--r--converters/php81-mbstring/files/patch-config.m444
4 files changed, 60 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 35de0a964209..2a0031cfd8a2 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -141,7 +141,9 @@
SUBDIR += php74-iconv
SUBDIR += php74-mbstring
SUBDIR += php80-iconv
+ SUBDIR += php81-iconv
SUBDIR += php80-mbstring
+ SUBDIR += php81-mbstring
SUBDIR += psiconv
SUBDIR += py-bencode.py
SUBDIR += py-bencoder
diff --git a/converters/php81-iconv/Makefile b/converters/php81-iconv/Makefile
new file mode 100644
index 000000000000..cd797676267b
--- /dev/null
+++ b/converters/php81-iconv/Makefile
@@ -0,0 +1,7 @@
+CATEGORIES= converters
+
+MASTERDIR= ${.CURDIR}/../../lang/php81
+
+PKGNAMESUFFIX= -iconv
+
+.include "${MASTERDIR}/Makefile"
diff --git a/converters/php81-mbstring/Makefile b/converters/php81-mbstring/Makefile
new file mode 100644
index 000000000000..5ec26ef20ab5
--- /dev/null
+++ b/converters/php81-mbstring/Makefile
@@ -0,0 +1,7 @@
+CATEGORIES= converters
+
+MASTERDIR= ${.CURDIR}/../../lang/php81
+
+PKGNAMESUFFIX= -mbstring
+
+.include "${MASTERDIR}/Makefile"
diff --git a/converters/php81-mbstring/files/patch-config.m4 b/converters/php81-mbstring/files/patch-config.m4
new file mode 100644
index 000000000000..a3e5c14477a3
--- /dev/null
+++ b/converters/php81-mbstring/files/patch-config.m4
@@ -0,0 +1,44 @@
+--- config.m4.orig 2019-08-06 06:54:10 UTC
++++ config.m4
+@@ -37,6 +37,31 @@ AC_DEFUN([PHP_MBSTRING_EXTENSION], [
+
+ out="php_config.h"
+
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
++
+ if test "$ext_shared" != "no" && test -f "$ext_builddir/config.h.in"; then
+ out="$abs_builddir/config.h"
+ fi
+@@ -200,6 +225,9 @@ PHP_ARG_ENABLE([mbregex],
+ [yes],
+ [no])
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir MBSTRING: pcre install prefix], no, no)
++
+ if test "$PHP_MBSTRING" != "no"; then
+ AC_DEFINE([HAVE_MBSTRING],1,[whether to have multibyte string support])
+