summaryrefslogtreecommitdiff
path: root/comms/py-qt5-serialport/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/py-qt5-serialport/Makefile')
-rw-r--r--comms/py-qt5-serialport/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/comms/py-qt5-serialport/Makefile b/comms/py-qt5-serialport/Makefile
index 50d3ef8fcfcb..67918dc5cf30 100644
--- a/comms/py-qt5-serialport/Makefile
+++ b/comms/py-qt5-serialport/Makefile
@@ -1,7 +1,6 @@
# $FreeBSD$
PORTNAME= serialport
-PORTREVISION= 1
CATEGORIES= comms devel python
MAINTAINER= kde@FreeBSD.org
@@ -15,7 +14,7 @@ PYQT_DIST= yes
USES= gl python pyqt:5 qt:5
USE_GL= gl
-USE_PYQT= sip_build core_run
+USE_PYQT= sip_build core_run
USE_PYTHON= concurrent flavors py3kplist
USE_QT= core gui serialport qmake_build
@@ -29,4 +28,7 @@ API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
DEBUG_CONFIGURE_ON= --debug --trace
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PyQt5/QtSerialPort.so
+
.include <bsd.port.mk>