summaryrefslogtreecommitdiff
path: root/comms/nec2c/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/nec2c/Makefile')
-rw-r--r--comms/nec2c/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/comms/nec2c/Makefile b/comms/nec2c/Makefile
new file mode 100644
index 000000000000..58f451cc4315
--- /dev/null
+++ b/comms/nec2c/Makefile
@@ -0,0 +1,46 @@
+# ports collection makefile for: splat
+# Date created: 8 July 2005
+# Whom: db
+#
+# $FreeBSD$
+
+PORTNAME= nec2c
+PORTVERSION= .9
+CATEGORIES= comms
+MASTER_SITES= http://www.si-list.org/NEC_Archives/
+DISTNAME= nec2c
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= db@db.net
+COMMENT= Used to calculate antenna patterns useful to ham radio
+
+#
+# both libccm and files/carg.c can "go away" once libc is filled in
+# with missing posix complex functions.
+#
+LIB_DEPENDS= ccm:${PORTSDIR}/math/ccmath
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "does not build (gcc does not understand complex numbers)"
+.endif
+
+post-patch:
+ ${CP} ${FILESDIR}/carg.c ${WRKSRC}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/nec2c ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Input/*.nec ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Input/*.NEC ${EXAMPLESDIR}
+ @${ECHO} ""
+ @${ECHO} "nec2c docs installed in ${DOCSDIR}"
+ @${ECHO} "nec2c sample Input files installed in ${EXAMPLESDIR}"
+ @${ECHO} ""
+.endif
+
+.include <bsd.port.post.mk>