summaryrefslogtreecommitdiff
path: root/comms/grig/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/grig/Makefile')
-rw-r--r--comms/grig/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/comms/grig/Makefile b/comms/grig/Makefile
index 112e7cfee969..48b98ee1eee6 100644
--- a/comms/grig/Makefile
+++ b/comms/grig/Makefile
@@ -1,9 +1,9 @@
# Created by: Matt Dawson <matt@mattsnetwork.co.uk>
PORTNAME= grig
-PORTVERSION= 0.8.1
+PORTVERSION= 0.9.0
+#DISTNAME= Grig
CATEGORIES= comms hamradio
-MASTER_SITES= SF/groundstation/Grig/${PORTVERSION}
MAINTAINER= hamradio@FreeBSD.org
COMMENT= Amateur Radio control front-end
@@ -11,16 +11,20 @@ COMMENT= Amateur Radio control front-end
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libhamlib.so:comms/hamlib
+USE_GITHUB= yes
+GH_ACCOUNT= fillods
+GH_PROJECT= grig
+GH_TAGNAME= 77ab785
-USE_GNOME= gtk20 intltool
+LIB_DEPENDS= libhamlib.so:comms/hamlib \
+ libharfbuzz.so:print/harfbuzz \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
+USE_GNOME= cairo gdkpixbuf2 gtk20 intltool
GNU_CONFIGURE= yes
-USES= gettext gmake gnome pkgconfig
+USES= autoreconf gettext gmake gnome libtool pkgconfig
LIBS+= -lm
-post-patch:
- @${FIND} ${WRKSRC} -name Makefile.* | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-D.*_DISABLE_DEPRECATED||g'
-
.include <bsd.port.mk>