summaryrefslogtreecommitdiff
path: root/cad/geda-gattrib
diff options
context:
space:
mode:
Diffstat (limited to 'cad/geda-gattrib')
-rw-r--r--cad/geda-gattrib/Makefile49
-rw-r--r--cad/geda-gattrib/distinfo2
-rw-r--r--cad/geda-gattrib/files/patch-icon-theme-installer17
-rw-r--r--cad/geda-gattrib/files/patch-src_gtkitementry_2_2.c28
-rw-r--r--cad/geda-gattrib/pkg-descr3
-rw-r--r--cad/geda-gattrib/pkg-plist9
6 files changed, 0 insertions, 108 deletions
diff --git a/cad/geda-gattrib/Makefile b/cad/geda-gattrib/Makefile
deleted file mode 100644
index ca439d825f64..000000000000
--- a/cad/geda-gattrib/Makefile
+++ /dev/null
@@ -1,49 +0,0 @@
-# Created by: Stanislav Sedov <ssedov@mbsd.msk.ru>
-# $FreeBSD$
-
-PORTNAME= gattrib
-PORTVERSION= 1.4.3
-PORTREVISION= 8
-PORTEPOCH= 1
-CATEGORIES= cad
-MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/release/v1.4/${PORTVERSION}/ \
- http://geda.seul.org/release/v1.4/${PORTVERSION}/
-PKGNAMEPREFIX= geda-
-DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= The gEDA's attribute editor
-
-BROKEN= Unfetchable
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2015-11-26
-RUN_DEPENDS= geda-symbols>0:${PORTSDIR}/cad/geda-symbols
-LIB_DEPENDS= libgeda.so:${PORTSDIR}/cad/libgeda
-
-DATADIR= ${PREFIX}/share/geda
-DOCSDIR= ${PREFIX}/share/doc/geda
-
-GNU_CONFIGURE= yes
-USES= desktop-file-utils gmake pkgconfig
-USE_GNOME= gtk20 glib20
-INSTALLS_ICONS= yes
-CONFIGURE_ARGS= --with-docdir="${DOCSDIR}" --disable-update-mime-database \
- --disable-update-desktop-database
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-OPTIONS_DEFINE= NLS
-OPTIONS_SUB= yes
-
-NLS_USES= gettext
-NLS_CONFIGURE_ENABLE= nls
-
-post-patch:
- @${REINPLACE_CMD} -E \
- -e "s,^(DATADIR[[:space:]]*=[[:space:]]*)gEDA,\1geda," \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|>n_bytes|>x_n_bytes|g' \
- -e 's|>text_size|>x_text_size|g' \
- ${WRKSRC}/src/gtkitementry_2_2.c
-
-.include <bsd.port.mk>
diff --git a/cad/geda-gattrib/distinfo b/cad/geda-gattrib/distinfo
deleted file mode 100644
index af7d3e9f1f3c..000000000000
--- a/cad/geda-gattrib/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (geda-gattrib-1.4.3.tar.gz) = 5eb48772d374dad446bfcd69990231fa6c6b52ba9b30048991632557512a7565
-SIZE (geda-gattrib-1.4.3.tar.gz) = 326641
diff --git a/cad/geda-gattrib/files/patch-icon-theme-installer b/cad/geda-gattrib/files/patch-icon-theme-installer
deleted file mode 100644
index 05a9bbec789c..000000000000
--- a/cad/geda-gattrib/files/patch-icon-theme-installer
+++ /dev/null
@@ -1,17 +0,0 @@
---- icon-theme-installer.orig 2009-01-28 18:58:56.000000000 +0100
-+++ icon-theme-installer 2009-01-28 18:59:24.000000000 +0100
-@@ -108,10 +108,10 @@
- exit 1
- fi
-
--if test ! -x `echo "$INSTALL_DATA_EXEC" | cut -f1 -d' '`; then
-- echo "Cannot find '$INSTALL_DATA_EXEC'; You probably want to pass -x \$(INSTALL_DATA)"
-- exit 1
--fi
-+#if test ! -x `echo "$INSTALL_DATA_EXEC" | cut -f1 -d' '`; then
-+# echo "Cannot find '$INSTALL_DATA_EXEC'; You probably want to pass -x \$(INSTALL_DATA)"
-+# exit 1
-+#fi
-
- if test -z "$SRC_DIR"; then
- SRC_DIR=.
diff --git a/cad/geda-gattrib/files/patch-src_gtkitementry_2_2.c b/cad/geda-gattrib/files/patch-src_gtkitementry_2_2.c
deleted file mode 100644
index 29d2ae56b635..000000000000
--- a/cad/geda-gattrib/files/patch-src_gtkitementry_2_2.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/gtkitementry_2_2.c.orig 2010-10-29 19:10:42.000000000 +0200
-+++ src/gtkitementry_2_2.c 2010-10-29 19:11:29.000000000 +0200
-@@ -156,7 +156,7 @@ static void gtk_entry_draw_curso
- static PangoLayout *gtk_entry_ensure_layout (GtkEntry *entry,
- gboolean include_preedit);
- static void gtk_entry_queue_draw (GtkEntry *entry);
--static void gtk_entry_reset_im_context (GtkEntry *entry);
-+//static void gtk_entry_reset_im_context (GtkEntry *entry);
- static void gtk_entry_recompute (GtkEntry *entry);
- static void gtk_entry_get_cursor_locations (GtkEntry *entry,
- CursorType type,
-@@ -1830,16 +1830,6 @@ gtk_entry_queue_draw (GtkEntry *entry)
- }
-
- static void
--gtk_entry_reset_im_context (GtkEntry *entry)
--{
-- if (entry->need_im_reset)
-- {
-- entry->need_im_reset = 0;
-- gtk_im_context_reset (entry->im_context);
-- }
--}
--
--static void
- gtk_entry_get_cursor_locations (GtkEntry *entry,
- CursorType type,
- gint *strong_x,
diff --git a/cad/geda-gattrib/pkg-descr b/cad/geda-gattrib/pkg-descr
deleted file mode 100644
index 6e183204d3dc..000000000000
--- a/cad/geda-gattrib/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-Gattrib is gEDA's attribute editor.
-
-WWW: http://www.geda.seul.org
diff --git a/cad/geda-gattrib/pkg-plist b/cad/geda-gattrib/pkg-plist
deleted file mode 100644
index 649221e25e54..000000000000
--- a/cad/geda-gattrib/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-bin/gattrib
-%%NLS%%lib/locale/de_DE/LC_MESSAGES/geda-gattrib.mo
-%%NLS%%lib/locale/es_ES/LC_MESSAGES/geda-gattrib.mo
-%%NLS%%lib/locale/nl_NL/LC_MESSAGES/geda-gattrib.mo
-share/applications/geda-gattrib.desktop
-%%DATADIR%%/gattrib-menus.xml
-%%DATADIR%%/system-gattribrc
-share/icons/hicolor/48x48/apps/geda-gattrib-48.png
-share/icons/hicolor/scalable/apps/geda-gattrib.svg