summaryrefslogtreecommitdiff
path: root/audio/xmms-mailnotify/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/xmms-mailnotify/Makefile')
-rw-r--r--audio/xmms-mailnotify/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/audio/xmms-mailnotify/Makefile b/audio/xmms-mailnotify/Makefile
index 44d8102ffe10..6b5f543ab159 100644
--- a/audio/xmms-mailnotify/Makefile
+++ b/audio/xmms-mailnotify/Makefile
@@ -6,7 +6,7 @@
PORTNAME= xmms-mailnotify
PORTVERSION= 0.2.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= arved
@@ -17,12 +17,15 @@ COMMENT= XMMS plugin, that plays a sound on incoming mail and opens the MUA
LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
USE_X_PREFIX= yes
-USE_AUTOTOOLS= libtool:13
+GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gtk12
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
+PLIST_FILES= lib/xmms/General/libmailnotify.so \
+ lib/xmms/General/alert.wav
+
post-patch:
${REINPLACE_CMD} -e "s,/usr/lib,${X11BASE}/lib," ${WRKSRC}/mailnotify.c