summaryrefslogtreecommitdiff
path: root/audio/pulseaudio/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/pulseaudio/Makefile')
-rw-r--r--audio/pulseaudio/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/audio/pulseaudio/Makefile b/audio/pulseaudio/Makefile
index 7471af1e22ee..6064209564c2 100644
--- a/audio/pulseaudio/Makefile
+++ b/audio/pulseaudio/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/audio/pulseaudio/Makefile,v 1.2 2009/04/18 19:59:03 marcus Exp $
+# $MCom: ports-stable/audio/pulseaudio/Makefile,v 1.5 2009/07/20 21:26:40 marcus Exp $
#
PORTNAME= pulseaudio
-PORTVERSION= 0.9.14
-PORTREVISION= 7
+PORTVERSION= 0.9.15
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://0pointer.de/lennart/projects/${PORTNAME}/
@@ -19,20 +19,23 @@ LIB_DEPENDS= samplerate.1:${PORTSDIR}/audio/libsamplerate \
oil-0.3.0:${PORTSDIR}/devel/liboil \
speexdsp.1:${PORTSDIR}/audio/speex \
dbus-1.3:${PORTSDIR}/devel/dbus \
- gdbm.3:${PORTSDIR}/databases/gdbm
+ gdbm.3:${PORTSDIR}/databases/gdbm \
+ execinfo:${PORTSDIR}/devel/libexecinfo
USE_GNOME= gnometarget gnomehack glib20 intltool ltverhack
-USE_XORG= x11 sm
+USE_XORG= x11 sm xtst ice
USE_LDCONFIG= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libltdl:15 libtool:15
+USE_AUTOTOOLS= libltdl:22 libtool:22
USE_GMAKE= yes
MAKE_JOBS_UNSAFE=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ OPENSSL_CFLAGS="-I/usr/include" \
+ OPENSSL_LIBS="-lcrypto -lssl" \
LIBS="-lm -lintl"
CONFIGURE_ARGS= --localstatedir=/var \
@@ -43,7 +46,7 @@ OPTIONS= JACK "JACK audio support" Off \
HAL "Enable HAL support" On \
GCONF "Enable GConf support" On
-PULSE_VERSION= ${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+PULSE_VERSION= ${PORTVERSION}
PLIST_SUB= PULSE_VERSION=${PULSE_VERSION}
MAN1= esdcompat.1 pabrowse.1 pacat.1 pacmd.1 pactl.1 padsp.1 \