summaryrefslogtreecommitdiff
path: root/audio/gnomoradio/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/gnomoradio/Makefile')
-rw-r--r--audio/gnomoradio/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/audio/gnomoradio/Makefile b/audio/gnomoradio/Makefile
index ab94e11a7ab1..ae490157ec8e 100644
--- a/audio/gnomoradio/Makefile
+++ b/audio/gnomoradio/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnomoradio
PORTVERSION= 0.15.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio net
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -27,7 +27,8 @@ USE_GCC= 3.4+
USE_GNOME= gnomehack gnomeprefix
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:15
+LIBTOOLFLAGS= --tag=CXX
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -36,11 +37,4 @@ post-patch:
s|-lpthread|${PTHREAD_LIBS}|' \
${WRKSRC}/roboradio/mp3/Makefile.in
-patch-autotools::
- @for file in ${LIBTOOLFILES}; do \
- ${REINPLACE_CMD} -e \
- '/^ltmain=/ s|$$ac_aux_dir/ltmain\.sh|${LTMAIN}|g' \
- ${PATCH_WRKSRC}/$$file; \
- done
-
.include <bsd.port.mk>