summaryrefslogtreecommitdiff
path: root/astro/xplanet
diff options
context:
space:
mode:
Diffstat (limited to 'astro/xplanet')
-rw-r--r--astro/xplanet/Makefile60
-rw-r--r--astro/xplanet/distinfo4
2 files changed, 47 insertions, 17 deletions
diff --git a/astro/xplanet/Makefile b/astro/xplanet/Makefile
index 52c7f07911b6..ad04899b731c 100644
--- a/astro/xplanet/Makefile
+++ b/astro/xplanet/Makefile
@@ -6,35 +6,65 @@
#
PORTNAME= xplanet
-PORTVERSION= 1.0.4
-PORTREVISION= 0
+PORTVERSION= 1.1.0
CATEGORIES= astro
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bogorodskiy@inbox.ru
COMMENT= Draw pictures of the earth textured by an image
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- freetype.9:${PORTSDIR}/print/freetype2 \
- ungif.5:${PORTSDIR}/graphics/libungif \
- png.5:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- netpbm.1:${PORTSDIR}/graphics/netpbm
-
USE_X_PREFIX= yes
-USE_GNOME= pango
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-map-extension=jpg --with-freetype --with-gif \
- --with-png --with-pnm --with-tiff --with-pango
+CONFIGURE_ARGS= --with-map-extension=jpg
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm"
-USE_GMAKE= yes
PLIST_FILES= bin/xplanet
MAN1= xplanet.1
-# Install the list of FreeBSD sites & committers locations from astro/xearth
+.if !defined(WITHOUT_FREETYPE)
+CONFIGURE_ARGS+= --with-freetype
+LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+.else
+CONFIGURE_ARGS+= --without-freetype
+.endif
+
+.if !defined(WITHOUT_PANGO)
+CONFIGURE_ARGS+= --with-pango
+USE_GNOME+= pango
+.else
+CONFIGURE_ARGS+= --without-pango
+.endif
+
+.if !defined(WITHOUT_GIF)
+CONFIGURE_ARGS+= --with-gif
+LIB_DEPENDS+= ungif.5:${PORTSDIR}/graphics/libungif
+.else
+CONFIGURE_ARGS+= --without-gif
+.endif
+
+.if !defined(WITHOUT_JPEG)
+CONFIGURE_ARGS+= --with-jpeg
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
+.else
+CONFIGURE_ARGS+= --without-jpeg
+.endif
+
+.if !defined(WITHOUT_PNG)
+CONFIGURE_ARGS+= --with-png
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+.else
+CONFIGURE_ARGS+= --without-png
+.endif
+
+.if !defined(WITH_TIFF)
+CONFIGURE_ARGS+= --with-tiff
+LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
+.else
+CONFIGURE_ARGS+= --without-tiff
+.endif
+
post-install:
.for file in freebsd.committers.markers freebsd.ftp.markers
@${INSTALL_DATA} ${PORTSDIR}/astro/xearth/files/${file} \
diff --git a/astro/xplanet/distinfo b/astro/xplanet/distinfo
index 3e6075a10984..a077430a065e 100644
--- a/astro/xplanet/distinfo
+++ b/astro/xplanet/distinfo
@@ -1,2 +1,2 @@
-MD5 (xplanet-1.0.4.tar.gz) = 8a6ca80b2d73c299622377e9af4ecfa2
-SIZE (xplanet-1.0.4.tar.gz) = 1148980
+MD5 (xplanet-1.1.0.tar.gz) = 7fdf32f759ae401471e7d820ed3d7051
+SIZE (xplanet-1.1.0.tar.gz) = 1176025