summaryrefslogtreecommitdiff
path: root/astro/marble/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/marble/Makefile')
-rw-r--r--astro/marble/Makefile35
1 files changed, 23 insertions, 12 deletions
diff --git a/astro/marble/Makefile b/astro/marble/Makefile
index f95ef669831e..f11434898e7b 100644
--- a/astro/marble/Makefile
+++ b/astro/marble/Makefile
@@ -10,25 +10,36 @@ PORTVERSION= ${KDE4_VERSION}
CATEGORIES= astro kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
-DISTNAME= kdeedu-${PORTVERSION}
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Virtual globe and world atlas for KDE
-LIB_DEPENDS= gps.20:${PORTSDIR}/astro/gpsd
+CONFLICTS= kdeedu-4.4.[0-4]
-CONFLICTS= kdeedu-4.5.[0-5]
-
-USE_BZIP2= yes
-USE_CMAKE= yes
-USE_KDE4= kdelibs kdeprefix kdehier automoc4
+USE_KDE4= kdehier kdelibs kdeprefix automoc4
+KDE4_BUILDENV= yes
USE_QT_VER= 4
-QT_COMPONENTS= qmake_build moc_build rcc_build uic_build
-USE_LDCONFIG= yes
-DISTINFO_FILE= ${PORTSDIR}/misc/kdeedu4/distinfo
+QT_COMPONENTS= dbus declarative gui network \
+ phonon script sql svg webkit xml \
+ qmake_build moc_build rcc_build uic_build
+USE_BZIP2= yes
+MAKE_JOBS_SAFE= yes
+
+OPTIONS= GPS "Support for GPS position provider" on
+
+.include <bsd.port.options.mk>
+
+.ifndef(WITHOUT_GPS)
+LIB_DEPENDS+= gps.20:${PORTSDIR}/astro/gpsd
+PLIST_SUB+= GPS=""
+.else
+CMAKE_ARGS+= -DWITH_libgps:BOOL=FALSE
+PLIST_SUB+= GPS="@comment "
+.endif
-WRKSRC= ${WRKDIR}/${DISTNAME}/marble
-CMAKE_OUTSOURCE= yes
+pre-configure:
+ ${REINPLACE_CMD} -e '/libgps/ s/FIND_PACKAGE/macro_optional_find_package/' \
+ ${WRKSRC}/src/plugins/positionprovider/CMakeLists.txt
.include <bsd.port.mk>