summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-asset_sync/Makefile23
-rw-r--r--net/rubygem-asset_sync/distinfo3
-rw-r--r--net/rubygem-asset_sync/pkg-descr9
4 files changed, 36 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index a5e7e43e1bf9..4154ce433843 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1151,6 +1151,7 @@
SUBDIR += rubygem-amq-protocol
SUBDIR += rubygem-amqp
SUBDIR += rubygem-amqp-utils
+ SUBDIR += rubygem-asset_sync
SUBDIR += rubygem-aws-s3
SUBDIR += rubygem-aws-ses
SUBDIR += rubygem-azure
diff --git a/net/rubygem-asset_sync/Makefile b/net/rubygem-asset_sync/Makefile
new file mode 100644
index 000000000000..ad353bc35c41
--- /dev/null
+++ b/net/rubygem-asset_sync/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= asset_sync
+PORTVERSION= 2.3.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Synchronizes Assets between Rails and S3
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-activemodel4>=4.1.0:databases/rubygem-activemodel4 \
+ rubygem-fog-core>=0:devel/rubygem-fog-core \
+ rubygem-mime-types>=2.99:misc/rubygem-mime-types \
+ rubygem-unf>=0:textproc/rubygem-unf
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-asset_sync/distinfo b/net/rubygem-asset_sync/distinfo
new file mode 100644
index 000000000000..ca33f6d50f99
--- /dev/null
+++ b/net/rubygem-asset_sync/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1513512123
+SHA256 (rubygem/asset_sync-2.3.0.gem) = 83dac5412bd66e7f8f4599a1f87ede356ad13763b82323bec4b82843a3a1b690
+SIZE (rubygem/asset_sync-2.3.0.gem) = 35328
diff --git a/net/rubygem-asset_sync/pkg-descr b/net/rubygem-asset_sync/pkg-descr
new file mode 100644
index 000000000000..e45398c2742a
--- /dev/null
+++ b/net/rubygem-asset_sync/pkg-descr
@@ -0,0 +1,9 @@
+Asset Sync is built to run with the new Rails Asset Pipeline feature introduced
+in Rails 3.1. After you run bundle exec rake assets:precompile your assets will
+be synchronised to your S3 bucket, optionally deleting unused files and only
+uploading the files it needs to.
+
+This was initially built and is intended to work on Heroku but can work on any
+platform.
+
+WWW: https://github.com/AssetSync/asset_sync