summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/Uses/qt-dist.mk11
-rw-r--r--comms/qt5-serialbus/Makefile2
-rw-r--r--devel/qt5-assistant/Makefile2
-rw-r--r--devel/qt5-buildtools/Makefile2
-rw-r--r--devel/qt5-core/Makefile2
-rw-r--r--devel/qt5-dbus/Makefile2
-rw-r--r--devel/qt5-designer/Makefile3
-rw-r--r--devel/qt5-help/Makefile3
-rw-r--r--devel/qt5-linguist/Makefile3
-rw-r--r--devel/qt5-linguisttools/Makefile3
-rw-r--r--devel/qt5-qdbus/Makefile3
-rw-r--r--devel/qt5-qdbusviewer/Makefile3
-rw-r--r--devel/qt5-qdoc/Makefile3
-rw-r--r--devel/qt5-qmake/Makefile4
-rw-r--r--devel/qt5-remoteobjects/Makefile3
-rw-r--r--devel/qt5-scxml/Makefile3
-rw-r--r--graphics/qt5-3d/Makefile3
-rw-r--r--graphics/qt5-pixeltool/Makefile3
-rw-r--r--graphics/qt5-wayland/Makefile3
-rw-r--r--misc/qtchooser/Makefile8
-rw-r--r--misc/qtchooser/files/patch-Makefile8
-rw-r--r--misc/qtchooser/files/update-qtchooser-wrapper.in70
-rw-r--r--misc/qtchooser/pkg-plist47
-rw-r--r--sysutils/qt5-qtdiag/Makefile3
-rw-r--r--sysutils/qt5-qtpaths/Makefile3
-rw-r--r--sysutils/qt5-qtplugininfo/Makefile3
-rw-r--r--textproc/qt5-xmlpatterns/Makefile3
-rw-r--r--www/qt5-webengine/Makefile4
-rw-r--r--x11-toolkits/qt5-declarative/Makefile2
-rw-r--r--x11-toolkits/qt5-gui/Makefile3
-rw-r--r--x11-toolkits/qt5-widgets/Makefile2
-rw-r--r--x11/qt5-qev/Makefile3
32 files changed, 169 insertions, 51 deletions
diff --git a/Mk/Uses/qt-dist.mk b/Mk/Uses/qt-dist.mk
index f0eba8a853af..ca83c34a1f65 100644
--- a/Mk/Uses/qt-dist.mk
+++ b/Mk/Uses/qt-dist.mk
@@ -384,4 +384,15 @@ qt-post-install:
. endif # ${QT_CONFIG:N-*}
. endif # M5
+# Handle misc/qtchooser wrapper installation and deinstallation
+# If a port installs Qt version-specific binaries (e.g. "designer" which existed as a Qt4 application
+# and exists as a Qt5 application and will probably be a Qt6 application) which should have a
+# qtchooser-based wrapper, the port should set `QT_BINARIES=yes`.
+#
+# When QT_BINARIES is set to yes, compatibility symlinks (designer -> qtchooser, so that
+# qtchooser can run designer-qt5 or whatever is the selected Qt version) are installed by the port.
+. if defined(QT_BINARIES)
+ ${ECHO_CMD} '@postexec if type update-qtchooser-wrapper >/dev/null 2>&1; then update-qtchooser-wrapper; fi' >> ${TMPPLIST}
+ ${ECHO_CMD} '@postunexec if type update-qtchooser-wrapper >/dev/null 2>&1; then update-qtchooser-wrapper; fi' >> ${TMPPLIST}
+. endif
.endif # defined(_QT_DIST_MK_INCLUDED)
diff --git a/comms/qt5-serialbus/Makefile b/comms/qt5-serialbus/Makefile
index aeccbf4933ae..c95fda8eb6d3 100644
--- a/comms/qt5-serialbus/Makefile
+++ b/comms/qt5-serialbus/Makefile
@@ -2,6 +2,7 @@
PORTNAME= serialbus
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= comms
PKGNAMEPREFIX= qt5-
@@ -11,5 +12,6 @@ COMMENT= Qt functions to access industrial bus systems
USES= compiler:c++11-lib qmake qt-dist:5,serialbus
USE_QT= core network serialport buildtools_build
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+QT_BINARIES= yes
.include <bsd.port.mk>
diff --git a/devel/qt5-assistant/Makefile b/devel/qt5-assistant/Makefile
index f4c9bd227208..10e49283964d 100644
--- a/devel/qt5-assistant/Makefile
+++ b/devel/qt5-assistant/Makefile
@@ -2,6 +2,7 @@
PORTNAME= assistant
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= qt5-
@@ -11,6 +12,7 @@ COMMENT= Qt 5 documentation browser
USES= compiler:c++11-lang qmake qt-dist:5,tools
USE_QT= core gui help network printsupport sql widgets \
buildtools_build sql-sqlite3_run
+QT_BINARIES= yes
DESKTOP_ENTRIES="Qt 5 Assistant" "" \
"${PREFIX}/share/pixmaps/assistant-qt5.png" \
diff --git a/devel/qt5-buildtools/Makefile b/devel/qt5-buildtools/Makefile
index ab86eed4f1f4..f8d2ad33231b 100644
--- a/devel/qt5-buildtools/Makefile
+++ b/devel/qt5-buildtools/Makefile
@@ -2,6 +2,7 @@
PORTNAME= buildtools
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= qt5-
@@ -12,6 +13,7 @@ USES= compiler:c++11-lang libtool perl5 qmake:no_env qt-dist:5,base
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -no-gui -no-xcb
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+QT_BINARIES= yes
BUILD_WRKSRC= ${WRKSRC}/src/tools/bootstrap
INSTALL_WRKSRC= ${BUILD_WRKSRC}
diff --git a/devel/qt5-core/Makefile b/devel/qt5-core/Makefile
index eec2232059e2..ed69e926ded6 100644
--- a/devel/qt5-core/Makefile
+++ b/devel/qt5-core/Makefile
@@ -2,6 +2,7 @@
PORTNAME= core
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= qt5-
@@ -30,6 +31,7 @@ USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
BUILD_WRKSRC= ${WRKSRC}/src/corelib
INSTALL_WRKSRC= ${BUILD_WRKSRC}
+QT_BINARIES= yes
QT_DEFINES= GLIB
QT_CONFIG= glib icu
diff --git a/devel/qt5-dbus/Makefile b/devel/qt5-dbus/Makefile
index bb1b65531d34..0cba695587be 100644
--- a/devel/qt5-dbus/Makefile
+++ b/devel/qt5-dbus/Makefile
@@ -2,6 +2,7 @@
PORTNAME= dbus
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= qt5-
@@ -21,6 +22,7 @@ INSTALL_WRKSRC= ${BUILD_WRKSRC}
TOOLS= qdbuscpp2xml qdbusxml2cpp
+QT_BINARIES= yes
QT_DEFINES= DBUS
QT_CONFIG= dbus
diff --git a/devel/qt5-designer/Makefile b/devel/qt5-designer/Makefile
index 098bf1efac76..94161a32f09b 100644
--- a/devel/qt5-designer/Makefile
+++ b/devel/qt5-designer/Makefile
@@ -2,6 +2,7 @@
PORTNAME= designer
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= qt5-
@@ -21,6 +22,8 @@ DESKTOP_ENTRIES="Qt 5 Designer" "" \
BUILD_WRKSRC= ${WRKSRC}/src/${PORTNAME}
INSTALL_WRKSRC= ${WRKSRC}/src/${PORTNAME}
+QT_BINARIES= yes
+
OPTIONS_DEFINE= WEBKIT
OPTIONS_SUB= yes
WEBKIT_DESC= Build WebKit-based WebView widget
diff --git a/devel/qt5-help/Makefile b/devel/qt5-help/Makefile
index 6b05aab6cc33..f3458182265a 100644
--- a/devel/qt5-help/Makefile
+++ b/devel/qt5-help/Makefile
@@ -2,6 +2,7 @@
PORTNAME= help
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= qt5-
@@ -16,4 +17,6 @@ USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
BUILD_WRKSRC= ${WRKSRC}/src/assistant
INSTALL_WRKSRC= ${WRKSRC}/src/assistant
+QT_BINARIES= yes
+
.include <bsd.port.mk>
diff --git a/devel/qt5-linguist/Makefile b/devel/qt5-linguist/Makefile
index b774755429ef..bf194fd40f27 100644
--- a/devel/qt5-linguist/Makefile
+++ b/devel/qt5-linguist/Makefile
@@ -2,6 +2,7 @@
PORTNAME= linguist
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= qt5-
@@ -21,6 +22,8 @@ DESKTOP_ENTRIES="Qt 5 Linguist" "" \
BUILD_WRKSRC= ${WRKSRC}/src/${PORTNAME}/${PORTNAME}
INSTALL_WRKSRC= ${WRKSRC}/src/${PORTNAME}/${PORTNAME}
+QT_BINARIES= yes
+
post-install:
${INSTALL_DATA} ${BUILD_WRKSRC}/images/icons/linguist-128-32.png \
${STAGEDIR}${PREFIX}/share/pixmaps/linguist-qt5.png
diff --git a/devel/qt5-linguisttools/Makefile b/devel/qt5-linguisttools/Makefile
index dd095a8ee2f6..de25686cd0fb 100644
--- a/devel/qt5-linguisttools/Makefile
+++ b/devel/qt5-linguisttools/Makefile
@@ -2,6 +2,7 @@
PORTNAME= linguisttools
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= qt5-
@@ -14,6 +15,8 @@ USE_QT= core xml buildtools_build declarative_build
BUILD_WRKSRC= ${WRKSRC}/src/linguist
INSTALL_WRKSRC= ${WRKSRC}/src/linguist
+QT_BINARIES= yes
+
post-patch:
@${REINPLACE_CMD} -e '/SUBDIRS.*linguist/ d' \
${WRKSRC}/src/linguist/linguist.pro
diff --git a/devel/qt5-qdbus/Makefile b/devel/qt5-qdbus/Makefile
index 1f43f0470b62..2d6f5c485280 100644
--- a/devel/qt5-qdbus/Makefile
+++ b/devel/qt5-qdbus/Makefile
@@ -2,6 +2,7 @@
PORTNAME= qdbus
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= qt5-
@@ -14,4 +15,6 @@ USE_QT= core dbus xml buildtools_build
BUILD_WRKSRC= ${WRKSRC}/src/${PORTNAME}/${PORTNAME}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
+QT_BINARIES= yes
+
.include <bsd.port.mk>
diff --git a/devel/qt5-qdbusviewer/Makefile b/devel/qt5-qdbusviewer/Makefile
index 4e85a308e30b..27aea7d88d5c 100644
--- a/devel/qt5-qdbusviewer/Makefile
+++ b/devel/qt5-qdbusviewer/Makefile
@@ -2,6 +2,7 @@
PORTNAME= qdbusviewer
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= qt5-
@@ -19,6 +20,8 @@ DESKTOP_ENTRIES="Qt 5 D-Bus Viewer" "" \
BUILD_WRKSRC= ${WRKSRC}/src/qdbus/${PORTNAME}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
+QT_BINARIES= yes
+
post-install:
${INSTALL_DATA} ${BUILD_WRKSRC}/images/qdbusviewer-128.png \
${STAGEDIR}${PREFIX}/share/pixmaps/qdbusviewer-qt5.png
diff --git a/devel/qt5-qdoc/Makefile b/devel/qt5-qdoc/Makefile
index 3199162c3e0e..27c7fe85e1ab 100644
--- a/devel/qt5-qdoc/Makefile
+++ b/devel/qt5-qdoc/Makefile
@@ -2,6 +2,7 @@
PORTNAME= qdoc
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= devel textproc
PKGNAMEPREFIX= qt5-
@@ -21,4 +22,6 @@ PLIST_FILES= ${QT_BINDIR}/qdoc
CONFIGURE_ENV= LLVM_INSTALL_DIR=${LOCALBASE}/llvm${LLVM_DEFAULT}
+QT_BINARIES= yes
+
.include <bsd.port.mk>
diff --git a/devel/qt5-qmake/Makefile b/devel/qt5-qmake/Makefile
index f8e87e1a0142..ed2ab76489c9 100644
--- a/devel/qt5-qmake/Makefile
+++ b/devel/qt5-qmake/Makefile
@@ -2,7 +2,7 @@
PORTNAME= qmake
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
PKGNAMEPREFIX= qt5-
@@ -33,6 +33,8 @@ INSTALL_TARGET= sub-qmake-qmake-aux-pro-install_subtargets install_mkspecs
BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+QT_BINARIES= yes
+
post-patch:
# Clean up files created by patching
@${RM} ${WRKSRC}/mkspecs/*/*.orig
diff --git a/devel/qt5-remoteobjects/Makefile b/devel/qt5-remoteobjects/Makefile
index 474cf7d97554..cd70598981d5 100644
--- a/devel/qt5-remoteobjects/Makefile
+++ b/devel/qt5-remoteobjects/Makefile
@@ -2,6 +2,7 @@
PORTNAME= remoteobjects
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= qt5-
@@ -14,4 +15,6 @@ USE_QT= core declarative network \
buildtools_build
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+QT_BINARIES= yes
+
.include <bsd.port.mk>
diff --git a/devel/qt5-scxml/Makefile b/devel/qt5-scxml/Makefile
index d994bca6eaaf..477e5302926d 100644
--- a/devel/qt5-scxml/Makefile
+++ b/devel/qt5-scxml/Makefile
@@ -2,6 +2,7 @@
PORTNAME= scxml
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= qt5-
@@ -12,4 +13,6 @@ USES= compiler:c++11-lang qmake qt-dist:5,scxml
USE_QT= core declarative network buildtools_build
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+QT_BINARIES= yes
+
.include <bsd.port.mk>
diff --git a/graphics/qt5-3d/Makefile b/graphics/qt5-3d/Makefile
index 641f22665d44..9c5be13dcf29 100644
--- a/graphics/qt5-3d/Makefile
+++ b/graphics/qt5-3d/Makefile
@@ -2,6 +2,7 @@
PORTNAME= 3d
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics
PKGNAMEPREFIX= qt5-
@@ -15,4 +16,6 @@ USE_QT= concurrent core declarative gui network buildtools_build
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+QT_BINARIES= yes
+
.include <bsd.port.mk>
diff --git a/graphics/qt5-pixeltool/Makefile b/graphics/qt5-pixeltool/Makefile
index a2fccc06154f..697e82ece20b 100644
--- a/graphics/qt5-pixeltool/Makefile
+++ b/graphics/qt5-pixeltool/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pixeltool
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics
PKGNAMEPREFIX= qt5-
@@ -20,4 +21,6 @@ DESKTOP_ENTRIES="Qt 5 PixelTool" "" \
BUILD_WRKSRC= ${WRKSRC}/src/${PORTNAME}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
+QT_BINARIES= yes
+
.include <bsd.port.mk>
diff --git a/graphics/qt5-wayland/Makefile b/graphics/qt5-wayland/Makefile
index 68265edbb5af..c06531485d74 100644
--- a/graphics/qt5-wayland/Makefile
+++ b/graphics/qt5-wayland/Makefile
@@ -2,6 +2,7 @@
PORTNAME= wayland
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics
PKGNAMEPREFIX= qt5-
@@ -23,4 +24,6 @@ USE_XORG= x11 xcomposite
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+QT_BINARIES= yes
+
.include <bsd.port.mk>
diff --git a/misc/qtchooser/Makefile b/misc/qtchooser/Makefile
index 042f6bbc8432..169cbd4799b4 100644
--- a/misc/qtchooser/Makefile
+++ b/misc/qtchooser/Makefile
@@ -2,6 +2,7 @@
PORTNAME= qtchooser
PORTVERSION= 66
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= QT/official_releases/${PORTNAME}
DIST_SUBDIR= KDE/Qt/qtchooser
@@ -16,6 +17,10 @@ USES= gmake tar:xz
DESTDIRNAME= INSTALL_ROOT
MAKE_ARGS= prefix=${PREFIX}
+SUB_FILES= update-qtchooser-wrapper
+# Keep this synchronized with qt.mk
+SUB_LIST= QT_SUPPORTED="5"
+
# bin/linguist
CONFLICTS_INSTALL= rubygem-github-linguist rubygem-github-linguist47 rubygem-gitlab-linguist
@@ -44,5 +49,8 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/qtchooser.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
# Create the default profile.
cd ${STAGEDIR}/${QT_QTCHOOSERDIR} && ${LN} -s qt5.conf default.conf
+ ${INSTALL_SCRIPT} ${WRKDIR}/update-qtchooser-wrapper \
+ ${STAGEDIR}${PREFIX}/bin/update-qtchooser-wrapper
+
.include <bsd.port.mk>
diff --git a/misc/qtchooser/files/patch-Makefile b/misc/qtchooser/files/patch-Makefile
index ff4b4122590c..d7e61cc17d58 100644
--- a/misc/qtchooser/files/patch-Makefile
+++ b/misc/qtchooser/files/patch-Makefile
@@ -1,6 +1,10 @@
---- Makefile.orig 2018-10-08 18:18:42 UTC
+--- Makefile.orig 2018-05-04 07:41:32 UTC
+++ Makefile
-@@ -70,8 +70,8 @@ install:
+@@ -66,12 +66,11 @@ distclean:
+
+ install:
+ cd src/qtchooser && $(MAKE) install
+- for tool in $(TOOLS); do ln -sf qtchooser "$(INSTALL_ROOT)$(bindir)/$$tool"; done
case `uname -s` in Darwin) \
for tool in $(MACTOOLS); do ln -sf qtchooser "$(INSTALL_ROOT)$(bindir)/$$tool"; done \
;; esac
diff --git a/misc/qtchooser/files/update-qtchooser-wrapper.in b/misc/qtchooser/files/update-qtchooser-wrapper.in
new file mode 100644
index 000000000000..0436cd2da2bb
--- /dev/null
+++ b/misc/qtchooser/files/update-qtchooser-wrapper.in
@@ -0,0 +1,70 @@
+#!/bin/sh
+
+# $FreeBSD$
+
+# If a port installs Qt version-specific binaries (e.g. "designer" which existed as a Qt4 application
+# and exists as a Qt5 application and will probably be a Qt6 application) which should have a
+# qtchooser-based wrapper, the port should set `QT_BINARIES=yes`.
+#
+# When QT_BINARIES is set to yes, compatibility symlinks (designer -> qtchooser, so that
+# qtchooser can run designer-qt5 or whatever is the selected Qt version) are installed by the port.
+
+PREFIX=%%PREFIX%%
+BINDIR=${PREFIX}/bin
+QTCHOOSER=${BINDIR}/qtchooser
+VERSIONS=%%QT_SUPPORTED%%
+
+if [ ! -d ${BINDIR} ] ; then
+ echo "Binary directory '${BINDIR}' missing." >&2
+ exit 1
+fi
+
+if [ ! -x ${QTCHOOSER} ] ; then
+ echo "Qtchooser binary '${QTCHOOSER}' missing." >&2
+ exit 2
+fi
+
+remove_links() {
+ echo "Removing qtchooser links"
+ for file in $(find -L ${BINDIR} -maxdepth 1 -samefile ${QTCHOOSER}) ; do
+ if [ ! -L ${file} ] ; then
+ continue
+ fi
+ # If at least one versioned executable is found for this name, keep the
+ # qtchooser compatibility symlink for this name; otherwise, remove it.
+ local found=0
+ for version in ${VERSIONS} ; do
+ version_bin_dir=${PREFIX}/lib/qt${version}/bin
+ target=${version_bin_dir}/$(basename ${file})
+ if [ -x ${target} ] ; then
+ found=1
+ break
+ fi
+ done
+ if [ ${found} -eq 0 ] ; then
+ echo " ${file}"
+ rm ${file}
+ fi
+ done
+ echo "done"
+}
+
+create_links() {
+ echo "Creating qtchooser links"
+ for version in ${VERSIONS} ; do
+ version_bin_dir=${PREFIX}/lib/qt${version}/bin
+ if [ -d ${version_bin_dir} ] ; then
+ for file in $(find ${version_bin_dir} -type f -maxdepth 1) ; do
+ target=${BINDIR}/$(basename ${file})
+ if [ ! -L ${target} -a ! -f ${target} ] ; then
+ echo " ${target}"
+ ln -s ${QTCHOOSER} ${target}
+ fi
+ done
+ fi
+ done
+ echo "done"
+}
+
+remove_links
+create_links
diff --git a/misc/qtchooser/pkg-plist b/misc/qtchooser/pkg-plist
index b74fba3f085f..0a9890519998 100644
--- a/misc/qtchooser/pkg-plist
+++ b/misc/qtchooser/pkg-plist
@@ -1,50 +1,5 @@
-bin/assistant
-bin/designer
-bin/lconvert
-bin/linguist
-bin/lrelease
-bin/lupdate
-bin/moc
-bin/pixeltool
-bin/qcollectiongenerator
-bin/qdbus
-bin/qdbuscpp2xml
-bin/qdbusviewer
-bin/qdbusxml2cpp
-bin/qdoc
-bin/qdoc3
-bin/qgltf
-bin/qhelpconverter
-bin/qhelpgenerator
-bin/qlalr
-bin/qmake
-bin/qml
-bin/qml1plugindump
-bin/qmlbundle
-bin/qmlcachegen
-bin/qmleasing
-bin/qmlimportscanner
-bin/qmljs
-bin/qmllint
-bin/qmlmin
-bin/qmlplugindump
-bin/qmlprofiler
-bin/qmlscene
-bin/qmltestrunner
-bin/qmlviewer
-bin/qtattributionsscanner
bin/qtchooser
-bin/qtconfig
-bin/qtdiag
-bin/qtpaths
-bin/qtplugininfo
-bin/qvkgen
-bin/rcc
-bin/repc
-bin/uic
-bin/uic3
-bin/xmlpatterns
-bin/xmlpatternsvalidator
+bin/update-qtchooser-wrapper
etc/xdg/qtchooser/default.conf
etc/xdg/qtchooser/qt4.conf
etc/xdg/qtchooser/qt5.conf
diff --git a/sysutils/qt5-qtdiag/Makefile b/sysutils/qt5-qtdiag/Makefile
index 34e18b168457..e03dc138be24 100644
--- a/sysutils/qt5-qtdiag/Makefile
+++ b/sysutils/qt5-qtdiag/Makefile
@@ -2,6 +2,7 @@
PORTNAME= qtdiag
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils
PKGNAMEPREFIX= qt5-
@@ -19,6 +20,8 @@ PLIST_FILES= ${QT_BINDIR}/qtdiag
# we do not really have to depend on.
WRKSRC_SUBDIR= src/${PORTNAME}
+QT_BINARIES= yes
+
post-patch:
${CP} ${WRKSRC}/../../.qmake.conf ${WRKSRC}
diff --git a/sysutils/qt5-qtpaths/Makefile b/sysutils/qt5-qtpaths/Makefile
index 00c2a7e2bd5b..e2864b0e6d18 100644
--- a/sysutils/qt5-qtpaths/Makefile
+++ b/sysutils/qt5-qtpaths/Makefile
@@ -2,6 +2,7 @@
PORTNAME= qtpaths
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils
PKGNAMEPREFIX= qt5-
@@ -19,6 +20,8 @@ PLIST_FILES= ${QT_BINDIR}/qtpaths
# we do not really have to depend on.
WRKSRC_SUBDIR= src/${PORTNAME}
+QT_BINARIES= yes
+
post-patch:
${CP} ${WRKSRC}/../../.qmake.conf ${WRKSRC}
diff --git a/sysutils/qt5-qtplugininfo/Makefile b/sysutils/qt5-qtplugininfo/Makefile
index eb61e1db0d89..234d3eaa53af 100644
--- a/sysutils/qt5-qtplugininfo/Makefile
+++ b/sysutils/qt5-qtplugininfo/Makefile
@@ -2,6 +2,7 @@
PORTNAME= qtplugininfo
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils
PKGNAMEPREFIX= qt5-
@@ -19,6 +20,8 @@ PLIST_FILES= ${QT_BINDIR}/qtplugininfo
# we do not really have to depend on.
WRKSRC_SUBDIR= src/${PORTNAME}
+QT_BINARIES= yes
+
post-patch:
${CP} ${WRKSRC}/../../.qmake.conf ${WRKSRC}
diff --git a/textproc/qt5-xmlpatterns/Makefile b/textproc/qt5-xmlpatterns/Makefile
index 8370b7d852f9..155826bef3c7 100644
--- a/textproc/qt5-xmlpatterns/Makefile
+++ b/textproc/qt5-xmlpatterns/Makefile
@@ -2,6 +2,7 @@
PORTNAME= xmlpatterns
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= textproc
PKGNAMEPREFIX= qt5-
@@ -12,4 +13,6 @@ USES= compiler:c++11-lang qmake:norecursive qt-dist:5,xmlpatterns
USE_QT= core network buildtools_build
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+QT_BINARIES= yes
+
.include <bsd.port.mk>
diff --git a/www/qt5-webengine/Makefile b/www/qt5-webengine/Makefile
index 4d7eab7cba0e..2aa9f41d6801 100644
--- a/www/qt5-webengine/Makefile
+++ b/www/qt5-webengine/Makefile
@@ -18,7 +18,7 @@
PORTNAME= webengine
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
PKGNAMEPREFIX= qt5-
@@ -111,6 +111,8 @@ MAKE_ENV+= CC="${CC}" CXX="${CXX}" \
CPLUS_INCLUDE_PATH=${LOCALBASE}/include \
${CONFIGURE_ENV}
+QT_BINARIES= yes
+
.include <bsd.port.pre.mk>
.if ${ARCH:Mmips*} || ${ARCH:Mpowerpc*} || ${ARCH} == sparc64
diff --git a/x11-toolkits/qt5-declarative/Makefile b/x11-toolkits/qt5-declarative/Makefile
index eb84c7be52a4..f330b48eb77a 100644
--- a/x11-toolkits/qt5-declarative/Makefile
+++ b/x11-toolkits/qt5-declarative/Makefile
@@ -2,6 +2,7 @@
PORTNAME= declarative
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= x11-toolkits
PKGNAMEPREFIX= qt5-
@@ -17,6 +18,7 @@ USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
CONFLICTS= qt5-declarative-render2d-* qt5-qml qt5-quick
+QT_BINARIES= yes
QT_DEFINES= ACCESSIBILITY
QT_CONFIG= accessibility accessibility-atspi-bridge
diff --git a/x11-toolkits/qt5-gui/Makefile b/x11-toolkits/qt5-gui/Makefile
index 38078202816b..24696e7af5d1 100644
--- a/x11-toolkits/qt5-gui/Makefile
+++ b/x11-toolkits/qt5-gui/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gui
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits graphics
PKGNAMEPREFIX= qt5-
@@ -65,6 +65,7 @@ MORE_WRKSRCS+= src/plugins/imageformats \
# openglextensions is the static library to use for further things like qtcanvas3d
MORE_WRKSRCS+= src/openglextensions
+QT_BINARIES= yes
QT_DEFINES= ACCESSIBILITY DBUS FONTCONFIG FREETYPE GLIB \
IMAGEFORMAT_PNG OPENGL SHAPE XCB XKB XKBCOMMON XRENDER
QT_CONFIG= accessibility accessibility-atspi-bridge dbus \
diff --git a/x11-toolkits/qt5-widgets/Makefile b/x11-toolkits/qt5-widgets/Makefile
index 6b89b9d32258..df13e2e99fc6 100644
--- a/x11-toolkits/qt5-widgets/Makefile
+++ b/x11-toolkits/qt5-widgets/Makefile
@@ -2,6 +2,7 @@
PORTNAME= widgets
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= x11-toolkits
PKGNAMEPREFIX= qt5-
@@ -19,6 +20,7 @@ INSTALL_WRKSRC= ${BUILD_WRKSRC}
MORE_WRKSRCS= src/tools/uic
+QT_BINARIES= yes
QT_DEFINES= ACCESSIBILITY WIDGETS XSYNC
QT_CONFIG= accessibility accessibility-atspi-bridge xlib
diff --git a/x11/qt5-qev/Makefile b/x11/qt5-qev/Makefile
index 4ef012577306..347d1d6e2198 100644
--- a/x11/qt5-qev/Makefile
+++ b/x11/qt5-qev/Makefile
@@ -2,6 +2,7 @@
PORTNAME= qev
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= x11
PKGNAMEPREFIX= qt5-
@@ -13,6 +14,8 @@ USE_QT= core widgets
WRKSRC_SUBDIR= src/${PORTNAME}
+QT_BINARIES= yes
+
# qev is not connected to qttool's build system, so we cannot just run qmake qt-dist:5,tools
# and set {BUILD,INSTALL}_WRKSRC.
# Instead, we run qmake qt-dist:5,tools from src/${PORTNAME} but need to copy .qmake qt-dist:5,tools.conf to