summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.gecko.mk2
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/files/patch-bug99125317
3 files changed, 3 insertions, 18 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 2ad5d15aab3f..6c6f9ec37886 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -539,8 +539,10 @@ gecko-post-patch:
-e 's|share/mozilla/extensions|lib/xpi|g' \
${MOZSRC}/xpcom/io/nsAppFileLocationProvider.cpp \
${MOZSRC}/toolkit/xre/nsXREDirProvider.cpp
+.if ${MOZILLA_VER:R:R} < 61
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${MOZSRC}/extensions/spellcheck/hunspell/*/mozHunspell.cpp
+.endif
# handles mozilla pis scripts.
gecko-moz-pis-patch:
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index f98628e21dcb..687aa9546afe 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= firefox
DISTVERSION= 63.0.3
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/firefox/files/patch-bug991253 b/www/firefox/files/patch-bug991253
deleted file mode 100644
index c0b032ec1a85..000000000000
--- a/www/firefox/files/patch-bug991253
+++ /dev/null
@@ -1,17 +0,0 @@
---- extensions/spellcheck/hunspell/glue/mozHunspell.cpp~
-+++ extensions/spellcheck/hunspell/glue/mozHunspell.cpp
-@@ -336,6 +336,14 @@ mozHunspell::LoadDictionaryList(bool aNotifyChildProcesses)
- }
- }
-
-+ // load system hunspell dictionaries
-+ nsCOMPtr<nsIFile> hunDir;
-+ NS_NewNativeLocalFile(NS_LITERAL_CSTRING("%%LOCALBASE%%/share/hunspell"),
-+ true, getter_AddRefs(hunDir));
-+ if (hunDir) {
-+ LoadDictionariesFromDir(hunDir);
-+ }
-+
- // find dictionaries from restartless extensions
- for (int32_t i = 0; i < mDynamicDirectories.Count(); i++) {
- LoadDictionariesFromDir(mDynamicDirectories[i]);