summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--dns/Makefile1
-rw-r--r--dns/py-adns/Makefile25
-rw-r--r--dns/py-adns/distinfo3
-rw-r--r--dns/py-adns/files/patch-adnsmodule.c10
-rw-r--r--dns/py-adns/pkg-descr8
-rw-r--r--net-p2p/py-tremc/Makefile26
-rw-r--r--net-p2p/py-tremc/distinfo6
-rw-r--r--net-p2p/py-tremc/files/patch-Makefile14
-rw-r--r--net-p2p/py-tremc/pkg-descr2
-rw-r--r--net-p2p/py-tremc/pkg-message28
-rw-r--r--net-p2p/py-tremc/pkg-plist4
12 files changed, 98 insertions, 30 deletions
diff --git a/MOVED b/MOVED
index d76076a62031..400cf9402357 100644
--- a/MOVED
+++ b/MOVED
@@ -9265,7 +9265,6 @@ audio/last-cmus||2017-04-30|Has expired: Unfetchable for more than six months (g
audio/mehdiaplayer||2017-04-30|Has expired: Unfetchable for more than six months (google code has gone away)
japanese/nhocr||2017-04-30|Has expired: Unfetchable for more than six months (google code has gone away)
misc/xsw||2017-04-30|Has expired: Unfetchable for more than six months (google code has gone away)
-dns/py-adns||2017-04-30|Has expired: Unfetchable for more than six months (google code has gone away)
dns/py-bonjour||2017-04-30|Has expired: Unfetchable for more than six months (google code has gone away)
games/robocalypto||2017-04-30|Has expired: Unfetchable for more than six months (google code has gone away)
games/libfov||2017-04-30|Has expired: Unfetchable for more than six months (google code has gone away)
diff --git a/dns/Makefile b/dns/Makefile
index 66859f45ca95..da5e19f5f66e 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -183,6 +183,7 @@
SUBDIR += powerdns-recursor
SUBDIR += powerdns-recursor40
SUBDIR += public_suffix_list
+ SUBDIR += py-adns
SUBDIR += py-aiodns
SUBDIR += py-cloudflare
SUBDIR += py-dns
diff --git a/dns/py-adns/Makefile b/dns/py-adns/Makefile
new file mode 100644
index 000000000000..176a0d71333c
--- /dev/null
+++ b/dns/py-adns/Makefile
@@ -0,0 +1,25 @@
+# Created by: Hye-Shik Chang <perky@fallin.lv>
+# $FreeBSD$
+
+PORTNAME= adns
+DISTVERSION= 1.4
+DISTVERSIONSUFFIX= -py1
+CATEGORIES= dns python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lebarondemerde@privacychain.ch
+COMMENT= Python module to resolve IPs to host names
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/GPL
+
+LIB_DEPENDS= libadns.so:dns/adns
+
+USES= localbase python:3.4+
+USE_PYTHON= autoplist distutils
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|1.4-py1|1.4|g' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/dns/py-adns/distinfo b/dns/py-adns/distinfo
new file mode 100644
index 000000000000..2a62ee895d53
--- /dev/null
+++ b/dns/py-adns/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1537084332
+SHA256 (adns-1.4-py1.tar.gz) = 675567453caf5843fabd1c2312aad13a93b61c3699dda2ceba67f1a2687ccddc
+SIZE (adns-1.4-py1.tar.gz) = 18868
diff --git a/dns/py-adns/files/patch-adnsmodule.c b/dns/py-adns/files/patch-adnsmodule.c
new file mode 100644
index 000000000000..58e2e5a2f1f6
--- /dev/null
+++ b/dns/py-adns/files/patch-adnsmodule.c
@@ -0,0 +1,10 @@
+--- adnsmodule.c.orig 2018-08-11 22:10:36 UTC
++++ adnsmodule.c
+@@ -6,6 +6,7 @@ any later version.
+ */
+
+ #include <Python.h>
++#include <sys/endian.h>
+ #include <adns.h>
+ #include <string.h>
+ #include <assert.h>
diff --git a/dns/py-adns/pkg-descr b/dns/py-adns/pkg-descr
new file mode 100644
index 000000000000..d521d6e0cc1d
--- /dev/null
+++ b/dns/py-adns/pkg-descr
@@ -0,0 +1,8 @@
+Python module to resolve IPs to host names.
+
+python3-adns is a Python 3 module that interfaces to the adns: an advanced easy
+to use, asynchronous-capable DNS client library and utilities. Adns is a
+resolver library for C (and C++) programs, and a collection of useful DNS
+resolver utilities.
+
+WWW: https://github.com/trolldbois/python3-adns/
diff --git a/net-p2p/py-tremc/Makefile b/net-p2p/py-tremc/Makefile
index b4aafab03577..c97df1298334 100644
--- a/net-p2p/py-tremc/Makefile
+++ b/net-p2p/py-tremc/Makefile
@@ -1,7 +1,8 @@
# $FreeBSD$
PORTNAME= tremc
-DISTVERSION= g20180106
+DISTVERSION= 0.9.1-11
+DISTVERSIONSUFFIX= -g54a873f
CATEGORIES= net-p2p python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,28 +14,17 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USES= python:3.4+ shebangfix
USE_GITHUB= yes
-GH_ACCOUNT= louipc
-GH_TAGNAME= dfbde72
NO_ARCH= yes
NO_BUILD= yes
SHEBANG_FILES= ${PORTNAME}
-PLIST_FILES= bin/${PORTNAME} \
- man/man1/${PORTNAME}.1.gz \
- share/bash-completion/completions/${PORTNAME}
+OPTIONS_DEFINE= ADNS GEOIP PYPERCLIP
+OPTIONS_DEFAULT= ADNS GEOIP PYPERCLIP
-OPTIONS_DEFINE= GEOIP XEROX
+PYPERCLIP_DESC= Copy magnet links to the system clipboard
-XEROX_DESC= Copy magnet links to the system clipboard
-
-GEOIP_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/GeoIP.so:net/py-GeoIP@${PY_FLAVOR}
-XEROX_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/xerox/__init__.py:devel/py-xerox@${PY_FLAVOR}
-
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
- ${INSTALL} -d ${STAGEDIR}${PREFIX}/share/bash-completion/completions
- ${INSTALL_DATA} ${WRKSRC}/completion/bash/${PORTNAME}.sh \
- ${STAGEDIR}${PREFIX}/share/bash-completion/completions/${PORTNAME}
+ADNS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}adns>=:dns/py-adns@${PY_FLAVOR}
+GEOIP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}GeoIP>=0:net/py-GeoIP@${PY_FLAVOR}
+PYPERCLIP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyperclip>=0:devel/py-pyperclip@${PY_FLAVOR}
.include <bsd.port.mk>
diff --git a/net-p2p/py-tremc/distinfo b/net-p2p/py-tremc/distinfo
index 66060a47df8e..d64e62b031d0 100644
--- a/net-p2p/py-tremc/distinfo
+++ b/net-p2p/py-tremc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1520992066
-SHA256 (louipc-tremc-g20180106-dfbde72_GH0.tar.gz) = 7f86c41fb9e4d343528cdde4f5f942ccb105cd188206c825df8100874360efbb
-SIZE (louipc-tremc-g20180106-dfbde72_GH0.tar.gz) = 315396
+TIMESTAMP = 1535129531
+SHA256 (tremc-tremc-0.9.1-11-g54a873f_GH0.tar.gz) = 8b404bf028938631a29986cd2c613f75c9b0a0e0674450d76abf1c81e68c1c97
+SIZE (tremc-tremc-0.9.1-11-g54a873f_GH0.tar.gz) = 315484
diff --git a/net-p2p/py-tremc/files/patch-Makefile b/net-p2p/py-tremc/files/patch-Makefile
new file mode 100644
index 000000000000..f4fe0aa84695
--- /dev/null
+++ b/net-p2p/py-tremc/files/patch-Makefile
@@ -0,0 +1,14 @@
+--- Makefile.orig 2018-08-13 15:08:26 UTC
++++ Makefile
+@@ -1,8 +1,8 @@
+ .PHONY: install
+
+ install:
+- install -d "${DESTDIR}${PREFIX}/share/man/man1"
+- install -m 644 tremc.1 "${DESTDIR}${PREFIX}/share/man/man1/tremc.1"
++ install -d "${DESTDIR}${MANPREFIX}/man/man1"
++ install -m 644 tremc.1 "${DESTDIR}${MANPREFIX}/man/man1"
+ install -d "${DESTDIR}${PREFIX}/bin"
+ install -m 755 tremc "${DESTDIR}${PREFIX}/bin/tremc"
+ install -d "${DESTDIR}${PREFIX}/share/bash-completion/completions"
+
diff --git a/net-p2p/py-tremc/pkg-descr b/net-p2p/py-tremc/pkg-descr
index 6ca6c7e39daa..e4a5368d1932 100644
--- a/net-p2p/py-tremc/pkg-descr
+++ b/net-p2p/py-tremc/pkg-descr
@@ -4,4 +4,4 @@ Python3 fork of the no longer maintained transmission-remote-cli. Some
extra modifications have been included and development will follow the
original project as much as possible.
-WWW: https://github.com/louipc/tremc
+WWW: https://github.com/tremc/tremc
diff --git a/net-p2p/py-tremc/pkg-message b/net-p2p/py-tremc/pkg-message
index b6b10ec28a4c..9013b8996cd0 100644
--- a/net-p2p/py-tremc/pkg-message
+++ b/net-p2p/py-tremc/pkg-message
@@ -1,10 +1,24 @@
-###################################################################
+##########################################################################
-Please do run "tremc --create-config" to create the configuration
-file with default values.
+Authentication and host/port can be set via command line with one of these
+patterns:
-NOTE: A config file won't be created unless you provide this
-option at least once. After that, it is rewritten whenever tremc
-exits.
+$ tremc -c homeserver
-###################################################################
+
+
+$ tremc -c homeserver:1234
+
+$ tremc -c johndoe:secretbirthday@homeserver
+
+$ tremc -c johndoe:secretbirthday@homeserver:1234
+
+You can write this (and other) stuff into a configuration file:
+
+$ tremc -c johndoe:secretbirthday@homeserver:1234 --create-config
+
+No configuration file is created automatically. You must create it.
+
+$ tremc --create-config
+
+##########################################################################
diff --git a/net-p2p/py-tremc/pkg-plist b/net-p2p/py-tremc/pkg-plist
new file mode 100644
index 000000000000..9c2007ca1718
--- /dev/null
+++ b/net-p2p/py-tremc/pkg-plist
@@ -0,0 +1,4 @@
+bin/tremc
+man/man1/tremc.1.gz
+share/bash-completion/completions/tremc
+share/zsh/site-functions/_tremc