summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/mtx/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/misc/mtx/Makefile b/misc/mtx/Makefile
index fdc7eb2cc595..e0a8098d3abb 100644
--- a/misc/mtx/Makefile
+++ b/misc/mtx/Makefile
@@ -3,16 +3,25 @@
PORTNAME= mtx
PORTVERSION= 1.3.12
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-stable/${PORTVERSION}
MAINTAINER= 5u623l20@gmail.com
COMMENT= Control SCSI media changer devices
+LICENSE= GPLv2
+
USES= gmake
GNU_CONFIGURE= yes
-MAN1= loaderinfo.1 mtx.1 tapeinfo.1 scsitape.1 scsieject.1
-PLIST_FILES= sbin/mtx sbin/tapeinfo sbin/loaderinfo sbin/scsitape sbin/scsieject
+PLIST_FILES= sbin/mtx sbin/tapeinfo sbin/loaderinfo sbin/scsitape sbin/scsieject \
+ man/man1/loaderinfo.1.gz man/man1/mtx.1.gz man/man1/tapeinfo.1.gz \
+ man/man1/scsitape.1.gz man/man1/scsieject.1.gz
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|@prefix@|${STAGEDIR}${PREFIX}|g' \
+ ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e 's|@mandir@|${STAGEDIR}${PREFIX}/man|g' \
+ ${WRKSRC}/Makefile.in
-NO_STAGE= yes
.include <bsd.port.mk>