summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/pawm/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11-wm/pawm/Makefile b/x11-wm/pawm/Makefile
index b6975f7e8bb8..dfaadc1a8c81 100644
--- a/x11-wm/pawm/Makefile
+++ b/x11-wm/pawm/Makefile
@@ -21,6 +21,12 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on 4.x"
+.endif
+
do-configure:
cd ${WRKSRC} && \
bash ./0 --prefix=${PREFIX} --datadir=${PREFIX}/share/pawm
@@ -54,4 +60,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>