summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/pike78/Makefile3
-rw-r--r--lang/pike78/Makefile.common6
-rw-r--r--www/caudium14/Makefile11
3 files changed, 13 insertions, 7 deletions
diff --git a/lang/pike78/Makefile b/lang/pike78/Makefile
index 5e8e5a65ce5a..19f623b3339c 100644
--- a/lang/pike78/Makefile
+++ b/lang/pike78/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= pike78
-PORTVERSION= 7.8.866
+PORTVERSION= ${PIKEVERSION}
CATEGORIES= lang
MASTER_SITES= http://pike.ida.liu.se/pub/pike/all/${PORTVERSION}/ \
ftp://pike.ida.liu.se/pub/pike/beta/${PORTVERSION}/ \
@@ -116,4 +116,5 @@ post-install:
verify:
cd ${WRKSRC}; ${GMAKE} verify
+.include "Makefile.common"
.include <bsd.port.mk>
diff --git a/lang/pike78/Makefile.common b/lang/pike78/Makefile.common
new file mode 100644
index 000000000000..4f5dd6dc81dc
--- /dev/null
+++ b/lang/pike78/Makefile.common
@@ -0,0 +1,6 @@
+# $FreeBSD$
+
+# Also used by www/caudium14
+
+PIKEVERSION= 7.8.866
+
diff --git a/www/caudium14/Makefile b/www/caudium14/Makefile
index bb10f4fdec6a..0389af96a7f5 100644
--- a/www/caudium14/Makefile
+++ b/www/caudium14/Makefile
@@ -2,24 +2,22 @@
# $FreeBSD$
PORTNAME= caudium14
-PORTVERSION= 1.4.18
-PORTREVISION= 1
+PORTVERSION= ${DISTVERSION}.${PIKEVERSION}
+DISTVERSION= 1.4.18
CATEGORIES= www
MASTER_SITES= http://caudium.googlecode.com/files/
-DISTNAME= Caudium-${PORTVERSION}
+DISTNAME= Caudium-${DISTVERSION}
MAINTAINER= johans@FreeBSD.org
COMMENT= Free webserver based on the Roxen Challenger 1.3 code base
-BROKEN= Fails to build
-
BUILD_DEPENDS= pike78:${PORTSDIR}/lang/pike78
LIB_DEPENDS= libsablot.so:${PORTSDIR}/textproc/sablotron
RUN_DEPENDS= lsof:${PORTSDIR}/sysutils/lsof
USES= tar:bzip2 gmake
-PIKEVERSION= 7.8.852
+# Pike version included from lang/pike78
SUB_LIST+= PIKEVERSION=${PIKEVERSION}
PLIST_SUB+= PIKEVERSION=${PIKEVERSION}
@@ -56,4 +54,5 @@ post-configure:
. endfor
.endif
+.include "../../lang/pike78/Makefile.common"
.include <bsd.port.post.mk>