summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/notify-osd/Makefile2
-rw-r--r--deskutils/notify-osd/files/patch-src_bubble-window.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/deskutils/notify-osd/Makefile b/deskutils/notify-osd/Makefile
index ccd136c5f7b7..5664cb9e0938 100644
--- a/deskutils/notify-osd/Makefile
+++ b/deskutils/notify-osd/Makefile
@@ -1,6 +1,6 @@
PORTNAME= notify-osd
PORTVERSION= 0.9.34
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils
MASTER_SITES= https://launchpad.net/notify-osd/precise/0.9.34/+download/ \
LOCAL/ehaupt
diff --git a/deskutils/notify-osd/files/patch-src_bubble-window.c b/deskutils/notify-osd/files/patch-src_bubble-window.c
new file mode 100644
index 000000000000..b6e277d4d8fd
--- /dev/null
+++ b/deskutils/notify-osd/files/patch-src_bubble-window.c
@@ -0,0 +1,13 @@
+--- src/bubble-window.c.orig 2012-03-23 14:49:59 UTC
++++ src/bubble-window.c
+@@ -78,8 +78,8 @@ bubble_window_get_accessible (GtkWidget *widget)
+ {
+ AtkObjectFactory *factory = NULL;
+ AtkRegistry *registry = NULL;
+- GType derived_type = NULL;
+- GType derived_atk_type = NULL;
++ GType derived_type = G_TYPE_NONE;
++ GType derived_atk_type = ATK_TYPE_OBJECT;
+
+ /*
+ * Figure out whether accessibility is enabled by looking at the