summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/fping/Makefile4
-rw-r--r--net/fping/files/patch-022
2 files changed, 5 insertions, 1 deletions
diff --git a/net/fping/Makefile b/net/fping/Makefile
index bfd30fb148ab..fe44ac27fb8a 100644
--- a/net/fping/Makefile
+++ b/net/fping/Makefile
@@ -18,6 +18,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --bindir="${PREFIX}/sbin"
MAN8= fping.8
+post-patch:
+ ${PERL} -pi.fbsd -e 's/fping@/${MAINTAINER:S/@/\\@/g} or fping@/g' \
+ ${WRKSRC}/fping.c
+
post-install:
@strip ${PREFIX}/sbin/fping
@${CHMOD} 4555 ${PREFIX}/sbin/fping
diff --git a/net/fping/files/patch-02 b/net/fping/files/patch-02
index 48efd00bb1e0..2d2777b407a4 100644
--- a/net/fping/files/patch-02
+++ b/net/fping/files/patch-02
@@ -55,7 +55,7 @@
- printf("%s: Version %s $Date: 1997/01/08 20:29:33 $\n",argv[0], VERSION);
- printf("%s: comments to fping@networking.Stanford.EDU\n",argv[0]);
+ printf("%s: FreeBSD port based on Version %s $Date: 1997/01/08 20:29:33 $\n",argv[0], VERSION);
-+ printf("%s: comments to obrien@FreeBSD.org or fping@networking.Stanford.EDU\n",argv[0]);
++ printf("%s: comments to fping@networking.Stanford.EDU\n",argv[0]);
exit(0);
case 'f':
#ifdef ENABLE_F_OPTION