summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/sl2tps/Makefile11
-rw-r--r--net/sl2tps/files/patch-Makefile21
-rw-r--r--net/sl2tps/pkg-plist4
3 files changed, 28 insertions, 8 deletions
diff --git a/net/sl2tps/Makefile b/net/sl2tps/Makefile
index 66048a1d1061..511db5b3b814 100644
--- a/net/sl2tps/Makefile
+++ b/net/sl2tps/Makefile
@@ -3,23 +3,18 @@
PORTNAME= sl2tps
PORTVERSION= 0.4.2
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= SF/libpdel/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple L2TP server based on libpdel(3) and netgraph(4)
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-LIB_DEPENDS= pdel.0:${PORTSDIR}/devel/libpdel
+LIB_DEPENDS= libpdel.so:${PORTSDIR}/devel/libpdel
-MANCOMPRESSED= maybe
-MAN1= sl2tps.1
-PLIST_FILES= bin/sl2tps %%ETCDIR%%/config.xml.sample
-PLIST_DIRS= %%ETCDIR%%
-
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e \
's|$${PREFIX}/include|$${LOCALBASE}/include|g ; \
diff --git a/net/sl2tps/files/patch-Makefile b/net/sl2tps/files/patch-Makefile
new file mode 100644
index 000000000000..71ddc4fa0444
--- /dev/null
+++ b/net/sl2tps/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig 2014-06-10 00:10:49.502121136 +0800
++++ Makefile 2014-06-10 00:11:31.903120544 +0800
+@@ -38,14 +38,14 @@ CLEANFILES+= ${PROG}.1
+ # Install example config file
+ #
+ beforeinstall:
+- @if [ ! -d ${PREFIX}/etc/${PROG} ]; then \
++ @if [ ! -d $(DESTDIR)${PREFIX}/etc/${PROG} ]; then \
+ ${ECHO} ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 0755 \
+- ${PREFIX}/etc/${PROG}; \
++ $(DESTDIR)${PREFIX}/etc/${PROG}; \
+ ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 0755 \
+- ${PREFIX}/etc/${PROG}; \
++ $(DESTDIR)${PREFIX}/etc/${PROG}; \
+ fi
+ ${INSTALL} -C -o ${SHAREOWN} -g ${SHAREGRP} -m 0644 \
+- ${CONFIG_SAMPLE} ${PREFIX}/etc/${PROG}/${CONFIG_SAMPLE}
++ ${CONFIG_SAMPLE} $(DESTDIR)${PREFIX}/etc/${PROG}/${CONFIG_SAMPLE}
+
+ distclean: cleandir
+
diff --git a/net/sl2tps/pkg-plist b/net/sl2tps/pkg-plist
new file mode 100644
index 000000000000..1cb3fc7ee29d
--- /dev/null
+++ b/net/sl2tps/pkg-plist
@@ -0,0 +1,4 @@
+bin/sl2tps
+@sample %%ETCDIR%%/config.xml.sample
+man/man1/sl2tps.1.gz
+@dirrmtry %%ETCDIR%%