summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/squidview/Makefile34
-rw-r--r--www/squidview/distinfo3
-rw-r--r--www/squidview/pkg-descr12
-rw-r--r--www/squidview/pkg-plist8
5 files changed, 58 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 28652eeff971..dd7fcf8ca2a4 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1102,6 +1102,7 @@
SUBDIR += squidguard
SUBDIR += squidpurge
SUBDIR += squidtimes
+ SUBDIR += squidview
SUBDIR += squirm
SUBDIR += squishdot
SUBDIR += srg
diff --git a/www/squidview/Makefile b/www/squidview/Makefile
new file mode 100644
index 000000000000..db1f13ba8a53
--- /dev/null
+++ b/www/squidview/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: squidview
+# Date created: 2007-04-21
+# Whom: stas
+#
+# $FreeBSD$
+#
+
+PORTNAME= squidview
+PORTVERSION= 0.71
+CATEGORIES= www
+MASTER_SITES= http://www.rillion.net/squidview/
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Monitor squid statistics in realtime
+
+GNU_CONFIGURE= yes
+
+MAN1= squidview.1
+DOCS= HOWTO README
+DATAFILES= aliases users words
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/squidview ${PREFIX}/bin/
+
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${DATAFILES:S,^,${WRKSRC}/,} ${DATADIR}/
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+.endif
+ ${INSTALL_MAN} ${WRKSRC}/squidview.1 ${MAN1PREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/www/squidview/distinfo b/www/squidview/distinfo
new file mode 100644
index 000000000000..ee876fcc91af
--- /dev/null
+++ b/www/squidview/distinfo
@@ -0,0 +1,3 @@
+MD5 (squidview-0.71.tar.gz) = 8588c0c36a19d8db0a7c4bfc5ba8a9bb
+SHA256 (squidview-0.71.tar.gz) = b3e352682c7a79233a38c11e5dd92ec1cc4b8de95fca430bca801e9319df335f
+SIZE (squidview-0.71.tar.gz) = 107551
diff --git a/www/squidview/pkg-descr b/www/squidview/pkg-descr
new file mode 100644
index 000000000000..6cad461b835d
--- /dev/null
+++ b/www/squidview/pkg-descr
@@ -0,0 +1,12 @@
+Squidview is a program that displays the squid proxy server log file in a nice
+fashion, providing the log file is in squid's native reporting fashion. It has
+features such as search, report generation, monitor mode and supports three log
+files.
+
+Thus, the program can be used to monitor Internet usage on a networked site.
+But please note squid has to be running first and this program is not a
+proactive resource controller. What it can do is tell you who and which sites
+are consuming the most bandwidth.
+
+Author: Graeme Sheppard
+WWW: http://www.rillion.net/squidview
diff --git a/www/squidview/pkg-plist b/www/squidview/pkg-plist
new file mode 100644
index 000000000000..703e9fa6f3d7
--- /dev/null
+++ b/www/squidview/pkg-plist
@@ -0,0 +1,8 @@
+bin/squidview
+%%PORTDOCS%%%%DOCSDIR%%/HOWTO
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%DATADIR%%/aliases
+%%DATADIR%%/users
+%%DATADIR%%/words
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%