summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/yaws/Makefile4
-rw-r--r--www/yaws/files/patch-scripts_yaws.template14
2 files changed, 16 insertions, 2 deletions
diff --git a/www/yaws/Makefile b/www/yaws/Makefile
index f49385d10af9..6e1a25fe2124 100644
--- a/www/yaws/Makefile
+++ b/www/yaws/Makefile
@@ -7,6 +7,7 @@
PORTNAME= yaws
PORTVERSION= 1.45
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://yaws.hyber.org/download/
@@ -36,7 +37,7 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|!!PREFIX!!|${PREFIX}|g' \
${WRKSRC}/man/yaws_api.5 ${WRKSRC}/man/yaws.conf.5 \
- ${WRKSRC}/src/yaws_config.erl
+ ${WRKSRC}/src/yaws_config.erl ${WRKSRC}/scripts/yaws.template
@${FIND} ${WRKSRC} -name \*.orig -or -name \*.bak | ${XARGS} ${RM}
do-install:
@@ -46,7 +47,6 @@ do-install:
@${MKDIR} ${PREFIX}/lib/yaws/include
@${MKDIR} ${PREFIX}/lib/yaws/priv
@${MKDIR} ${PREFIX}/www/yaws
- @${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/ebin/* ${PREFIX}/lib/yaws/ebin
@${INSTALL_DATA} ${WRKSRC}/priv/* ${PREFIX}/lib/yaws/priv
@${INSTALL_DATA} ${WRKSRC}/include/* ${PREFIX}/lib/yaws/include
diff --git a/www/yaws/files/patch-scripts_yaws.template b/www/yaws/files/patch-scripts_yaws.template
new file mode 100644
index 000000000000..80167320775d
--- /dev/null
+++ b/www/yaws/files/patch-scripts_yaws.template
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- scripts/yaws.template.orig Thu May 6 14:43:33 2004
++++ scripts/yaws.template Thu May 6 14:44:26 2004
+@@ -1,7 +1,7 @@
+ #!/bin/sh
+
+
+-yawsdir="%yawsdir%"
++yawsdir=!!PREFIX!!/lib/yaws
+ erl="%erl%"
+ case `uname` in
+ CYGWIN*)