summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/typo345/Makefile21
1 files changed, 5 insertions, 16 deletions
diff --git a/www/typo345/Makefile b/www/typo345/Makefile
index 0526fe6357df..0b4bedb07284 100644
--- a/www/typo345/Makefile
+++ b/www/typo345/Makefile
@@ -35,15 +35,12 @@ GD_DESC= GDlib/freetype support
IMAGICK_DESC= ${IMAGEMAGICK_DESC}
MBSTRING_DESC= ${MULTIBYTE_DESC}
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MCURL}
-USE_PHP+= curl
-.endif
+CURL_USE= PHP=curl
+GD_USE= PHP=gd
+MBSTRING_USE= PHP=mbstring
+ZLIB_USE= PHP=zlib
-.if ${PORT_OPTIONS:MGD}
-USE_PHP+= gd
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MIMAGICK}
.if ${PORT_OPTIONS:MX11}
@@ -53,14 +50,6 @@ RUN_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick-nox11
.endif
.endif
-.if ${PORT_OPTIONS:MMBSTRING}
-USE_PHP+= mbstring
-.endif
-
-.if ${PORT_OPTIONS:MZLIB}
-USE_PHP+= zlib
-.endif
-
pre-install:
${MV} ${WRKDIR}/${TYPO3DUMMY}/typo3conf/localconf.php \
${WRKDIR}/${TYPO3DUMMY}/typo3conf/localconf.php.dist