summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/galeon2/Makefile4
-rw-r--r--www/galeon2/files/patch-configure19
2 files changed, 18 insertions, 5 deletions
diff --git a/www/galeon2/Makefile b/www/galeon2/Makefile
index 3a85dd8256e3..d66023824c47 100644
--- a/www/galeon2/Makefile
+++ b/www/galeon2/Makefile
@@ -52,10 +52,10 @@ MAN1= galeon.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
+.if ${OSVERSION} > 500000
# Galeon does not build correctly in -CURRENT if -Werror is passed
# to the compiler.
-CONFIGURE_ARGS+= --enable-werror
+CONFIGURE_ARGS+= --disable-werror
.endif
post-extract:
diff --git a/www/galeon2/files/patch-configure b/www/galeon2/files/patch-configure
index 7c0b2ed87ef2..1624ed425cb4 100644
--- a/www/galeon2/files/patch-configure
+++ b/www/galeon2/files/patch-configure
@@ -1,6 +1,6 @@
---- configure Thu Nov 7 02:51:25 2002
-+++ configure2 Thu Nov 7 02:51:32 2002
-@@ -7140,6 +7140,7 @@
+--- configure.orig Tue Jan 21 15:44:16 2003
++++ configure Tue Jan 21 15:45:28 2003
+@@ -14219,6 +14219,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -8,3 +8,16 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -18588,7 +18589,11 @@
+ # Check whether --enable-werror or --disable-werror was given.
+ if test "${enable_werror+set}" = set; then
+ enableval="$enable_werror"
+- disable_werror=no
++ if test "x$enable_werror" != "xno"; then
++ disable_werror=no
++ else
++ disable_werror=yes
++ fi
+ else
+ disable_werror=yes
+ fi;