summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/p5-CGI-Untaint/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/www/p5-CGI-Untaint/Makefile b/www/p5-CGI-Untaint/Makefile
index d1875282d528..41b60634a4ed 100644
--- a/www/p5-CGI-Untaint/Makefile
+++ b/www/p5-CGI-Untaint/Makefile
@@ -15,16 +15,19 @@ PKGNAMEPREFIX= p5-
MAINTAINER= mat@FreeBSD.org
COMMENT= Process CGI input parameters
-RUN_DEPENDS= ${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-exports \
+RUN_DEPENDS= ${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-require \
${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
-BUILD_DEPENDS= ${RUN_DEPENDS} \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
PERL_CONFIGURE= yes
MAN3= CGI::Untaint.3 CGI::Untaint::hex.3 CGI::Untaint::integer.3 \
CGI::Untaint::object.3 CGI::Untaint::printable.3
+post-configure:
+ ${PERL} -pi -e 's/-I\S+PERL\S+ //g if m{PERL_DL_NONLAZY}' ${WRKSRC}/Makefile
+
.if !defined(NOPORTDOCS)
PORTDOCS= Changes