summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/exim/Makefile1
-rw-r--r--mail/exim/files/patch-src::dbfn.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index dfafb3267260..256152fc46d6 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -7,6 +7,7 @@
PORTNAME= exim
PORTVERSION= ${EXIM_VERSION}
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/exim4/ \
http://www.exim.org/ftp/exim4/ \
diff --git a/mail/exim/files/patch-src::dbfn.c b/mail/exim/files/patch-src::dbfn.c
new file mode 100644
index 000000000000..68ffdda34f0b
--- /dev/null
+++ b/mail/exim/files/patch-src::dbfn.c
@@ -0,0 +1,11 @@
+--- src/dbfn.c.orig Wed Dec 18 12:28:01 2002
++++ src/dbfn.c Tue Jan 21 12:17:02 2003
+@@ -148,7 +148,7 @@
+ sprintf(CS buffer, "%s/db/%s", spool_directory, name);
+ EXIM_DBOPEN(buffer, flags, EXIMDB_MODE, &(dbblock->dbptr));
+
+-if (dbblock->dbptr == NULL && errno == ENOENT)
++if (dbblock->dbptr == NULL && errno == ENOENT && flags == O_RDWR)
+ {
+ DEBUG(D_hints_lookup)
+ debug_printf("%s appears not to exist: trying to create\n", buffer);