summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/apache13+ipv6/Makefile2
-rw-r--r--www/apache13+ipv6/files/patch-util.c31
2 files changed, 32 insertions, 1 deletions
diff --git a/www/apache13+ipv6/Makefile b/www/apache13+ipv6/Makefile
index 9485b93f0740..2b2e5597ae39 100644
--- a/www/apache13+ipv6/Makefile
+++ b/www/apache13+ipv6/Makefile
@@ -7,7 +7,7 @@
PORTNAME= apache+ipv6
PORTVERSION= 1.3.19
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www ipv6
MASTER_SITES= http://www.apache.org/dist/ \
ftp://ftp.ccs.neu.edu/net/mirrors/ftp.apache.org/apache/dist/ \
diff --git a/www/apache13+ipv6/files/patch-util.c b/www/apache13+ipv6/files/patch-util.c
new file mode 100644
index 000000000000..4c5b12a638a5
--- /dev/null
+++ b/www/apache13+ipv6/files/patch-util.c
@@ -0,0 +1,31 @@
+--- src/main/util.c.orig Mon Apr 2 13:21:27 2001
++++ src/main/util.c Mon Apr 2 13:21:28 2001
+@@ -2048,12 +2048,14 @@
+ int x;
+
+ if (!strchr(p->h_name, '.')) {
+- for (x = 0; p->h_aliases[x]; ++x) {
+- if (strchr(p->h_aliases[x], '.') &&
+- (!strncasecmp(p->h_aliases[x], p->h_name, strlen(p->h_name))))
+- return ap_pstrdup(a, p->h_aliases[x]);
+- }
+- return NULL;
++ if (p->h_aliases) {
++ for (x = 0; p->h_aliases[x]; ++x) {
++ if (p->h_aliases[x] && strchr(p->h_aliases[x], '.') &&
++ (!strncasecmp(p->h_aliases[x], p->h_name, strlen(p->h_name))))
++ return ap_pstrdup(a, p->h_aliases[x]);
++ }
++ }
++ return NULL;
+ }
+ return ap_pstrdup(a, (void *) p->h_name);
+ }
+@@ -2077,7 +2079,6 @@
+ ap_log_error(APLOG_MARK, APLOG_WARNING, NULL,
+ "%s: gethostname() failed to determine ServerName\n",
+ ap_server_argv0);
+- server_hostname = ap_pstrdup(a, "127.0.0.1");
+ }
+ else
+ {