summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/nginx-devel/Makefile11
-rw-r--r--www/nginx-devel/distinfo2
-rw-r--r--www/nginx/Makefile11
-rw-r--r--www/nginx/distinfo2
4 files changed, 26 insertions, 0 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index b1cc3340e890..43a0a22c6222 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -105,6 +105,7 @@ OPTIONS_DEFINE= \
RTMP \
SET_MISC \
SFLOW \
+ SHIBBOLETH \
SLOWFS_CACHE \
SMALL_LIGHT \
SRCACHE \
@@ -201,6 +202,7 @@ REDIS2_DESC= 3rd party redis2 module
RTMP_DESC= 3rd party rtmp module
SET_MISC_DESC= 3rd party set_misc module
SFLOW_DESC= 3rd party sflow module
+SHIBBOLETH_DESC= 3rd party shibboleth module
SLOWFS_CACHE_DESC= 3rd party slowfs_cache module
SMALL_LIGHT_DESC= 3rd party small_light module
SRCACHE_DESC= 3rd party srcache module
@@ -775,6 +777,15 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_http_sflow_config.c \
${PATCHDIR}/extra-patch-ngx_http_sflow_module.c
.endif
+.if ${PORT_OPTIONS:MSHIBBOLETH}
+RUN_DEPENDS+= ${LOCALBASE}/sbin/shibd:${PORTSDIR}/security/shibboleth2-sp/
+GIT_SHIBBOLETH_VERSION= 20150121
+GH_ACCOUNT+= nginx-shib:shib
+GH_PROJECT+= nginx-http-shibboleth:shib
+GH_TAGNAME+= v${GIT_SHIBBOLETH_VERSION}:shib
+CONFIGURE_ARGS+=--add-module=${WRKSRC_shib}
+.endif
+
.if ${PORT_OPTIONS:MSLOWFS_CACHE}
NGINX_SLOWFS_CACHE_VERSION= 1.10
MASTER_SITES+= http://labs.frickle.com/files/:slowfs_cache
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index 9cfb82e3c42f..c43812783f25 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -116,5 +116,7 @@ SHA256 (calio-form-input-nginx-module-v0.07_GH0.tar.gz) = c0c56cc697a290e98b88d4
SIZE (calio-form-input-nginx-module-v0.07_GH0.tar.gz) = 10563
SHA256 (calio-iconv-nginx-module-v0.10_GH0.tar.gz) = 88e326eba7fdf9fd2376b1ba033b48cb0eee45136528cf5430ac9340088ce324
SIZE (calio-iconv-nginx-module-v0.10_GH0.tar.gz) = 12513
+SHA256 (nginx-shib-nginx-http-shibboleth-v20150121_GH0.tar.gz) = e38a19bb4d30e5487c013c4b6b3e3d5b96de82d63b776471cc2c381a5d00374d
+SIZE (nginx-shib-nginx-http-shibboleth-v20150121_GH0.tar.gz) = 10106
SHA256 (patch.http2-v3_1.9.4.txt) = 6fced0feb2511a8078e770672b77f07fa94e607aa76899f64715b66d726085af
SIZE (patch.http2-v3_1.9.4.txt) = 314486
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index d7dea82f50cb..2acc8a92929f 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -102,6 +102,7 @@ OPTIONS_DEFINE= \
RTMP \
SET_MISC \
SFLOW \
+ SHIBBOLETH \
SLOWFS_CACHE \
SMALL_LIGHT \
SRCACHE \
@@ -194,6 +195,7 @@ REDIS2_DESC= 3rd party redis2 module
RTMP_DESC= 3rd party rtmp module
SET_MISC_DESC= 3rd party set_misc module
SFLOW_DESC= 3rd party sflow module
+SHIBBOLETH_DESC= 3rd party shibboleth module
SLOWFS_CACHE_DESC= 3rd party slowfs_cache module
SMALL_LIGHT_DESC= 3rd party small_light module
SRCACHE_DESC= 3rd party srcache module
@@ -758,6 +760,15 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_http_sflow_config.c \
${PATCHDIR}/extra-patch-ngx_http_sflow_module.c
.endif
+.if ${PORT_OPTIONS:MSHIBBOLETH}
+RUN_DEPENDS+= ${LOCALBASE}/sbin/shibd:${PORTSDIR}/security/shibboleth2-sp/
+GIT_SHIBBOLETH_VERSION= 20150121
+GH_ACCOUNT+= nginx-shib:shib
+GH_PROJECT+= nginx-http-shibboleth:shib
+GH_TAGNAME+= v${GIT_SHIBBOLETH_VERSION}:shib
+CONFIGURE_ARGS+=--add-module=${WRKSRC_shib}
+.endif
+
.if ${PORT_OPTIONS:MSLOWFS_CACHE}
NGINX_SLOWFS_CACHE_VERSION= 1.10
MASTER_SITES+= http://labs.frickle.com/files/:slowfs_cache
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 740b9c8a0b07..4d95d334e3db 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -114,3 +114,5 @@ SHA256 (calio-form-input-nginx-module-v0.07_GH0.tar.gz) = c0c56cc697a290e98b88d4
SIZE (calio-form-input-nginx-module-v0.07_GH0.tar.gz) = 10563
SHA256 (calio-iconv-nginx-module-v0.10_GH0.tar.gz) = 88e326eba7fdf9fd2376b1ba033b48cb0eee45136528cf5430ac9340088ce324
SIZE (calio-iconv-nginx-module-v0.10_GH0.tar.gz) = 12513
+SHA256 (nginx-shib-nginx-http-shibboleth-v20150121_GH0.tar.gz) = e38a19bb4d30e5487c013c4b6b3e3d5b96de82d63b776471cc2c381a5d00374d
+SIZE (nginx-shib-nginx-http-shibboleth-v20150121_GH0.tar.gz) = 10106