summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--irc/undernet-ircu/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/irc/undernet-ircu/Makefile b/irc/undernet-ircu/Makefile
index 608294a8272b..40aca51d365d 100644
--- a/irc/undernet-ircu/Makefile
+++ b/irc/undernet-ircu/Makefile
@@ -59,6 +59,11 @@ CONFIGURE_ARGS+= --enable-profile
.include <bsd.port.options.mk>
+# always disable profile support on 8.x
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 900000
+CONFIGURE_ARGS:= ${CONFIGURE_ARGS:N--enable-profile}
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ircd/ircd ${STAGEDIR}${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/ircd/convert-conf \