summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/grig/Makefile2
-rw-r--r--comms/grig/files/patch-src::grig-druid-loc.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/comms/grig/Makefile b/comms/grig/Makefile
index 699cd2b27260..6994d7745848 100644
--- a/comms/grig/Makefile
+++ b/comms/grig/Makefile
@@ -6,7 +6,7 @@
PORTNAME= grig
PORTVERSION= 0.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= comms
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= groundstation
diff --git a/comms/grig/files/patch-src::grig-druid-loc.c b/comms/grig/files/patch-src::grig-druid-loc.c
new file mode 100644
index 000000000000..6d0f307914ff
--- /dev/null
+++ b/comms/grig/files/patch-src::grig-druid-loc.c
@@ -0,0 +1,13 @@
+--- src/grig-druid-loc.c.orig Sun May 9 07:18:50 2004
++++ src/grig-druid-loc.c Sun May 9 07:16:04 2004
+@@ -293,9 +293,9 @@
+ */
+ if (gtk_toggle_button_get_active (GTK_TOGGLE_BUTTON (radll))) {
+ longlat2locator (g_strtod (gtk_entry_get_text (GTK_ENTRY (lonwdg)), NULL),
+ g_strtod (gtk_entry_get_text (GTK_ENTRY (latwdg)), NULL),
+- loc);
++ loc, 3);
+ gtk_entry_set_text (GTK_ENTRY (locatorwdg), g_strdup (loc));
+ }
+ #endif
+ }