summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/thrift-cpp/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/devel/thrift-cpp/Makefile b/devel/thrift-cpp/Makefile
index 9e44208037c5..7a425249a104 100644
--- a/devel/thrift-cpp/Makefile
+++ b/devel/thrift-cpp/Makefile
@@ -44,13 +44,11 @@ CONFIGURE_ARGS+= \
--without-ruby \
--without-go
-.include <bsd.port.pre.mk>
-
# src/thrift/transport/TSSLSocket.cpp:147: error: 'TLSv1_1_method' was not declared in this scope
# src/thrift/transport/TSSLSocket.cpp:149: error: 'TLSv1_2_method' was not declared in this scope
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000015
-IGNORE= does not build with 9.x base OpenSSL
-.endif
+BROKEN_FreeBSD_9= does not build with 9.x base OpenSSL
+
+.include <bsd.port.pre.mk>
.if ${COMPILER_TYPE} == clang
USE_CXXSTD= c++11