summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/mp3plot/Makefile2
-rw-r--r--devel/synfig/Makefile2
-rw-r--r--editors/emacs-devel/Makefile1
-rw-r--r--editors/emacs/Makefile1
-rw-r--r--graphics/ImageMagick/Makefile17
-rw-r--r--graphics/ImageMagick/distinfo6
-rw-r--r--graphics/ImageMagick/pkg-plist12
-rw-r--r--graphics/autotrace/Makefile2
-rw-r--r--graphics/converseen/Makefile2
-rw-r--r--graphics/dcraw-m/Makefile2
-rw-r--r--graphics/dmtx-utils/Makefile2
-rw-r--r--graphics/fpc-imagemagick/Makefile2
-rw-r--r--graphics/gimp-gmic-plugin/Makefile2
-rw-r--r--graphics/gscan2pdf/Makefile1
-rw-r--r--graphics/hdr_tools/Makefile2
-rw-r--r--graphics/inkscape/Makefile2
-rw-r--r--graphics/kipi-plugin-videoslideshow/Makefile2
-rw-r--r--graphics/libboard/Makefile2
-rw-r--r--graphics/libdmtx/Makefile2
-rw-r--r--graphics/npretty/Makefile2
-rw-r--r--graphics/opendx/Makefile2
-rw-r--r--graphics/p5-Image-Magick-Iterator/Makefile2
-rw-r--r--graphics/pecl-imagick/Makefile2
-rw-r--r--graphics/php-magickwand/Makefile2
-rw-r--r--graphics/pstoedit/Makefile2
-rw-r--r--graphics/py-wand/Makefile2
-rw-r--r--graphics/reallyslick/Makefile2
-rw-r--r--graphics/rubygem-rmagick/Makefile2
-rw-r--r--graphics/timg/Makefile2
-rw-r--r--graphics/zbar/Makefile2
-rw-r--r--misc/img2xterm/Makefile2
-rw-r--r--multimedia/emby-server/Makefile1
-rw-r--r--security/libfprint/Makefile2
-rw-r--r--www/WebMagick/Makefile2
-rw-r--r--x11-wm/libwraster/Makefile2
-rw-r--r--x11-wm/windowmaker/Makefile2
36 files changed, 53 insertions, 44 deletions
diff --git a/audio/mp3plot/Makefile b/audio/mp3plot/Makefile
index c45573bf7438..db7848245300 100644
--- a/audio/mp3plot/Makefile
+++ b/audio/mp3plot/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mp3plot
DISTVERSION= 0.6.0
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES= audio
MASTER_SITES= http://p.outlyer.net/mp3plot/files/
diff --git a/devel/synfig/Makefile b/devel/synfig/Makefile
index a5903b5818a8..32f991b927db 100644
--- a/devel/synfig/Makefile
+++ b/devel/synfig/Makefile
@@ -3,7 +3,7 @@
PORTNAME= synfig
PORTVERSION= 1.0.2
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= devel graphics multimedia
MASTER_SITES= SF/${PORTNAME}/releases/${PORTVERSION}/source
diff --git a/editors/emacs-devel/Makefile b/editors/emacs-devel/Makefile
index c2bbf9c987e5..dd7acc26a2e2 100644
--- a/editors/emacs-devel/Makefile
+++ b/editors/emacs-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= emacs
DISTVERSION= ${EMACS_VER}.${EMACS_REV}
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= editors ipv6
PKGNAMESUFFIX= -devel
diff --git a/editors/emacs/Makefile b/editors/emacs/Makefile
index 970519033c5e..fbf605463483 100644
--- a/editors/emacs/Makefile
+++ b/editors/emacs/Makefile
@@ -3,6 +3,7 @@
PORTNAME= emacs
PORTVERSION= ${EMACS_VER}
+PORTREVISION= 1
PORTEPOCH= 3
CATEGORIES= editors ipv6
MASTER_SITES= GNU
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index ff63db7f5cb2..cce59fcc3488 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= ImageMagick
-DISTVERSION= 6.9.8-9
-PORTREVISION= 1
+DISTVERSION= 6.9.9-15
PORTEPOCH= 1
CATEGORIES= graphics perl5
MASTER_SITES= http://www.imagemagick.org/download/ \
@@ -36,7 +35,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libltdl.so:devel/libltdl
-PORTSCOUT?= limit:6.*$$
+PORTSCOUT?= limit:^6\.9\.
CONFLICTS_INSTALL= execline-[0-9]* # bin/import
CONFLICTS_INSTALL+= ImageMagick7 ImageMagick7-nox11 # bin/Magick++-config
@@ -62,10 +61,10 @@ PLIST_SUB= PORTVERSION=${PORTVERSION:R}
OPTIONS_DEFINE= BZIP2 DOCS DJVU FFTW FONTCONFIG FPX FREETYPE \
GRAPHVIZ GSLIB JPEG2000 JBIG JPEG LCMS2 LZMA LQR MODULES \
OPENEXR OPENMP PANGO PDF PERL PNG SVG TESTS TIFF WEBP WMF \
- THREADS X11 16BIT_PIXEL HDRI
-OPTIONS_DEFAULT= 16BIT_PIXEL BZIP2 FFTW FONTCONFIG FPX FREETYPE \
+ THREADS X11 16BIT_PIXEL HDRI RAW
+OPTIONS_DEFAULT= 16BIT_PIXEL BZIP2 FFTW FONTCONFIG FREETYPE \
JPEG2000 JBIG JPEG LCMS2 LZMA LQR MODULES PDF PERL PNG SVG \
- TIFF WEBP WMF THREADS X11
+ TIFF WEBP WMF THREADS X11 RAW
16BIT_PIXEL_DESC= 16bit pixel support
JPEG2000_DESC= OpenJPEG 2000 support via openjpeg
@@ -78,6 +77,12 @@ TESTS_DESC= Run bundled self-tests after build
#SIMD_CONFIGURE_WITH= gcc-arch
CONFIGURE_ARGS+= --without-gcc-arch
+# libraw is by default liked to lcms2, whichs also ends up in IM regardless
+# of the IM LCMS option.
+RAW_CONFIGURE_WITH= raw
+RAW_LIB_DEPENDS= libraw_r.so:graphics/libraw \
+ liblcms2.so:graphics/lcms2
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MHDRI}
diff --git a/graphics/ImageMagick/distinfo b/graphics/ImageMagick/distinfo
index 73bfacbc6c56..684df1fcedce 100644
--- a/graphics/ImageMagick/distinfo
+++ b/graphics/ImageMagick/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1496652633
-SHA256 (ImageMagick-6.9.8-9.tar.xz) = f64f1a66d2a3ec4ff2c79527dd2a773c8c71abb4f8da37af71c270b52be32673
-SIZE (ImageMagick-6.9.8-9.tar.xz) = 8777352
+TIMESTAMP = 1506539505
+SHA256 (ImageMagick-6.9.9-15.tar.xz) = cc5411bcd766efbc5c281ae2147f0d154c452e5f0cc72894796afb88036baf2f
+SIZE (ImageMagick-6.9.9-15.tar.xz) = 8792252
diff --git a/graphics/ImageMagick/pkg-plist b/graphics/ImageMagick/pkg-plist
index 4cfe5496f964..331f43ff8b92 100644
--- a/graphics/ImageMagick/pkg-plist
+++ b/graphics/ImageMagick/pkg-plist
@@ -416,18 +416,18 @@ lib/ImageMagick-%%PORTVERSION%%/config-%%QBIT%%%%HDRI%%/configure.xml
lib/libMagick++-6.a
lib/libMagick++-6.la
lib/libMagick++-6.so
-lib/libMagick++-6.so.7
-lib/libMagick++-6.so.7.0.0
+lib/libMagick++-6.so.8
+lib/libMagick++-6.so.8.0.0
lib/libMagickCore-6.a
lib/libMagickCore-6.la
lib/libMagickCore-6.so
-lib/libMagickCore-6.so.4
-lib/libMagickCore-6.so.4.0.0
+lib/libMagickCore-6.so.5
+lib/libMagickCore-6.so.5.0.0
lib/libMagickWand-6.a
lib/libMagickWand-6.la
lib/libMagickWand-6.so
-lib/libMagickWand-6.so.4
-lib/libMagickWand-6.so.4.0.0
+lib/libMagickWand-6.so.5
+lib/libMagickWand-6.so.5.0.0
%%WITH_PERL%%%%SITE_ARCH%%/Image/Magick.pm
%%WITH_PERL%%%%SITE_ARCH%%/Image/Magick/%%QBIT%%%%HDRI%%.pm
%%WITH_PERL%%%%SITE_ARCH%%/auto/Image/Magick/%%QBIT%%%%HDRI%%/%%QBIT%%%%HDRI%%.so
diff --git a/graphics/autotrace/Makefile b/graphics/autotrace/Makefile
index 7af0bd26bc3a..1a3727886c1f 100644
--- a/graphics/autotrace/Makefile
+++ b/graphics/autotrace/Makefile
@@ -3,7 +3,7 @@
PORTNAME= autotrace
PORTVERSION= 0.31.1
-PORTREVISION= 30
+PORTREVISION= 31
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/AutoTrace/${PORTVERSION}
diff --git a/graphics/converseen/Makefile b/graphics/converseen/Makefile
index 9f433a034061..c8c7e832d413 100644
--- a/graphics/converseen/Makefile
+++ b/graphics/converseen/Makefile
@@ -3,7 +3,7 @@
PORTNAME= converseen
PORTVERSION= 0.9.6.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/Converseen/Converseen%20${PORTVERSION:R:R}/
diff --git a/graphics/dcraw-m/Makefile b/graphics/dcraw-m/Makefile
index f8a5640562c6..7981603908c5 100644
--- a/graphics/dcraw-m/Makefile
+++ b/graphics/dcraw-m/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dcraw-m
PORTVERSION= 9.22
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MAINTAINER= waitman@waitman.net
diff --git a/graphics/dmtx-utils/Makefile b/graphics/dmtx-utils/Makefile
index 5d67696a3d84..43a536e33316 100644
--- a/graphics/dmtx-utils/Makefile
+++ b/graphics/dmtx-utils/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dmtx-utils
PORTVERSION= 0.7.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= SF/libdmtx/libdmtx/${PORTVERSION}
diff --git a/graphics/fpc-imagemagick/Makefile b/graphics/fpc-imagemagick/Makefile
index b46cd3e38a67..714c5a128556 100644
--- a/graphics/fpc-imagemagick/Makefile
+++ b/graphics/fpc-imagemagick/Makefile
@@ -1,7 +1,7 @@
# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics lang
PKGNAMESUFFIX= -imagemagick
diff --git a/graphics/gimp-gmic-plugin/Makefile b/graphics/gimp-gmic-plugin/Makefile
index 09c4373cf823..f4fdf67b6249 100644
--- a/graphics/gimp-gmic-plugin/Makefile
+++ b/graphics/gimp-gmic-plugin/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gmic
PORTVERSION= 1.6.9
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics
MASTER_SITES= http://gmic.eu/files/source/
PKGNAMEPREFIX= gimp-
diff --git a/graphics/gscan2pdf/Makefile b/graphics/gscan2pdf/Makefile
index db04894bd4bd..6fc60cd179d7 100644
--- a/graphics/gscan2pdf/Makefile
+++ b/graphics/gscan2pdf/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gscan2pdf
PORTVERSION= 1.8.2
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF
diff --git a/graphics/hdr_tools/Makefile b/graphics/hdr_tools/Makefile
index fcb98f135043..4f2fb90a06ad 100644
--- a/graphics/hdr_tools/Makefile
+++ b/graphics/hdr_tools/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hdr_tools
PORTVERSION= 0.0.2010.11.23 # unspecified by the author, so use the date
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://ttic.uchicago.edu/~cotter/projects/hdr_tools/archives/ \
http://freebsd.nsu.ru/distfiles/
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index bf7904a3e395..7458cef70e50 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -3,7 +3,7 @@
PORTNAME= inkscape
PORTVERSION= 0.92.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics gnome
MASTER_SITES= https://launchpadlibrarian.net/306309537/ \
LOCAL/kwm
diff --git a/graphics/kipi-plugin-videoslideshow/Makefile b/graphics/kipi-plugin-videoslideshow/Makefile
index 3e6bef138383..c2f307eb8438 100644
--- a/graphics/kipi-plugin-videoslideshow/Makefile
+++ b/graphics/kipi-plugin-videoslideshow/Makefile
@@ -2,7 +2,7 @@
PORTNAME= kipi-plugin-${KIPI_PLUGIN}
PORTVERSION= ${DIGIKAM_VER}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics kde
MAINTAINER= kde@FreeBSD.org
diff --git a/graphics/libboard/Makefile b/graphics/libboard/Makefile
index abf09cbfab21..fd47a2533f66 100644
--- a/graphics/libboard/Makefile
+++ b/graphics/libboard/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libboard
DISTVERSION= 0.9.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MAINTAINER= thierry@FreeBSD.org
diff --git a/graphics/libdmtx/Makefile b/graphics/libdmtx/Makefile
index 6d7f58b3dba1..afa1cb482d9b 100644
--- a/graphics/libdmtx/Makefile
+++ b/graphics/libdmtx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libdmtx
PORTVERSION= 0.7.4
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics
MASTER_SITES= SF
diff --git a/graphics/npretty/Makefile b/graphics/npretty/Makefile
index 4d03f180bca2..e27eebf1ea9f 100644
--- a/graphics/npretty/Makefile
+++ b/graphics/npretty/Makefile
@@ -4,7 +4,7 @@
PORTNAME= npretty
DISTVERSIONPREFIX= n
DISTVERSION= 0.9.3-1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MAINTAINER= peter@pean.org
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index 217b91ba0877..86f15aaa8228 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= opendx
PORTVERSION= 4.4.4
-PORTREVISION= 23
+PORTREVISION= 24
CATEGORIES= graphics math java
MASTER_SITES= http://www.sfr-fresh.com/unix/misc/
DISTNAME= dx-${PORTVERSION}
diff --git a/graphics/p5-Image-Magick-Iterator/Makefile b/graphics/p5-Image-Magick-Iterator/Makefile
index 5dcf5ec57fe6..066169b46650 100644
--- a/graphics/p5-Image-Magick-Iterator/Makefile
+++ b/graphics/p5-Image-Magick-Iterator/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Image-Magick-Iterator
PORTVERSION= 0.01
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/graphics/pecl-imagick/Makefile b/graphics/pecl-imagick/Makefile
index 8f3c65f8edd6..69947704b229 100644
--- a/graphics/pecl-imagick/Makefile
+++ b/graphics/pecl-imagick/Makefile
@@ -3,7 +3,7 @@
PORTNAME= imagick
PORTVERSION= 3.4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MAINTAINER= mm@FreeBSD.org
diff --git a/graphics/php-magickwand/Makefile b/graphics/php-magickwand/Makefile
index 71f97ed38cd9..a22da2ce3409 100644
--- a/graphics/php-magickwand/Makefile
+++ b/graphics/php-magickwand/Makefile
@@ -3,7 +3,7 @@
PORTNAME= magickwand
PORTVERSION= 1.0.9
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
MASTER_SITES= http://www.magickwand.org/download/php/
PKGNAMEPREFIX= php-
diff --git a/graphics/pstoedit/Makefile b/graphics/pstoedit/Makefile
index ffe4d1195202..0c5c64d3577e 100644
--- a/graphics/pstoedit/Makefile
+++ b/graphics/pstoedit/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pstoedit
PORTVERSION= 3.70
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= graphics print
MASTER_SITES= SF
diff --git a/graphics/py-wand/Makefile b/graphics/py-wand/Makefile
index e14db4796ac2..71b55e75e1fc 100644
--- a/graphics/py-wand/Makefile
+++ b/graphics/py-wand/Makefile
@@ -2,7 +2,7 @@
PORTNAME= Wand
PORTVERSION= 0.4.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/graphics/reallyslick/Makefile b/graphics/reallyslick/Makefile
index 4c3e21d8bf10..0b61d9875f47 100644
--- a/graphics/reallyslick/Makefile
+++ b/graphics/reallyslick/Makefile
@@ -3,7 +3,7 @@
PORTNAME= reallyslick
PORTVERSION= 0.9.1
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES= graphics
MASTER_SITES= SF/rss-glx/rss-glx/${PORTVERSION}
DISTNAME= rss-glx_${PORTVERSION}
diff --git a/graphics/rubygem-rmagick/Makefile b/graphics/rubygem-rmagick/Makefile
index fcb667328c11..f1c8d7315b73 100644
--- a/graphics/rubygem-rmagick/Makefile
+++ b/graphics/rubygem-rmagick/Makefile
@@ -2,7 +2,7 @@
PORTNAME= rmagick
PORTVERSION= 2.16.0
-PORTREVISION= 3
+PORTREVISION= 5
CATEGORIES= graphics rubygems
MASTER_SITES= RG
diff --git a/graphics/timg/Makefile b/graphics/timg/Makefile
index d8a8b60b379a..52025820fcd9 100644
--- a/graphics/timg/Makefile
+++ b/graphics/timg/Makefile
@@ -3,7 +3,7 @@
PORTNAME= timg
PORTVERSION= 0.9.5
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MAINTAINER= uzsolt@uzsolt.hu
diff --git a/graphics/zbar/Makefile b/graphics/zbar/Makefile
index a8d45cdf0b5d..12194f5b7f92 100644
--- a/graphics/zbar/Makefile
+++ b/graphics/zbar/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zbar
PORTVERSION= 0.10
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= graphics
MASTER_SITES= SF
diff --git a/misc/img2xterm/Makefile b/misc/img2xterm/Makefile
index 298f2d9464a2..3aaae5dd0746 100644
--- a/misc/img2xterm/Makefile
+++ b/misc/img2xterm/Makefile
@@ -3,7 +3,7 @@
PORTNAME= img2xterm
PORTVERSION= 1.0.0
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc
MAINTAINER= arved@FreeBSD.org
diff --git a/multimedia/emby-server/Makefile b/multimedia/emby-server/Makefile
index 71ba9790c100..5660c34737d1 100644
--- a/multimedia/emby-server/Makefile
+++ b/multimedia/emby-server/Makefile
@@ -3,6 +3,7 @@
PORTNAME= emby-server
PORTVERSION= 3.2.32.0
+PORTREVISION= 1
CATEGORIES= multimedia
MAINTAINER= woodsb02@FreeBSD.org
diff --git a/security/libfprint/Makefile b/security/libfprint/Makefile
index a56f91afdf0d..cb18290e3049 100644
--- a/security/libfprint/Makefile
+++ b/security/libfprint/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libfprint
PORTVERSION= 0.6.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= http://people.freedesktop.org/~hadess/
diff --git a/www/WebMagick/Makefile b/www/WebMagick/Makefile
index f89c17b540be..0ec5d54347c0 100644
--- a/www/WebMagick/Makefile
+++ b/www/WebMagick/Makefile
@@ -3,7 +3,7 @@
PORTNAME= WebMagick
PORTVERSION= 2.03p29
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www graphics
MASTER_SITES= SF/${PORTNAME:tl}/${PORTNAME:tl}-beta/${DISTVERSION}
diff --git a/x11-wm/libwraster/Makefile b/x11-wm/libwraster/Makefile
index 6bcc8b8dbf6f..ad20a3125472 100644
--- a/x11-wm/libwraster/Makefile
+++ b/x11-wm/libwraster/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libwraster
PORTVERSION= 0.95.7
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-wm windowmaker
MASTER_SITES= http://windowmaker.org/pub/source/release/
DISTNAME= WindowMaker-${PORTVERSION}
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index 8ed7816889cc..d758e00b1cf9 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -3,7 +3,7 @@
PORTNAME= windowmaker
PORTVERSION= 0.95.7
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-wm windowmaker
MASTER_SITES= http://windowmaker.org/pub/source/release/
DISTNAME= WindowMaker-${PORTVERSION}