summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/gstreamer-plugins-sndio/Makefile3
-rw-r--r--audio/gstreamer1-plugins-sndio/Makefile3
-rw-r--r--audio/spectrogram/Makefile2
-rw-r--r--deskutils/copyq/Makefile2
-rw-r--r--devel/allegro/Makefile2
-rw-r--r--devel/plan9port/Makefile2
-rw-r--r--emulators/gxemul/Makefile1
-rw-r--r--games/adonthell/Makefile2
-rw-r--r--games/etracer/Makefile2
-rw-r--r--games/iortcw/Makefile2
-rw-r--r--games/openmw/Makefile2
-rw-r--r--graphics/waylandpp/Makefile2
-rw-r--r--java/openjfx8-devel/Makefile3
-rw-r--r--sysutils/contractor/Makefile2
-rw-r--r--x11-wm/cwm/Makefile2
-rw-r--r--x11/alacritty/Makefile2
-rw-r--r--x11/simplestroke/Makefile1
-rw-r--r--x11/workrave/Makefile4
-rw-r--r--x11/xbanish/Makefile2
19 files changed, 21 insertions, 20 deletions
diff --git a/audio/gstreamer-plugins-sndio/Makefile b/audio/gstreamer-plugins-sndio/Makefile
index a33bb38a73b1..a23a03fe8225 100644
--- a/audio/gstreamer-plugins-sndio/Makefile
+++ b/audio/gstreamer-plugins-sndio/Makefile
@@ -14,10 +14,9 @@ LIB_DEPENDS= libgstaudio-0.10.so:multimedia/gstreamer-plugins \
libgstbase-0.10.so:multimedia/gstreamer \
libsndio.so:audio/sndio
+USES= gnome pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= t6
-
-USES= pkgconfig
USE_GNOME= glib20
PLIST_FILES= lib/gstreamer-0.10/libgstsndio.so
diff --git a/audio/gstreamer1-plugins-sndio/Makefile b/audio/gstreamer1-plugins-sndio/Makefile
index 1cb65e6a57a4..992c2cb23c46 100644
--- a/audio/gstreamer1-plugins-sndio/Makefile
+++ b/audio/gstreamer1-plugins-sndio/Makefile
@@ -14,10 +14,9 @@ LIB_DEPENDS= libgstaudio-1.0.so:multimedia/gstreamer1-plugins \
libgstbase-1.0.so:multimedia/gstreamer1 \
libsndio.so:audio/sndio
+USES= gnome pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= t6
-
-USES= pkgconfig
USE_GNOME= glib20
PLIST_FILES= lib/gstreamer-1.0/libgstsndio.so
diff --git a/audio/spectrogram/Makefile b/audio/spectrogram/Makefile
index 8b229313a1d4..10148a2697a2 100644
--- a/audio/spectrogram/Makefile
+++ b/audio/spectrogram/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libfftw3.so:math/fftw3 \
libsndio.so:audio/sndio
-USES= pkgconfig
+USES= pkgconfig xorg
USE_XORG= x11
USE_GITHUB= yes
diff --git a/deskutils/copyq/Makefile b/deskutils/copyq/Makefile
index 70489a2ba99f..a52246f0f6f3 100644
--- a/deskutils/copyq/Makefile
+++ b/deskutils/copyq/Makefile
@@ -11,7 +11,7 @@ COMMENT= Qt5 based clipboard manager
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake compiler:c++11-lang qt:5
+USES= cmake compiler:c++11-lang qt:5 xorg
USE_GITHUB= yes
GH_ACCOUNT= hluk
GH_PROJECT= CopyQ
diff --git a/devel/allegro/Makefile b/devel/allegro/Makefile
index cc52b6fe275a..6b91678dde50 100644
--- a/devel/allegro/Makefile
+++ b/devel/allegro/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libogg.so:audio/libogg \
libpng.so:graphics/png \
libvorbis.so:audio/libvorbis
-USES= cmake gl makeinfo pkgconfig
+USES= cmake gl makeinfo pkgconfig xorg
USE_GL= gl glu
USE_XORG= ice sm x11 xcursor xext xpm xxf86dga xxf86vm
USE_LDCONFIG= yes
diff --git a/devel/plan9port/Makefile b/devel/plan9port/Makefile
index 31edeb1079d4..f5cf6497d87d 100644
--- a/devel/plan9port/Makefile
+++ b/devel/plan9port/Makefile
@@ -22,7 +22,7 @@ BROKEN_armv7= fails to compile: thread.c:130:5: no member named 'arm_r0' in 'mc
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
-USES= localbase:ldflags perl5 shebangfix
+USES= localbase:ldflags perl5 shebangfix xorg
USE_GITHUB= yes
GH_ACCOUNT= 9fans
GH_TAGNAME= e995a0c101863688d5f14649ae3de45a7c43789c
diff --git a/emulators/gxemul/Makefile b/emulators/gxemul/Makefile
index 526413f41795..f13b4ceeac22 100644
--- a/emulators/gxemul/Makefile
+++ b/emulators/gxemul/Makefile
@@ -31,6 +31,7 @@ OPTIONS_DEFINE= DOCS X11
OPTIONS_DEFAULT= X11
X11_RUN_DEPENDS= xterm:x11/xterm
+X11_USES= xorg
X11_USE= XORG=x11
X11_CONFIGURE_OFF= --disable-x
diff --git a/games/adonthell/Makefile b/games/adonthell/Makefile
index 9e38496232f1..8a3e6edfe5c9 100644
--- a/games/adonthell/Makefile
+++ b/games/adonthell/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis
-USES= gettext gmake localbase pkgconfig python:2.7
+USES= gettext gmake localbase pkgconfig python:2.7 sdl
USE_SDL= mixer2 ttf2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-py-debug --disable-pyc \
diff --git a/games/etracer/Makefile b/games/etracer/Makefile
index f2ecbbcae453..e3302b386cbd 100644
--- a/games/etracer/Makefile
+++ b/games/etracer/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libsfml-system.so:devel/sfml
-USES= compiler:c++11-lang pkgconfig tar:xz
+USES= compiler:c++11-lang gl pkgconfig tar:xz xorg
USE_GL= gl glu
GNU_CONFIGURE= yes
diff --git a/games/iortcw/Makefile b/games/iortcw/Makefile
index ef8c25ae61af..522e9047ba1e 100644
--- a/games/iortcw/Makefile
+++ b/games/iortcw/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libopus.so:audio/opus \
libopusfile.so:audio/opusfile
-USES= gl gmake jpeg openal pkgconfig sdl
+USES= gl gmake jpeg openal pkgconfig sdl xorg
USE_GITHUB= yes
USE_GL= gl
USE_SDL= sdl2
diff --git a/games/openmw/Makefile b/games/openmw/Makefile
index 36a245d65691..fc5f2e3b567d 100644
--- a/games/openmw/Makefile
+++ b/games/openmw/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
libosg.so:graphics/osg \
libunshield.so:archivers/unshield
-USES= cmake compiler:c++14-lang gl openal pkgconfig qt:5 sdl
+USES= cmake compiler:c++14-lang gl openal pkgconfig qt:5 sdl xorg
USE_GITHUB= yes
GH_ACCOUNT= OpenMW
USE_GL= gl
diff --git a/graphics/waylandpp/Makefile b/graphics/waylandpp/Makefile
index a510aa3df768..cefc16a6244a 100644
--- a/graphics/waylandpp/Makefile
+++ b/graphics/waylandpp/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libpugixml.so:textproc/pugixml \
libwayland-egl.so:graphics/wayland
-USES= cmake compiler:c++11-lang gl localbase:ldflags pkgconfig
+USES= cmake compiler:c++11-lang gl localbase:ldflags pkgconfig xorg
USE_GITHUB= yes
GH_ACCOUNT= NilsBrause
USE_GL= egl
diff --git a/java/openjfx8-devel/Makefile b/java/openjfx8-devel/Makefile
index 323cf87e8297..7b71e5bd1134 100644
--- a/java/openjfx8-devel/Makefile
+++ b/java/openjfx8-devel/Makefile
@@ -26,7 +26,8 @@ BUILD_DEPENDS= apache-ant>0:devel/apache-ant \
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= gettext-runtime gl gnome jpeg localbase:ldflags pkgconfig sqlite
+USES= gettext-runtime gl gnome jpeg localbase:ldflags pkgconfig \
+ sqlite xorg
USE_GL= gl
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk20 gtk30 pango
USE_JAVA= yes
diff --git a/sysutils/contractor/Makefile b/sysutils/contractor/Makefile
index 5f050e350628..98b3d5b7422f 100644
--- a/sysutils/contractor/Makefile
+++ b/sysutils/contractor/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= valac:lang/vala
LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libgee-0.8.so:devel/libgee
-USES= gettext-runtime meson pkgconfig tar:xz
+USES= gettext-runtime gnome meson pkgconfig tar:xz
USE_GITHUB= yes
GH_ACCOUNT= elementary
USE_GNOME= glib20
diff --git a/x11-wm/cwm/Makefile b/x11-wm/cwm/Makefile
index ea819e906f42..24d727eb8a86 100644
--- a/x11-wm/cwm/Makefile
+++ b/x11-wm/cwm/Makefile
@@ -13,7 +13,7 @@ LICENSE= ISCL
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= pkgconfig shebangfix
+USES= pkgconfig shebangfix xorg
USE_XORG= x11 xft xinerama xrandr
PLIST_FILES= bin/cwm \
diff --git a/x11/alacritty/Makefile b/x11/alacritty/Makefile
index e650721c48e5..aeb933408c42 100644
--- a/x11/alacritty/Makefile
+++ b/x11/alacritty/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE-APACHE
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= cargo python:3.6+,build ssl:build
+USES= cargo python:3.6+,build ssl:build xorg
USE_GITHUB= yes
GH_ACCOUNT= jwilm
USE_XORG= xcb
diff --git a/x11/simplestroke/Makefile b/x11/simplestroke/Makefile
index 0d727bd4aba8..51edd4f60b0a 100644
--- a/x11/simplestroke/Makefile
+++ b/x11/simplestroke/Makefile
@@ -38,6 +38,7 @@ X11_DESC= XTEST based mouse tracker
SUID_VARS_OFF= _MAYBE_SUID=""
SUID_VARS= _MAYBE_SUID="@(,,4755) "
+X11_USES= xorg
X11_USE= XORG=x11,xtst
pre-configure-X11-off:
diff --git a/x11/workrave/Makefile b/x11/workrave/Makefile
index e65627948eaa..8dba0571546e 100644
--- a/x11/workrave/Makefile
+++ b/x11/workrave/Makefile
@@ -14,8 +14,8 @@ LICENSE= GPLv3+
LIB_DEPENDS= libgdome.so:textproc/gdome2
-USES= compiler:c++11-lang autoreconf:build gettext gmake libtool \
- localbase pathfix pkgconfig
+USES= autoreconf:build compiler:c++11-lang gettext gmake gnome \
+ libtool localbase pathfix pkgconfig xorg
USE_CXXSTD= c++11
USE_XORG= ice xorgproto sm x11 xext xmu xscrnsaver xtst
USE_GNOME= intltool intlhack introspection gtkmm30
diff --git a/x11/xbanish/Makefile b/x11/xbanish/Makefile
index 25a495c4c733..fcf18f1bd082 100644
--- a/x11/xbanish/Makefile
+++ b/x11/xbanish/Makefile
@@ -11,9 +11,9 @@ COMMENT= Banish the mouse cursor when typing
LICENSE= BSD3CLAUSE
+USES= xorg
USE_GITHUB= yes
GH_ACCOUNT= jcs
-
USE_XORG= x11 xfixes xi xt
MAKE_ARGS= X11BASE="${LOCALBASE}"