summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/fetchmail/Makefile7
-rw-r--r--mail/fetchmail/distinfo6
-rw-r--r--mail/fetchmail/files/patch-fetchmail.man10
-rw-r--r--mail/fetchmail/files/patch-t.smoke10
-rw-r--r--mail/fetchmailconf/Makefile23
-rw-r--r--mail/fetchmailconf/files/patch-fetchmailconf.py24
6 files changed, 47 insertions, 33 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index 1d0ee27de657..6d7ce4758b20 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -2,9 +2,10 @@
# $FreeBSD$
PORTNAME?= fetchmail
-PORTVERSION= 6.4.1
-PORTREVISION= 1
+PORTVERSION= 6.4.2
CATEGORIES= mail
+# The next line is inherited by the fetchmailconf slave port,
+# do NOT replace fetchmail by ${PORTNAME}
MASTER_SITES= SF/fetchmail/branch_6.4/
MAINTAINER= chalpin@cs.wisc.edu
@@ -71,7 +72,7 @@ PATCH_STRIP= -p1
.if empty(MASTERDIR)
post-build:
- ${MAKE_CMD} -C ${WRKSRC} check ; { r=$$? ; ( set -x ; cat "${WRKSRC}/test-suite.log" ) ; exit $$r ; }
+ ${MAKE_CMD} -C ${WRKSRC} check ; { r=$$? ; ( set -x ; ${CAT} "${WRKSRC}/test-suite.log" ) ; exit $$r ; }
post-install:
${INSTALL} -d ${STAGEDIR}/var/run/fetchmail
diff --git a/mail/fetchmail/distinfo b/mail/fetchmail/distinfo
index 1f8f5956c8a8..4f81555eb93b 100644
--- a/mail/fetchmail/distinfo
+++ b/mail/fetchmail/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1569677341
-SHA256 (fetchmail-6.4.1.tar.xz) = 3f33f11dd08c3e8cc3e9d18eec686b1626d4818f4d5a72791507bbc4dce6a9a0
-SIZE (fetchmail-6.4.1.tar.xz) = 1257488
+TIMESTAMP = 1581675882
+SHA256 (fetchmail-6.4.2.tar.xz) = e21f6b3326f29fdb0c4786b5602aa4b9e668805424d0708eb42be6395c1ca630
+SIZE (fetchmail-6.4.2.tar.xz) = 1261472
diff --git a/mail/fetchmail/files/patch-fetchmail.man b/mail/fetchmail/files/patch-fetchmail.man
deleted file mode 100644
index 800b36315646..000000000000
--- a/mail/fetchmail/files/patch-fetchmail.man
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/fetchmail.man 2019-09-28 11:09:52.000000000 +0200
-+++ b/fetchmail.man 2019-10-03 11:28:41.306247000 +0200
-@@ -1891,7 +1891,6 @@
- user[name] \-u \& T{
- This is the user description and must come first after server
- description and after possible server options, and before user options.
--.br
- It sets the remote user name if by itself or followed by 'there', or the
- local user name if followed by 'here'.
- T}
diff --git a/mail/fetchmail/files/patch-t.smoke b/mail/fetchmail/files/patch-t.smoke
deleted file mode 100644
index 91a43967d1e3..000000000000
--- a/mail/fetchmail/files/patch-t.smoke
+++ /dev/null
@@ -1,10 +0,0 @@
---- fetchmail-6.4.1/t.smoke 2019-08-20 18:00:35.000000000 -0500
-+++ fetchmail-6.4.1-patched/t.smoke 2019-09-30 19:20:23.633504000 -0500
-@@ -4,6 +4,7 @@
- # configuration and dump it in human-readable and machine-readable form.
-
- set -e
-+export HOME=/tmp
- trap 'rm -f t.rc.$$' 0
- cp "${srcdir}/t.rc" t.rc.$$
- chmod 0400 t.rc.$$
diff --git a/mail/fetchmailconf/Makefile b/mail/fetchmailconf/Makefile
index f5e4287da235..7e26b6e8be22 100644
--- a/mail/fetchmailconf/Makefile
+++ b/mail/fetchmailconf/Makefile
@@ -2,22 +2,27 @@
PORTNAME= fetchmailconf
DISTNAME= fetchmail-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
+# NOTE: MASTER_SITES in ../fetchmail must NOT use the $PORTNAME variable,
+# else _this_ port (fetchmailconf) becomes unfetchable
MAINTAINER= chalpin@cs.wisc.edu
COMMENT= Python-based GUI to configure fetchmail
-# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=244130 has an update to get it
-# compatible to Python 3.
-
LICENSE= GPLv2 LGPL21
LICENSE_COMB= dual
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>=0:x11-toolkits/py-tkinter@${PY_FLAVOR} \
+# minimum required version 6.4.2 - not codified, on the assumption
+# that fetchmail port updated at the same time
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>=0:x11-toolkits/py-tkinter@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}future>=0:devel/py-future@${PY_FLAVOR} \
fetchmail>=${PORTVERSION}:mail/fetchmail
+RUN_DEPENDS+= ${BUILD_DEPENDS}
-USES= python:2.7 shebangfix tar:xz
+USES= python shebangfix tar:xz
+USE_PYTHON= py3kplist
FILESDIR= ${.CURDIR}/files
+PATCHDIR= ${FILESDIR}
SUB_FILES= fetchmailconf
SUB_LIST= PYTHON_CMD=${PYTHON_CMD} PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR}
@@ -30,8 +35,12 @@ ALL_TARGET= fetchmailconf
INSTALL_TARGET= install-data-am install-nodist_binSCRIPTS install-man
post-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/fetchmailconf ${STAGEDIR}${PREFIX}/bin
- ${RM} ${STAGEDIR}${PREFIX}/man/man1/fetchmail.1*
+# first, run smoke tests - the version check makes sure we have all
+# modules listed in the *_DEPENDS variables:
+ ${PYTHON_CMD} ${WRKSRC}/fetchmailconf.py -V
+# then install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/fetchmailconf ${STAGEDIR}${PREFIX}/bin
+ ${RM} ${STAGEDIR}${PREFIX}/man/man1/fetchmail.1*
MASTERDIR= ${.CURDIR}/../fetchmail
diff --git a/mail/fetchmailconf/files/patch-fetchmailconf.py b/mail/fetchmailconf/files/patch-fetchmailconf.py
new file mode 100644
index 000000000000..0e6953efb7a7
--- /dev/null
+++ b/mail/fetchmailconf/files/patch-fetchmailconf.py
@@ -0,0 +1,24 @@
+--- fetchmailconf.py.orig 2020-01-31 20:22:54 UTC
++++ fetchmailconf.py
+@@ -2132,10 +2132,6 @@ def copy_instance(toclass, fromdict):
+
+ if __name__ == '__main__':
+
+- if "DISPLAY" not in os.environ:
+- print("fetchmailconf must be run under X")
+- sys.exit(1)
+-
+ fetchmail_icon = """
+ R0lGODdhPAAoAPcAAP///wgICBAQEISEhIyMjJSUlKWlpa2trbW1tcbGxs7Ozufn5+/v7//39yEY
+ GNa9tUoxKZyEe1o5KTEQAN7OxpyMhIRjUvfn3pxSKYQ5EO/Wxv/WvWtSQrVzSmtCKWspAMatnP/e
+@@ -2202,6 +2198,10 @@ fetchmailconf comes with ABSOLUTELY NO WARRANTY. This
+ welcome to redistribute it under certain conditions. Please see the file
+ COPYING in the source or documentation directory for details.""")
+ sys.exit(0)
++
++ if "DISPLAY" not in os.environ:
++ print("fetchmailconf must be run under X")
++ sys.exit(1)
+
+ # Get client host's FQDN
+ hostname = socket.gethostname()