summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING12
-rw-r--r--databases/sqlite3/Makefile4
2 files changed, 15 insertions, 1 deletions
diff --git a/UPDATING b/UPDATING
index 6d648be11f16..2def2788a33b 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,18 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20230313:
+ AFFECTS: users of databases/sqlite3
+ AUTHOR: fuz@FreeBSD.org
+
+ Due to various ports not being prepared for this change (see 20230227
+ entry), the DQS option of databases/sqlite3 has been reenabled as a
+ stop gap measure. It is scheduled to be disabled again for good no
+ earlier than 20240101, giving downstream software authors more time
+ to fix their queries.
+
+ See also: https://sqlite.org/quirks.html#dblquote
+
20230311:
AFFECTS: users of net/dshell
AUTHOR: nobutaka@FreeBSD.org
diff --git a/databases/sqlite3/Makefile b/databases/sqlite3/Makefile
index 993737673af6..a0ffcd221d5c 100644
--- a/databases/sqlite3/Makefile
+++ b/databases/sqlite3/Makefile
@@ -1,5 +1,6 @@
PORTNAME= sqlite3
DISTVERSION= 3.41.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= databases
MASTER_SITES= https://www.sqlite.org/${_YEAR}/ https://www2.sqlite.org/${_YEAR}/ https://www3.sqlite.org/${_YEAR}/
@@ -74,7 +75,7 @@ OPTIONS_DEFINE+= ARMOR DBPAGE DBSTAT DIRECT_READ DQS EXTENSION FTS3_TOKEN \
SORT_REF STATIC STMT TRUSTED_SCHEMA UNKNOWN_SQL UNLOCK_NOTIFY \
UPDATE_LIMIT URI URI_AUTHORITY
.endif
-OPTIONS_DEFAULT= DBPAGE DBSTAT EXTENSION FTS3_TOKEN FTS4 FTS5 LIBEDIT METADATA \
+OPTIONS_DEFAULT= DBPAGE DBSTAT DQS EXTENSION FTS3_TOKEN FTS4 FTS5 LIBEDIT METADATA \
RTREE SECURE_DELETE STRIP THREADS TS1 UNICODE61 UNLOCK_NOTIFY URI
# SECURE_DELETE, UNLOCK_NOTIFY, DBSTAT (since 41.0) used by www/firefox et al.
# RTREE used by graphics/mapnik, databases/spatialite
@@ -82,6 +83,7 @@ OPTIONS_DEFAULT= DBPAGE DBSTAT EXTENSION FTS3_TOKEN FTS4 FTS5 LIBEDIT METADATA \
# FTS5 used by sysutils/tracker
# JSON1 used by net-im/py-matrix-synapse
# DBPAGE used by audio/audacity (since 3.0.0)
+# DQS used by multimedia/emby-server, multimedia/tautulli, net/vnstat, www/qutebrowser
#
.if !defined(TEA)
OPTIONS_GROUP= OPT_EXT OPT_FUNC RTREEG UNICODE