summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/dovecot-xaps/Makefile37
-rw-r--r--mail/dovecot-xaps/distinfo3
-rw-r--r--mail/dovecot-xaps/files/patch-CMakeLists.txt10
-rw-r--r--mail/dovecot-xaps/pkg-descr4
-rw-r--r--mail/dovecot-xaps/pkg-message18
6 files changed, 73 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index d99ffef9b74b..4c3f82fc239a 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -102,6 +102,7 @@
SUBDIR += dovecot-fts-flatcurve
SUBDIR += dovecot-fts-xapian
SUBDIR += dovecot-pigeonhole
+ SUBDIR += dovecot-xaps
SUBDIR += dspam
SUBDIR += ecartis
SUBDIR += elm
diff --git a/mail/dovecot-xaps/Makefile b/mail/dovecot-xaps/Makefile
new file mode 100644
index 000000000000..911e958b268b
--- /dev/null
+++ b/mail/dovecot-xaps/Makefile
@@ -0,0 +1,37 @@
+PORTNAME= dovecot-xaps
+DISTVERSION= g20210623
+CATEGORIES= mail
+
+MAINTAINER= PopularMoment@protonmail.com
+COMMENT= Apple push notifications plugin for dovecot
+WWW= https://github.com/freswa/dovecot-xaps-plugin
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= dovecot>=2.3.17:mail/dovecot
+RUN_DEPENDS= dovecot>=2.3.17:mail/dovecot \
+ xapsd:net/xapsd
+
+USES= cmake compiler:c11
+CMAKE_BUILD_TYPE= Release
+CMAKE_ARGS+= -DCMAKE_INSTALL_PREFIX=${PREFIX}
+
+USE_GITHUB= yes
+GH_ACCOUNT= freswa
+GH_PROJECT= dovecot-xaps-plugin
+GH_TAGNAME= 197d68e
+
+LDFLAGS+= -L${LOCALBASE}/lib
+USE_LDCONFIG= ${PREFIX}/lib/dovecot
+
+PLIST_FILES= etc/dovecot/example-config/conf.d/95-xaps.conf \
+ lib/dovecot/lib25_xaps_imap_plugin.so \
+ lib/dovecot/lib25_xaps_push_notification_plugin.so
+
+post-stage:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/dovecot/example-config/conf.d/
+ ${INSTALL_DATA} ${WRKSRC}/xaps.conf \
+ ${STAGEDIR}${PREFIX}/etc/dovecot/example-config/conf.d/95-xaps.conf
+
+.include <bsd.port.mk>
diff --git a/mail/dovecot-xaps/distinfo b/mail/dovecot-xaps/distinfo
new file mode 100644
index 000000000000..262956e54a3c
--- /dev/null
+++ b/mail/dovecot-xaps/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1677281432
+SHA256 (freswa-dovecot-xaps-plugin-g20210623-197d68e_GH0.tar.gz) = a7c1fd8e69477ebd64d18c45782ceb8cd6c4d857d78031c52535870b2b52e1d9
+SIZE (freswa-dovecot-xaps-plugin-g20210623-197d68e_GH0.tar.gz) = 10460
diff --git a/mail/dovecot-xaps/files/patch-CMakeLists.txt b/mail/dovecot-xaps/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..7b6df84ee3ac
--- /dev/null
+++ b/mail/dovecot-xaps/files/patch-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- CMakeLists.txt.orig 2023-02-25 01:00:54 UTC
++++ CMakeLists.txt
+@@ -34,5 +34,5 @@ target_link_libraries(lib25_xaps_imap_plugin ${LIBDOVE
+ set_target_properties(lib25_xaps_push_notification_plugin PROPERTIES PREFIX "")
+ set_target_properties(lib25_xaps_imap_plugin PROPERTIES PREFIX "")
+
+-install(TARGETS lib25_xaps_push_notification_plugin DESTINATION /usr/lib/dovecot/modules)
+-install(TARGETS lib25_xaps_imap_plugin DESTINATION /usr/lib/dovecot/modules)
++install(TARGETS lib25_xaps_push_notification_plugin DESTINATION lib/dovecot)
++install(TARGETS lib25_xaps_imap_plugin DESTINATION lib/dovecot)
diff --git a/mail/dovecot-xaps/pkg-descr b/mail/dovecot-xaps/pkg-descr
new file mode 100644
index 000000000000..f37db656e2b9
--- /dev/null
+++ b/mail/dovecot-xaps/pkg-descr
@@ -0,0 +1,4 @@
+Apple push notifications plugin for dovecot.
+
+Together with net/xapsd this will enable push email
+for iOS devices that talk to your dovecot IMAP server.
diff --git a/mail/dovecot-xaps/pkg-message b/mail/dovecot-xaps/pkg-message
new file mode 100644
index 000000000000..d4865c3c76dc
--- /dev/null
+++ b/mail/dovecot-xaps/pkg-message
@@ -0,0 +1,18 @@
+[
+{ type: install
+ message: <<EOM
+
+ This port assumes you are familiar with Dovecot and have it installed
+ and running on the system you have installed this plugin on.
+
+ You can enable the plugin by adding the contents of
+ ${PREFIX}/etc/dovecot/example-config/conf.d/95-xaps.conf to your
+ dovecot.conf.
+
+ You must be using Dovecot LDA or LMTP for local delivery.
+
+ net/xapsd must be configured and running.
+
+EOM
+}
+]