summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/opal/Makefile5
-rw-r--r--net/opal3/Makefile5
2 files changed, 10 insertions, 0 deletions
diff --git a/net/opal/Makefile b/net/opal/Makefile
index 1548e3c442a9..ef2c52fb2f26 100644
--- a/net/opal/Makefile
+++ b/net/opal/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= pt_r.1:${PORTSDIR}/devel/pwlib
WRKSRC= ${WRKDIR}/${PORTNAME}_v${PORTVERSION:S/./_/g}
+# In opal's Makefile the default make's target is optshared
ALL_TARGET= optshared
USE_GMAKE= yes
USE_AUTOTOOLS= autoconf:259
@@ -32,6 +33,10 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= Does not build on FreeBSD 4.x, if you manage to make it work, please send a patch to the maintainer: ${MAINTAINER}
+.endif
+
.ifdef (WITH_FFMPEG)
LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
CONFIGURE_ARGS+= --enable-h263avcodec=${LOCALBASE}/include/ffmpeg
diff --git a/net/opal3/Makefile b/net/opal3/Makefile
index 1548e3c442a9..ef2c52fb2f26 100644
--- a/net/opal3/Makefile
+++ b/net/opal3/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= pt_r.1:${PORTSDIR}/devel/pwlib
WRKSRC= ${WRKDIR}/${PORTNAME}_v${PORTVERSION:S/./_/g}
+# In opal's Makefile the default make's target is optshared
ALL_TARGET= optshared
USE_GMAKE= yes
USE_AUTOTOOLS= autoconf:259
@@ -32,6 +33,10 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= Does not build on FreeBSD 4.x, if you manage to make it work, please send a patch to the maintainer: ${MAINTAINER}
+.endif
+
.ifdef (WITH_FFMPEG)
LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
CONFIGURE_ARGS+= --enable-h263avcodec=${LOCALBASE}/include/ffmpeg