summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/strongswan/Makefile3
-rw-r--r--security/strongswan/distinfo4
-rw-r--r--security/strongswan/files/patch-src_starter_starterstroke.c10
-rw-r--r--security/strongswan/files/patch-src_stroke_stroke.c10
4 files changed, 23 insertions, 4 deletions
diff --git a/security/strongswan/Makefile b/security/strongswan/Makefile
index e1f63ea2e93e..d8f59c8e2c38 100644
--- a/security/strongswan/Makefile
+++ b/security/strongswan/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= strongswan
-PORTVERSION= 5.3.0
-PORTREVISION= 1
+PORTVERSION= 5.3.2
CATEGORIES= security
MASTER_SITES= http://download.strongswan.org/ \
http://download2.strongswan.org/
diff --git a/security/strongswan/distinfo b/security/strongswan/distinfo
index 704416a39f0e..8aa04c7df962 100644
--- a/security/strongswan/distinfo
+++ b/security/strongswan/distinfo
@@ -1,2 +1,2 @@
-SHA256 (strongswan-5.3.0.tar.bz2) = 824da31a1ff89ac2500d56705e6f9ce06fe5260f9caaeb1da35ea13a8691d284
-SIZE (strongswan-5.3.0.tar.bz2) = 4263420
+SHA256 (strongswan-5.3.2.tar.bz2) = a4a9bc8c4e42bdc4366a87a05a02bf9f425169a7ab0c6f4482d347e44acbf225
+SIZE (strongswan-5.3.2.tar.bz2) = 4320601
diff --git a/security/strongswan/files/patch-src_starter_starterstroke.c b/security/strongswan/files/patch-src_starter_starterstroke.c
new file mode 100644
index 000000000000..63157e628a2d
--- /dev/null
+++ b/security/strongswan/files/patch-src_starter_starterstroke.c
@@ -0,0 +1,10 @@
+--- src/starter/starterstroke.c.orig 2015-06-09 09:46:26 UTC
++++ src/starter/starterstroke.c
+@@ -16,6 +16,7 @@
+
+ #include <unistd.h>
+ #include <stdlib.h>
++#include <stdint.h>
+ #include <string.h>
+
+ #include <credentials/auth_cfg.h>
diff --git a/security/strongswan/files/patch-src_stroke_stroke.c b/security/strongswan/files/patch-src_stroke_stroke.c
new file mode 100644
index 000000000000..39b990f070ae
--- /dev/null
+++ b/security/strongswan/files/patch-src_stroke_stroke.c
@@ -0,0 +1,10 @@
+--- src/stroke/stroke.c.orig 2015-06-09 09:46:03 UTC
++++ src/stroke/stroke.c
+@@ -17,6 +17,7 @@
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <stdio.h>
++#include <stdint.h>
+ #include <string.h>
+ #include <getopt.h>
+