summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--cad/brickutils/Makefile2
-rw-r--r--cad/fritzing/Makefile3
-rw-r--r--cad/geda/Makefile2
-rw-r--r--cad/sp2sp/Makefile2
-rw-r--r--cad/tkgate/Makefile2
-rw-r--r--cad/transcalc/Makefile2
-rw-r--r--chinese/fcitx-chewing/Makefile2
-rw-r--r--chinese/fcitx-configtool/Makefile2
-rw-r--r--chinese/fcitx-libpinyin/Makefile2
-rw-r--r--chinese/fcitx-rime/Makefile2
-rw-r--r--chinese/fcitx-sunpinyin/Makefile2
-rw-r--r--chinese/fcitx-table-extra/Makefile2
-rw-r--r--chinese/ibus-array/Makefile3
-rw-r--r--chinese/ibus-cangjie/Makefile2
-rw-r--r--chinese/ibus-pinyin/Makefile3
-rw-r--r--chinese/pcmanx/Makefile2
-rw-r--r--chinese/pyzy/Makefile3
-rw-r--r--chinese/wenju/Makefile2
-rw-r--r--comms/freedv/Makefile2
-rw-r--r--comms/gnocky/Makefile2
-rw-r--r--comms/gnokii/Makefile4
-rw-r--r--comms/grig/Makefile2
-rw-r--r--comms/hamlib/Makefile3
-rw-r--r--comms/kb/Makefile2
-rw-r--r--comms/libimobiledevice/Makefile1
-rw-r--r--comms/libticables2/Makefile3
-rw-r--r--comms/libticalcs2/Makefile3
-rw-r--r--comms/lysdr/Makefile2
-rw-r--r--comms/pear-Horde_ActiveSync/Makefile2
-rw-r--r--comms/syncterm/Makefile1
-rw-r--r--comms/tilp2/Makefile5
-rw-r--r--comms/xdx/Makefile2
-rw-r--r--comms/xmorse/Makefile1
-rw-r--r--comms/xnec2c/Makefile2
-rw-r--r--comms/xnecview/Makefile2
-rw-r--r--converters/gbase/Makefile2
-rw-r--r--converters/gbsdconv/Makefile2
-rw-r--r--converters/libticonv/Makefile2
-rw-r--r--converters/xml2c/Makefile1
39 files changed, 48 insertions, 38 deletions
diff --git a/cad/brickutils/Makefile b/cad/brickutils/Makefile
index 35f83fe9ea85..6a1d4f7d35e6 100644
--- a/cad/brickutils/Makefile
+++ b/cad/brickutils/Makefile
@@ -27,7 +27,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/ldraw/models/car.dat:cad/ldraw \
WRKSRC= ${WRKDIR}/BrickUtils-${PORTVERSION}
NO_ARCH= yes
-USES= python:2.7 shebangfix
+USES= gnome python:2.7 shebangfix
USE_GNOME= pygtk2
SHEBANG_FILES= pyBrickUtils.py \
BrickUtils/*.py
diff --git a/cad/fritzing/Makefile b/cad/fritzing/Makefile
index 2f00565fb825..47b04294f196 100644
--- a/cad/fritzing/Makefile
+++ b/cad/fritzing/Makefile
@@ -16,7 +16,8 @@ LICENSE= GPLv2+
SUB_FILES+= pkg-install
-USES= compiler:c++11-lang dos2unix gmake python qmake qt:5 tar:bzip2
+USES= compiler:c++11-lang dos2unix gmake gnome python qmake qt:5 \
+ tar:bzip2
USE_QT= buildtools concurrent core dbus gui imageformats network printsupport qmake serialport sql-sqlite3 svg xml
DOS2UNIX_REGEX= .*pro
INSTALLS_ICONS= yes
diff --git a/cad/geda/Makefile b/cad/geda/Makefile
index 56c33d63e992..159ff444ad16 100644
--- a/cad/geda/Makefile
+++ b/cad/geda/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libstroke.so:devel/libstroke \
libguile.so:lang/guile
RUN_DEPENDS= gawk:lang/gawk\
-USES= desktop-file-utils gettext gmake libtool pathfix perl5 \
+USES= desktop-file-utils gettext gmake gnome libtool pathfix perl5 \
pkgconfig python:run shared-mime-info shebangfix
SHEBANG_FILES= examples/lightning_detector/bom libgeda/docs/*.dox \
utils/gxyrs/*.pl utils/scripts/* \
diff --git a/cad/sp2sp/Makefile b/cad/sp2sp/Makefile
index 53065419a55e..3f170566fb4e 100644
--- a/cad/sp2sp/Makefile
+++ b/cad/sp2sp/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= autoreconf gettext-runtime pkgconfig
+USES= autoreconf gettext-runtime gnome pkgconfig
USE_GNOME= gtk20 pango atk cairo gdkpixbuf2 glib20
GNU_CONFIGURE= yes
PLIST_FILES= bin/sp2sp
diff --git a/cad/tkgate/Makefile b/cad/tkgate/Makefile
index a8f5c1f458fd..3b781bde2beb 100644
--- a/cad/tkgate/Makefile
+++ b/cad/tkgate/Makefile
@@ -12,7 +12,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
-USES+= iconv:translit tk:build,run autoreconf libtool pkgconfig
+USES+= autoreconf gnome iconv:translit libtool pkgconfig tk:build,run
USE_GNOME= pango
OPTIONS_DEFINE= DOCS
diff --git a/cad/transcalc/Makefile b/cad/transcalc/Makefile
index ffa15649d68c..21bd6995571f 100644
--- a/cad/transcalc/Makefile
+++ b/cad/transcalc/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://transcalc.sourceforge.net/
MAINTAINER= ports@FreeBSD.org
COMMENT= Analysis and synthesis tool for RF and microwave transmission lines
-USES= pkgconfig
+USES= gnome pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes
diff --git a/chinese/fcitx-chewing/Makefile b/chinese/fcitx-chewing/Makefile
index 7c0bb1711d33..edfbe41e6705 100644
--- a/chinese/fcitx-chewing/Makefile
+++ b/chinese/fcitx-chewing/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= libfcitx-config.so:chinese/fcitx \
libchewing.so:chinese/libchewing
-USES= tar:xz cmake gettext pkgconfig
+USES= cmake gettext gnome pkgconfig tar:xz
INSTALLS_ICONS= yes
.include <bsd.port.mk>
diff --git a/chinese/fcitx-configtool/Makefile b/chinese/fcitx-configtool/Makefile
index 5e27e7973db4..3cb3e2738f21 100644
--- a/chinese/fcitx-configtool/Makefile
+++ b/chinese/fcitx-configtool/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes \
LIB_DEPENDS= libfcitx-config.so:chinese/fcitx
USE_GNOME= intltool
-USES= cmake gettext pkgconfig tar:xz
+USES= cmake gettext gnome pkgconfig tar:xz
LDFLAGS+= -lintl
OPTIONS_SINGLE= UI
diff --git a/chinese/fcitx-libpinyin/Makefile b/chinese/fcitx-libpinyin/Makefile
index a70b906522d5..5eaadd726179 100644
--- a/chinese/fcitx-libpinyin/Makefile
+++ b/chinese/fcitx-libpinyin/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libfcitx-config.so:chinese/fcitx \
libpinyin.so:chinese/libpinyin\
libFcitxQt5WidgetsAddons.so:textproc/fcitx-qt5
-USES= tar:xz cmake gettext pkgconfig
+USES= cmake gettext gnome pkgconfig tar:xz
INSTALLS_ICONS= yes
_MODEL_VER= 20161206
diff --git a/chinese/fcitx-rime/Makefile b/chinese/fcitx-rime/Makefile
index f86133d9edb0..a7028bd92219 100644
--- a/chinese/fcitx-rime/Makefile
+++ b/chinese/fcitx-rime/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libfcitx-config.so:chinese/fcitx \
librime.so:chinese/librime
RUN_DEPENDS= ${LOCALBASE}/share/brise/default.yaml:chinese/brise
-USES= tar:xz cmake gettext pkgconfig
+USES= cmake gettext gnome pkgconfig tar:xz
INSTALLS_ICONS= yes
CMAKE_ARGS+= -DBRISE_DIR=${LOCALBASE}/share/brise
diff --git a/chinese/fcitx-sunpinyin/Makefile b/chinese/fcitx-sunpinyin/Makefile
index 906a42b065cb..92240687cc0d 100644
--- a/chinese/fcitx-sunpinyin/Makefile
+++ b/chinese/fcitx-sunpinyin/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= libfcitx-config.so:chinese/fcitx \
libsunpinyin.so:chinese/sunpinyin
-USES= cmake gettext pkgconfig tar:xz
+USES= cmake gettext gnome pkgconfig tar:xz
INSTALLS_ICONS= yes
.include <bsd.port.mk>
diff --git a/chinese/fcitx-table-extra/Makefile b/chinese/fcitx-table-extra/Makefile
index f50b6d443ba7..c60e9ed335af 100644
--- a/chinese/fcitx-table-extra/Makefile
+++ b/chinese/fcitx-table-extra/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= libfcitx-config.so:chinese/fcitx
-USES= tar:xz cmake gettext
+USES= cmake gettext gnome tar:xz
INSTALLS_ICONS= yes
STRIP=
diff --git a/chinese/ibus-array/Makefile b/chinese/ibus-array/Makefile
index 95337f9b27fe..ab7b71338171 100644
--- a/chinese/ibus-array/Makefile
+++ b/chinese/ibus-array/Makefile
@@ -15,7 +15,8 @@ RUN_DEPENDS= ibus-daemon:textproc/ibus
GNU_CONFIGURE= yes
-USES= autoreconf gettext gmake libtool pkgconfig python:2.7 sqlite
+USES= autoreconf gettext gmake gnome libtool pkgconfig python:2.7 \
+ sqlite
USE_GNOME+= glib20
USE_GITHUB= yes
diff --git a/chinese/ibus-cangjie/Makefile b/chinese/ibus-cangjie/Makefile
index 11c82da492ae..056c7f33a33e 100644
--- a/chinese/ibus-cangjie/Makefile
+++ b/chinese/ibus-cangjie/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/cangjie/_core.so:chinese/pycangjie \
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/cangjie/_core.so:chinese/pycangjie \
${PYTHON_SITELIBDIR}/pycanberra/pycanberra.py:devel/pycanberra@${PY_FLAVOR}
-USES= autoreconf gmake libtool pkgconfig python:3.4+
+USES= autoreconf gmake gnome libtool pkgconfig python:3.4+
USE_GNOME= introspection:run pygobject3 intltool
GLIB_SCHEMAS= org.cangjians.ibus.cangjie.gschema.xml \
org.cangjians.ibus.quick.gschema.xml
diff --git a/chinese/ibus-pinyin/Makefile b/chinese/ibus-pinyin/Makefile
index 7f11faf139cc..568b9f106b50 100644
--- a/chinese/ibus-pinyin/Makefile
+++ b/chinese/ibus-pinyin/Makefile
@@ -17,7 +17,8 @@ LIB_DEPENDS= libpyzy-1.0.so:chinese/pyzy \
libibus-1.0.so:textproc/ibus \
libsqlite3.so:databases/sqlite3
-USES= compiler:c++11-lib gmake pkgconfig python autoreconf libtool gettext
+USES= autoreconf compiler:c++11-lib gettext gmake gnome libtool \
+ pkgconfig python
USE_GITHUB= yes
GH_ACCOUNT= ibus
USE_GNOME= glib20 intltool
diff --git a/chinese/pcmanx/Makefile b/chinese/pcmanx/Makefile
index 04f8ef526274..92cbb479bba7 100644
--- a/chinese/pcmanx/Makefile
+++ b/chinese/pcmanx/Makefile
@@ -14,7 +14,7 @@ COMMENT= BBS client using GTK+ 2.x
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= compiler:c++11-lang gmake iconv pkgconfig tar:xz
+USES= compiler:c++11-lang gmake gnome iconv pkgconfig tar:xz
GNU_CONFIGURE= yes
USE_GNOME= gtk20 intlhack
diff --git a/chinese/pyzy/Makefile b/chinese/pyzy/Makefile
index 5a8c84c335f5..2addc645c859 100644
--- a/chinese/pyzy/Makefile
+++ b/chinese/pyzy/Makefile
@@ -16,7 +16,8 @@ LIB_DEPENDS= libsqlite3.so:databases/sqlite3
USE_GITHUB= yes
GH_TAGNAME= 6d9c3cd
-USES= compiler:c++11-lang gmake libtool pkgconfig python:2.7,build shebangfix autoreconf gettext-runtime pathfix
+USES= autoreconf compiler:c++11-lang gettext-runtime gmake gnome \
+ libtool pathfix pkgconfig python:2.7,build shebangfix
SHEBANG_FILES= data/db/android/create_db.py
USE_GNOME= glib20
USE_LDCONFIG= yes
diff --git a/chinese/wenju/Makefile b/chinese/wenju/Makefile
index c59501562899..5ed1ab25887b 100644
--- a/chinese/wenju/Makefile
+++ b/chinese/wenju/Makefile
@@ -13,7 +13,7 @@ COMMENT= Collection of writing tools in Chinese
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= libtool pkgconfig
+USES= gnome libtool pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= gtk20
INSTALL_TARGET= install-strip
diff --git a/comms/freedv/Makefile b/comms/freedv/Makefile
index a52912f5bdd9..64fc1a71c56f 100644
--- a/comms/freedv/Makefile
+++ b/comms/freedv/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libcodec2.so:audio/codec2 \
libspeex.so:audio/speex \
libspeexdsp.so:audio/speexdsp
-USES= cmake compiler:c++11-lib tar:xz
+USES= cmake compiler:c++11-lib gnome tar:xz
USE_WX= 3.0+
CMAKE_ARGS+= -DCODEC2_INCLUDE_DIRS=${LOCALBASE}/include/codec2 \
-DCODEC2_LIBRARY=${LOCALBASE}/lib/libcodec2.so \
diff --git a/comms/gnocky/Makefile b/comms/gnocky/Makefile
index db59f711bf12..fc8c3ae3cc3b 100644
--- a/comms/gnocky/Makefile
+++ b/comms/gnocky/Makefile
@@ -12,7 +12,7 @@ COMMENT= Graphical (GTK+2) frontend for gnokii
LIB_DEPENDS= libgnokii.so:comms/gnokii
-USES= pkgconfig tar:bzip2
+USES= gnome pkgconfig tar:bzip2
USE_GNOME= gtk20 libglade2
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index b16059a0f070..8a3b4a9a955c 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -18,8 +18,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= p5-XML-Parser>=0:textproc/p5-XML-Parser
GROUPS= ${PORTNAME}
-USES= gettext gmake iconv libtool localbase pathfix pkgconfig readline \
- tar:bzip2
+USES= gettext gmake gnome iconv libtool localbase pathfix pkgconfig \
+ readline tar:bzip2
USE_LDCONFIG= yes
USE_CSTD= gnu89
USE_GNOME= glib20 intltool
diff --git a/comms/grig/Makefile b/comms/grig/Makefile
index ac9d1e7476ed..fb75e4de3f79 100644
--- a/comms/grig/Makefile
+++ b/comms/grig/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libhamlib.so:comms/hamlib
USE_GNOME= gtk20 intltool
GNU_CONFIGURE= yes
-USES= gettext gmake pkgconfig
+USES= gettext gmake gnome pkgconfig
LIBS+= -lm
diff --git a/comms/hamlib/Makefile b/comms/hamlib/Makefile
index d050c56dce29..64ffbece6f2c 100644
--- a/comms/hamlib/Makefile
+++ b/comms/hamlib/Makefile
@@ -15,7 +15,8 @@ LICENSE= LGPL20
BUILD_DEPENDS= swig3.0:devel/swig30
LIB_DEPENDS= libltdl.so:devel/libltdl
-USES= autoreconf libtool:keepla pathfix perl5 pathfix pkgconfig python readline shebangfix tcl
+USES= autoreconf gnome libtool:keepla pathfix perl5 pkgconfig python \
+ readline shebangfix tcl
USE_PYTHON= py3kplist
USE_PERL5= build run
USE_GNOME= libxml2
diff --git a/comms/kb/Makefile b/comms/kb/Makefile
index e7588a34e52d..c05654fd8b96 100644
--- a/comms/kb/Makefile
+++ b/comms/kb/Makefile
@@ -10,7 +10,7 @@ DISTFILES= kb_src-${PORTVERSION}.tar.gz kb_inst-${PORTVERSION}.tar.gz
MAINTAINER= hamradio@FreeBSD.org
COMMENT= Amateur Radio contest logger
-USES= pkgconfig
+USES= gnome pkgconfig
USE_GNOME= libgnome gtk20 libbonobo
NO_WRKSUBDIR= yes
PKGMESSAGE= ${FILESDIR}/pkg_message
diff --git a/comms/libimobiledevice/Makefile b/comms/libimobiledevice/Makefile
index e94efb3d59f6..243af005ad88 100644
--- a/comms/libimobiledevice/Makefile
+++ b/comms/libimobiledevice/Makefile
@@ -26,6 +26,7 @@ INSTALL_TARGET= install-strip
LIB_DEPENDS= libplist.so:devel/libplist \
libusbmuxd.so:comms/libusbmuxd
+USES+= gnome
USE_GNOME= glib20
CONFIGURE_ARGS+=--without-cython
USE_CSTD= gnu89
diff --git a/comms/libticables2/Makefile b/comms/libticables2/Makefile
index 45966ca09026..77673147e984 100644
--- a/comms/libticables2/Makefile
+++ b/comms/libticables2/Makefile
@@ -13,7 +13,8 @@ LICENSE= GPLv2
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= autoreconf gettext-tools gmake libtool pkgconfig tar:bzip2
+USES= autoreconf gettext-tools gmake gnome libtool pkgconfig \
+ tar:bzip2
USE_GNOME= glib20
USE_LDCONFIG= yes
diff --git a/comms/libticalcs2/Makefile b/comms/libticalcs2/Makefile
index 951360ed25da..c65a0e08784a 100644
--- a/comms/libticalcs2/Makefile
+++ b/comms/libticalcs2/Makefile
@@ -16,7 +16,8 @@ LIB_DEPENDS= libticables2.so:comms/libticables2 \
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= autoreconf gettext-tools gmake libtool pkgconfig tar:bzip2
+USES= autoreconf gettext-tools gmake gnome libtool pkgconfig \
+ tar:bzip2
USE_GNOME= glib20
USE_LDCONFIG= yes
diff --git a/comms/lysdr/Makefile b/comms/lysdr/Makefile
index f8b8d5aea4be..18ab9c9c2be9 100644
--- a/comms/lysdr/Makefile
+++ b/comms/lysdr/Makefile
@@ -17,7 +17,7 @@ USE_GITHUB= yes
GH_ACCOUNT= gordonjcp
GH_TAGNAME= stable-0
-USES= pkgconfig
+USES= gnome pkgconfig
USE_GNOME= gtk20
PLIST_FILES= bin/lysdr
diff --git a/comms/pear-Horde_ActiveSync/Makefile b/comms/pear-Horde_ActiveSync/Makefile
index de7291132448..3aabbdf698dd 100644
--- a/comms/pear-Horde_ActiveSync/Makefile
+++ b/comms/pear-Horde_ActiveSync/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= comms www pear
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde ActiveSync Server Library
-USES= horde
+USES= horde php
USE_PHP= ctype
USE_HORDE_RUN= Horde_Compress \
Horde_Date \
diff --git a/comms/syncterm/Makefile b/comms/syncterm/Makefile
index 635d9ed847b6..23693a9cb9a1 100644
--- a/comms/syncterm/Makefile
+++ b/comms/syncterm/Makefile
@@ -35,6 +35,7 @@ X11_USES= xorg
X11_USE= xorg=x11
X11_MAKE_ARGS_OFF= NO_X=1
+SDL_USES= sdl
SDL_USE= SDL=sdl
SDL_MAKE_ARGS= USE_SDL=1
SDL_MAKE_ARGS_OFF= WITHOUT_SDL=1
diff --git a/comms/tilp2/Makefile b/comms/tilp2/Makefile
index bdba0f71ccde..590ea1f268a8 100644
--- a/comms/tilp2/Makefile
+++ b/comms/tilp2/Makefile
@@ -18,9 +18,8 @@ LIB_DEPENDS= libticables2.so:comms/libticables2 \
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= autoreconf compiler:c11 desktop-file-utils gettext \
- gmake groff localbase \
- libtool pkgconfig shared-mime-info tar:bzip2
+USES= autoreconf compiler:c11 desktop-file-utils gettext gmake gnome \
+ groff libtool localbase pkgconfig shared-mime-info tar:bzip2
USE_GNOME= gtk20 intltool
OPTIONS_DEFINE= NLS
diff --git a/comms/xdx/Makefile b/comms/xdx/Makefile
index 8c5e6f78d9f4..c6bf277a1e34 100644
--- a/comms/xdx/Makefile
+++ b/comms/xdx/Makefile
@@ -13,7 +13,7 @@ COMMENT= Amateur Radio DX cluster monitor
LICENSE= GPLv2
-USES= gmake pkgconfig
+USES= gmake gnome pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes
diff --git a/comms/xmorse/Makefile b/comms/xmorse/Makefile
index 3f786b1d123e..4aa22f7567e1 100644
--- a/comms/xmorse/Makefile
+++ b/comms/xmorse/Makefile
@@ -15,6 +15,7 @@ COMMENT= Fully automatic Morse code teaching machine
LIB_DEPENDS= libfltk.so:x11-toolkits/fltk
+USES= sdl
USE_SDL= sdl
PLIST_FILES= bin/xmorse
diff --git a/comms/xnec2c/Makefile b/comms/xnec2c/Makefile
index d915875a314b..35fa0156b3ca 100644
--- a/comms/xnec2c/Makefile
+++ b/comms/xnec2c/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libccm.so:math/ccmath
GNU_CONFIGURE= yes
-USES= gettext gmake pkgconfig tar:bzip2
+USES= gettext gmake gnome pkgconfig tar:bzip2
USE_GNOME= gtk20 intltool
OPTIONS_DEFINE= DOCS
diff --git a/comms/xnecview/Makefile b/comms/xnecview/Makefile
index 17018580e912..7f6f5a821f55 100644
--- a/comms/xnecview/Makefile
+++ b/comms/xnecview/Makefile
@@ -12,7 +12,7 @@ COMMENT= A X viewer of nec2c data
LIB_DEPENDS= libpng.so:graphics/png
-USES= gmake pkgconfig tar:tgz
+USES= gmake gnome pkgconfig tar:tgz
USE_GNOME= gtk20
PLIST_FILES= bin/xnecview man/man1/xnecview.1.gz
diff --git a/converters/gbase/Makefile b/converters/gbase/Makefile
index 24474a5c9638..f3f6d3f26053 100644
--- a/converters/gbase/Makefile
+++ b/converters/gbase/Makefile
@@ -13,7 +13,7 @@ COMMENT= Program to convert between the 4 common bases used in programming
LICENSE= ART10
PLIST_FILES= bin/${PORTNAME}
-USES= pkgconfig
+USES= gnome pkgconfig
USE_GNOME+= gtk20
GTK_CFLAGS= `pkg-config --cflags gtk+-2.0`
diff --git a/converters/gbsdconv/Makefile b/converters/gbsdconv/Makefile
index 97607fcbd52a..936e2c909492 100644
--- a/converters/gbsdconv/Makefile
+++ b/converters/gbsdconv/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bsdconv>=8.0:converters/py-bsdconv@${PY_FLAV
USE_GITHUB= yes
GH_ACCOUNT= buganini
-USES= python shebangfix
+USES= gnome python shebangfix
USE_GNOME= gtk30 introspection:run
SHEBANG_FILES= gbsdconv
diff --git a/converters/libticonv/Makefile b/converters/libticonv/Makefile
index d6b685f5b593..102b60470585 100644
--- a/converters/libticonv/Makefile
+++ b/converters/libticonv/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-iconv
INSTALL_TARGET= install-strip
-USES= autoreconf gmake iconv libtool pkgconfig tar:bzip2
+USES= autoreconf gmake gnome iconv libtool pkgconfig tar:bzip2
USE_GNOME= glib20
USE_LDCONFIG= yes
diff --git a/converters/xml2c/Makefile b/converters/xml2c/Makefile
index 7633bc833ef2..dc584e7d9877 100644
--- a/converters/xml2c/Makefile
+++ b/converters/xml2c/Makefile
@@ -11,6 +11,7 @@ COMMENT= Reads in an XML file and produces equivalent C source code
LICENSE= BSD2CLAUSE
+USES= gnome
USE_GNOME= libxml2
WRKSRC= ${WRKDIR}/${PORTNAME}