summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/virtualbox-ose-additions/Makefile19
-rw-r--r--emulators/virtualbox-ose-additions/distinfo4
-rw-r--r--emulators/virtualbox-ose-kmod/Makefile25
-rw-r--r--emulators/virtualbox-ose-kmod/distinfo4
-rw-r--r--emulators/virtualbox-ose-kmod/pkg-plist4
-rw-r--r--emulators/virtualbox-ose/Makefile64
-rw-r--r--emulators/virtualbox-ose/distinfo8
7 files changed, 68 insertions, 60 deletions
diff --git a/emulators/virtualbox-ose-additions/Makefile b/emulators/virtualbox-ose-additions/Makefile
index 1dd2b61e0aed..ee592f1731bd 100644
--- a/emulators/virtualbox-ose-additions/Makefile
+++ b/emulators/virtualbox-ose-additions/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= virtualbox-ose
-DISTVERSION= 4.1.16
+DISTVERSION= 4.1.18
CATEGORIES= emulators kld
MASTER_SITES= http://tmp.chruetertee.ch/ \
http://freebsd.unixfreunde.de/sources/ \
@@ -41,9 +41,8 @@ CONFLICTS= bcc-[0-9]*
CONFLICTS_BUILD= kBuild-[0-9]*
CONFLICTS_INSTALL= virtualbox-ose-additions-devel-[3,4]* virtualbox-ose-[3,4]* virtualbox-ose-devel-[3,4]* virtualbox-ose-legacy-[3,4]*
-OPTIONS= DEBUG "Build with debugging symbols" off \
- X11 "Build with X11 support" on \
- OPENGL "Build with OpenGL support" off
+OPTIONS_DEFINE= DEBUG X11 OPENGL
+OPTIONS_DEFAULT= X11
.include <bsd.port.options.mk>
@@ -60,12 +59,12 @@ KMK_BUILDTYPE= release
KMK_CONFIG= VBOX_LIBPATH_X11=${LOCALBASE}
KMK_FLAGS=
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
KMK_FLAGS+= BUILD_TYPE=debug
KMK_BUILDTYPE= debug
.endif
-.if !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
VBOX_WITH_X11= 1
USE_XORG= xcursor xmu inputproto xorg-server xrandr
PLIST_SUB+= X11=""
@@ -74,10 +73,10 @@ VBOX_WITH_X11=
PLIST_SUB+= X11="@comment "
.endif
-.if defined(WITHOUT_OPENGL)
-CONFIGURE_ARGS+=--disable-opengl
-.else
+.if ${PORT_OPTIONS:MOPENGL}
USE_GL= gl
+.else
+CONFIGURE_ARGS+=--disable-opengl
.endif
.if ${ARCH} == i386
@@ -139,7 +138,7 @@ do-install:
${INSTALL_PROGRAM} ${VBOX_BIN}/VBoxControl ${PREFIX}/sbin/
${INSTALL_PROGRAM} ${VBOX_BIN}/VBoxService ${PREFIX}/sbin/
-.if !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
${INSTALL_PROGRAM} ${VBOX_BIN}/VBoxClient ${PREFIX}/bin/
${MKDIR} ${PREFIX}/bin
diff --git a/emulators/virtualbox-ose-additions/distinfo b/emulators/virtualbox-ose-additions/distinfo
index 136b7cf26a20..228fa029bd43 100644
--- a/emulators/virtualbox-ose-additions/distinfo
+++ b/emulators/virtualbox-ose-additions/distinfo
@@ -1,2 +1,2 @@
-SHA256 (VirtualBox-4.1.16.tar.bz2) = b670499804c718a8ebbc7c2ddee37f70e98771a151391a597b5808f4310f824e
-SIZE (VirtualBox-4.1.16.tar.bz2) = 73255692
+SHA256 (VirtualBox-4.1.18.tar.bz2) = e650e4fdc23581b9edc0e5d5705cc596c76796851ebf65ccda0edb8e413fa3b7
+SIZE (VirtualBox-4.1.18.tar.bz2) = 73688436
diff --git a/emulators/virtualbox-ose-kmod/Makefile b/emulators/virtualbox-ose-kmod/Makefile
index 94e6f73b841b..4ed6af762e78 100644
--- a/emulators/virtualbox-ose-kmod/Makefile
+++ b/emulators/virtualbox-ose-kmod/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= virtualbox-ose
-DISTVERSION= 4.1.16
+DISTVERSION= 4.1.18
CATEGORIES= emulators kld
MASTER_SITES= http://tmp.chruetertee.ch/ \
http://freebsd.unixfreunde.de/sources/ \
@@ -40,8 +40,8 @@ CONFLICTS= bcc-[0-9]*
CONFLICTS_BUILD= kBuild-[0-9]*
CONFLICTS_INSTALL= virtualbox-ose-kmod-devel-[3,4]* virtualbox-ose-kmod-legacy-[3,4]*
-OPTIONS= DEBUG "Build with debugging symbols" off \
- VIMAGE "VIMAGE virtual networking support" off
+OPTIONS_DEFINE= DEBUG VIMAGE
+VIMAGE_DESC= VIMAGE virtual networking support
.include <bsd.port.options.mk>
@@ -56,9 +56,15 @@ KMK_BUILDTYPE= release
KMK_CONFIG= VBOX_LIBPATH_X11=${LOCALBASE} VBOX_FREEBSD_SRC=${SRC_BASE}/sys
KMK_FLAGS= HostDrivers-src vboxdrv-mod VBoxNetFlt-src VBoxNetAdp-src
-.if defined(WITH_DEBUG)
+MAKE_FLAGS= SYSDIR=${SRC_BASE}/sys
+
+.if ${PORT_OPTIONS:MDEBUG}
KMK_FLAGS+= BUILD_TYPE=debug
KMK_BUILDTYPE= debug
+MAKE_FLAGS+= DEBUG_FLAGS="-O1 -g"
+PLIST_SUB+= WITH_DEBUG=""
+.else
+PLIST_SUB+= WITH_DEBUG="@comment "
.endif
.if ${ARCH} == i386
@@ -77,7 +83,7 @@ IGNORE= requires kernel sources
BROKEN= Does not compile on FreeBSD < 8.2
.endif
-.if ${OSVERSION} < 800500 && defined(WITH_VIMAGE)
+.if ${OSVERSION} < 800500 && !empty(PORT_OPTIONS:MVIMAGE)
IGNORE= newer kernel is required to build with VIMAGE
.endif
@@ -86,7 +92,7 @@ post-patch:
@${ECHO} 'VBOX_WITH_NETFLT = 1' >> ${WRKSRC}/LocalConfig.kmk
@${ECHO} 'VBOX_WITH_NETADP = 1' >> ${WRKSRC}/LocalConfig.kmk
@${ECHO} 'VBOX_WITH_ADDITIONS =' >> ${WRKSRC}/LocalConfig.kmk
-.if defined(WITH_VIMAGE)
+.if ${PORT_OPTIONS:MVIMAGE}
@${ECHO} 'VBOX_WITH_NETFLT_VIMAGE = 1' >> ${WRKSRC}/LocalConfig.kmk
.endif
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
@@ -100,13 +106,18 @@ pre-build:
do-build:
cd ${WRKSRC} && ${SH} env.sh && cd ${WRKSRC}/src/VBox/HostDrivers && ${KMK_CONFIG} ${LOCALBASE}/bin/kmk ${KMK_FLAGS}
- cd ${VBOX_BIN} && make SYSDIR=${SRC_BASE}/sys
+ cd ${VBOX_BIN} && make ${MAKE_FLAGS}
do-install:
${MKDIR} ${KMODDIR}
${INSTALL_KLD} ${VBOX_BIN}/vboxdrv/vboxdrv.ko ${KMODDIR}
${INSTALL_KLD} ${VBOX_BIN}/vboxnetadp/vboxnetadp.ko ${KMODDIR}
${INSTALL_KLD} ${VBOX_BIN}/vboxnetflt/vboxnetflt.ko ${KMODDIR}
+.if $(PORT_OPTIONS:MDEBUG)
+ ${INSTALL_KLD} ${VBOX_BIN}/vboxdrv/vboxdrv.ko.symbols ${KMODDIR}
+ ${INSTALL_KLD} ${VBOX_BIN}/vboxnetadp/vboxnetadp.ko.symbols ${KMODDIR}
+ ${INSTALL_KLD} ${VBOX_BIN}/vboxnetflt/vboxnetflt.ko.symbols ${KMODDIR}
+.endif
@/usr/sbin/kldxref ${KMODDIR}
.include <bsd.port.post.mk>
diff --git a/emulators/virtualbox-ose-kmod/distinfo b/emulators/virtualbox-ose-kmod/distinfo
index 136b7cf26a20..228fa029bd43 100644
--- a/emulators/virtualbox-ose-kmod/distinfo
+++ b/emulators/virtualbox-ose-kmod/distinfo
@@ -1,2 +1,2 @@
-SHA256 (VirtualBox-4.1.16.tar.bz2) = b670499804c718a8ebbc7c2ddee37f70e98771a151391a597b5808f4310f824e
-SIZE (VirtualBox-4.1.16.tar.bz2) = 73255692
+SHA256 (VirtualBox-4.1.18.tar.bz2) = e650e4fdc23581b9edc0e5d5705cc596c76796851ebf65ccda0edb8e413fa3b7
+SIZE (VirtualBox-4.1.18.tar.bz2) = 73688436
diff --git a/emulators/virtualbox-ose-kmod/pkg-plist b/emulators/virtualbox-ose-kmod/pkg-plist
index ef2cca5a6af2..83a55bedda50 100644
--- a/emulators/virtualbox-ose-kmod/pkg-plist
+++ b/emulators/virtualbox-ose-kmod/pkg-plist
@@ -1,8 +1,10 @@
@comment $FreeBSD$
@cwd /
%%KMODDIR%%/vboxdrv.ko
+%%WITH_DEBUG%%%%KMODDIR%%/vboxdrv.ko.symbols
%%KMODDIR%%/vboxnetadp.ko
+%%WITH_DEBUG%%%%KMODDIR%%/vboxnetadp.ko.symbols
%%KMODDIR%%/vboxnetflt.ko
+%%WITH_DEBUG%%%%KMODDIR%%/vboxnetflt.ko.symbols
@exec /usr/sbin/kldxref /%%KMODDIR%%
@unexec /usr/sbin/kldxref /%%KMODDIR%%
-
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index 95f3e0aa8890..3389c75d7687 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= virtualbox-ose
-DISTVERSION= 4.1.16
-PORTREVISION= 1
+DISTVERSION= 4.1.18
CATEGORIES= emulators
MASTER_SITES= http://tmp.chruetertee.ch/ \
http://freebsd.unixfreunde.de/sources/ \
@@ -60,17 +59,14 @@ GROUPS= ${VBOXGROUP}
VBOX_FRONTENDS= VBoxHeadless
VBOX_GUEST_VER= ${PORTVERSION}
-OPTIONS= QT4 "Build with QT4 Frontend" on \
- DEBUG "Build with debugging symbols" off \
- GUESTADDITIONS "Build with Guest Additions" off \
- DBUS "Build with D-Bus and HAL support" on \
- PULSEAUDIO "Build with PulseAudio" off \
- X11 "Build with X11 support" on \
- UDPTUNNEL "Build with UDP tunnel support" on \
- VDE "Build with VDE support" off \
- VNC "Build with VNC support" off \
- WEBSERVICE "Build Webservice" off \
- NLS "Native language support" on
+OPTIONS_DEFINE= QT4 DEBUG GUESTADDITIONS DBUS PULSEAUDIO UDPTUNNEL VDE VNC WEBSERVICE NLS X11
+OPTIONS_DEFAULT= QT4 DBUS X11 UDPTUNNEL
+QT4_DESC= Build with QT4 Frontend
+GUESTADDITIONS_DESC= Build with Guest Additions
+UDPTUNNEL_DESC= Build with UDP tunnel support
+VDE_DESC= Build with VDE support
+VNC_DESC= Build with VNC support
+WEBSERVICE_DESC= Build Webservice
.include <bsd.port.options.mk>
@@ -85,15 +81,15 @@ KMK_BUILDTYPE= release
KMK_CONFIG= VBOX_LIBPATH_X11=${LOCALBASE} VBOX_FREEBSD_SRC=${SRC_BASE}/sys
KMK_FLAGS=
-.if defined(WITHOUT_QT4) && !defined(WITHOUT_NLS)
+.if empty(PORT_OPTIONS:MQT4) && !empty(PORT_OPTIONS:MNLS)
BROKEN= NLS support requires QT4 frontend. Run 'make config' again!
.endif
-.if defined(WITHOUT_X11) && !defined(WITHOUT_QT4)
+.if empty(PORT_OPTIONS:MX11) && !empty(PORT_OPTIONS:MQT4)
BROKEN= QT4 frontend requires X11 support. Run 'make config' again!
.endif
-.if !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
USE_SDL= sdl
USE_XORG= xcursor xmu inputproto xinerama
VBOX_FRONTENDS+=VBoxBFE VBoxSDL
@@ -103,7 +99,7 @@ CONFIGURE_ARGS+=--build-headless
PLIST_SUB+= X11="@comment "
.endif
-.if !defined(WITHOUT_QT4)
+.if ${PORT_OPTIONS:MQT4}
QT_NONSTANDARD= yes
USE_QT4= gui network moc_build uic_build rcc_build linguist
INSTALLS_ICONS= yes
@@ -114,7 +110,7 @@ CONFIGURE_ARGS+=--disable-qt4
PLIST_SUB+= QT4="@comment "
.endif
-.if defined(WITH_GUESTADDITIONS)
+.if ${PORT_OPTIONS:MGUESTADDITIONS}
GUESTADDITIONS= VBoxGuestAdditions_${VBOX_GUEST_VER}.iso
GADISTFILES= ${GUESTADDITIONS}:guestadditions
RESTRICTED= for personal use only
@@ -125,39 +121,39 @@ PLIST_SUB+= GUESTADDITIONS=""
PLIST_SUB+= GUESTADDITIONS="@comment "
.endif
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
KMK_FLAGS+= BUILD_TYPE=debug
KMK_BUILDTYPE= debug
.endif
-.if !defined(WITHOUT_DBUS)
+.if ${PORT_OPTIONS:MDBUS}
LIB_DEPENDS+= dbus-1.3:${PORTSDIR}/devel/dbus
.else
CONFIGURE_ARGS+=--disable-dbus
.endif
-.if !defined(WITH_PULSEAUDIO)
-CONFIGURE_ARGS+=--disable-pulse
-.else
+.if ${PORT_OPTIONS:MPULSEAUDIO}
LIB_DEPENDS+= pulse.0:${PORTSDIR}/audio/pulseaudio
+.else
+CONFIGURE_ARGS+=--disable-pulse
.endif
-.if defined(WITH_VNC)
+.if ${PORT_OPTIONS:MVNC}
LIB_DEPENDS+= vncserver.0:${PORTSDIR}/net/libvncserver
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITH_VDE)
+.if ${PORT_OPTIONS:MVDE}
RUN_DEPENDS+= vde_switch:${PORTSDIR}/net/vde2
CONFIGURE_ARGS+=--enable-vde
.endif
-.if defined(WITH_WEBSERVICE)
+.if ${PORT_OPTIONS:MWEBSERVICE}
BUILD_DEPENDS+= soapcpp2:${PORTSDIR}/devel/gsoap
VBOX_WEB= vboxwebsrv webtest
USE_RC_SUBR+= vboxwebsrv
@@ -214,16 +210,16 @@ post-patch:
@${ECHO} 'SDK_VBOX_LIBPNG_LIBS = png' >> ${WRKSRC}/LocalConfig.kmk
@${ECHO} 'VBOX_WITH_ADDITIONS=' >> ${WRKSRC}/LocalConfig.kmk
@${ECHO} 'VBOX_WITH_X11_ADDITIONS=' >> ${WRKSRC}/LocalConfig.kmk
-.if defined(WITH_VNC)
+.if ${PORT_OPTIONS:MVNC}
@${ECHO} 'VBOX_WITH_VNC = 1' >> ${WRKSRC}/LocalConfig.kmk
.endif
.if ${OSVERSION} < 800069
@${ECHO} 'VBOX_WITH_USB=' >> ${WRKSRC}/LocalConfig.kmk
.endif
-.if defined(WITH_UDPTUNNEL)
+.if ${PORT_OPTIONS:MUDPTUNNEL}
@${ECHO} 'VBOX_WITH_UDPTUNNEL = 1' >> ${WRKSRC}/LocalConfig.kmk
.endif
-.if defined(WITH_WEBSERVICE)
+.if ${PORT_OPTIONS:MWEBSERVICE}
@${ECHO} 'VBOX_WITH_WEBSERVICES = 1' >> ${WRKSRC}/LocalConfig.kmk
@${ECHO} 'VBOX_GSOAP_INSTALLED = 1' >> ${WRKSRC}/LocalConfig.kmk
@${ECHO} 'VBOX_PATH_GSOAP = ${PREFIX}/lib/gsoap' >> ${WRKSRC}/LocalConfig.kmk
@@ -255,7 +251,7 @@ do-install:
${MKDIR} ${PREFIX}/lib/virtualbox
(cd ${WRKSRC}/out/${KMK_ARCH}/${KMK_BUILDTYPE}/bin && ${COPYTREE_SHARE} "*.so *.gc *.r0 *.fd components VBoxExtPackHelperApp" ${PREFIX}/lib/virtualbox)
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
${MKDIR} ${DATADIR}/nls
(cd ${WRKSRC}/out/${KMK_ARCH}/${KMK_BUILDTYPE}/obj/VirtualBox/qtnls && ${COPYTREE_SHARE} "*.qm" ${DATADIR}/nls)
.endif
@@ -274,14 +270,14 @@ do-install:
${CHMOD} 0711 ${PREFIX}/lib/virtualbox/${f}
.endfor
-.if defined(WITH_WEBSERVICE)
+.if ${PORT_OPTIONS:MWEBSERVICE}
${MKDIR} -p ${DATADIR}/sdk/bindings/webservice
.for f in vboxweb.wsdl vboxwebService.wsdl
${INSTALL_DATA} ${WRKSRC}/out/${KMK_ARCH}/${KMK_BUILDTYPE}/bin/sdk/bindings/webservice/${f} ${DATADIR}/sdk/bindings/webservice/
.endfor
.endif
-.if defined(WITH_GUESTADDITIONS)
+.if ${PORT_OPTIONS:MGUESTADDITIONS}
${MKDIR} ${PREFIX}/lib/virtualbox/additions
${INSTALL_DATA} ${DISTDIR}/${GUESTADDITIONS} ${PREFIX}/lib/virtualbox/additions/
${LN} -sf ${PREFIX}/lib/virtualbox/additions/${GUESTADDITIONS} ${PREFIX}/lib/virtualbox/additions/VBoxGuestAdditions.iso
@@ -303,7 +299,7 @@ post-install:
@${FIND} ${PREFIX}/include/virtualbox -type d -print0 | ${XARGS} -0 ${CHMOD} 755
@${FIND} ${PREFIX}/lib/virtualbox -type d -print0 | ${XARGS} -0 ${CHMOD} 755
-.if !defined(WITHOUT_QT4)
+.if ${PORT_OPTIONS:MQT4}
${MKDIR} ${PREFIX}/share/pixmaps/
${INSTALL_DATA} ${WRKSRC}/src/VBox/Frontends/VirtualBox/images/OSE/VirtualBox_48px.png ${PREFIX}/share/pixmaps/VBox.png
${MKDIR} ${PREFIX}/share/applications/
diff --git a/emulators/virtualbox-ose/distinfo b/emulators/virtualbox-ose/distinfo
index fae4eaf97958..db0f0b9db2cf 100644
--- a/emulators/virtualbox-ose/distinfo
+++ b/emulators/virtualbox-ose/distinfo
@@ -1,4 +1,4 @@
-SHA256 (VirtualBox-4.1.16.tar.bz2) = b670499804c718a8ebbc7c2ddee37f70e98771a151391a597b5808f4310f824e
-SIZE (VirtualBox-4.1.16.tar.bz2) = 73255692
-SHA256 (VBoxGuestAdditions_4.1.16.iso) = b5c6b2a2836f65aececc40608b266ac06ca62aa871b514b761bd00f0981157b8
-SIZE (VBoxGuestAdditions_4.1.16.iso) = 52168704
+SHA256 (VirtualBox-4.1.18.tar.bz2) = e650e4fdc23581b9edc0e5d5705cc596c76796851ebf65ccda0edb8e413fa3b7
+SIZE (VirtualBox-4.1.18.tar.bz2) = 73688436
+SHA256 (VBoxGuestAdditions_4.1.18.iso) = 0b670a698dcb427ebf69cdec1e040b26e93538e1ca76f58506c1db70308152ff
+SIZE (VBoxGuestAdditions_4.1.18.iso) = 52164608