summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/R-cran-shiny/Makefile23
-rw-r--r--www/R-cran-shiny/distinfo2
-rw-r--r--www/R-cran-shiny/pkg-descr11
4 files changed, 37 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e48cf9ab5847..86289eaf390b 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -8,6 +8,7 @@
SUBDIR += R-cran-Rpad
SUBDIR += R-cran-httpuv
SUBDIR += R-cran-scrapeR
+ SUBDIR += R-cran-shiny
SUBDIR += WebMagick
SUBDIR += abyssws
SUBDIR += ach
diff --git a/www/R-cran-shiny/Makefile b/www/R-cran-shiny/Makefile
new file mode 100644
index 000000000000..60bf99bf78d8
--- /dev/null
+++ b/www/R-cran-shiny/Makefile
@@ -0,0 +1,23 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= shiny
+PORTVERSION= 0.5.0
+CATEGORIES= www
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Web Application Framework for R
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= R-cran-httpuv>=1.0.5:${PORTSDIR}/www/R-cran-httpuv \
+ R-cran-caTools>0:${PORTSDIR}/devel/R-cran-caTools \
+ R-cran-RJSONIO>0:${PORTSDIR}/converters/R-cran-RJSONIO \
+ R-cran-xtable>0:${PORTSDIR}/converters/R-cran-xtable \
+ R-cran-digest>0:${PORTSDIR}/security/R-cran-digest
+
+USE_R_MOD= yes
+R_MOD_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/R-cran-shiny/distinfo b/www/R-cran-shiny/distinfo
new file mode 100644
index 000000000000..9e6015be9361
--- /dev/null
+++ b/www/R-cran-shiny/distinfo
@@ -0,0 +1,2 @@
+SHA256 (shiny_0.5.0.tar.gz) = 9c06ae2615495fd02bdac777a85237ceeeeef3959a290db0d246862a65fe5efd
+SIZE (shiny_0.5.0.tar.gz) = 284546
diff --git a/www/R-cran-shiny/pkg-descr b/www/R-cran-shiny/pkg-descr
new file mode 100644
index 000000000000..2925622e974e
--- /dev/null
+++ b/www/R-cran-shiny/pkg-descr
@@ -0,0 +1,11 @@
+Shiny makes it super simple for R users like you to turn analyses
+into interactive web applications that anyone can use. Let your
+users choose input parameters using friendly controls like sliders,
+drop-downs, and text fields. Easily incorporate any number of outputs
+like plots, tables, and summaries.
+
+No HTML or JavaScript knowledge is necessary. If you have some
+experience with R, youre just minutes away from combining the
+statistical power of R with the simplicity of a web page.
+
+WWW: http://www.rstudio.com/shiny/