summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/virtualbox-ose-additions/Makefile2
-rw-r--r--emulators/virtualbox-ose-kmod-legacy/Makefile5
-rw-r--r--emulators/virtualbox-ose-kmod/Makefile5
-rw-r--r--emulators/virtualbox-ose-legacy/Makefile2
-rw-r--r--emulators/virtualbox-ose/Makefile2
5 files changed, 2 insertions, 14 deletions
diff --git a/emulators/virtualbox-ose-additions/Makefile b/emulators/virtualbox-ose-additions/Makefile
index 6bd8f57ac8e7..797c6c075714 100644
--- a/emulators/virtualbox-ose-additions/Makefile
+++ b/emulators/virtualbox-ose-additions/Makefile
@@ -17,7 +17,6 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm \
- as86:${PORTSDIR}/devel/dev86 \
kmk:${PORTSDIR}/devel/kBuild
UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
@@ -36,7 +35,6 @@ CONFIGURE_ARGS+=--with-gcc="${CC}" --with-g++="${CXX}" --nofatal \
--disable-xpcom --disable-sdl-ttf --disable-pulse \
--disable-alsa --disable-dbus --disable-python
-CONFLICTS= bcc-[0-9]*
CONFLICTS_INSTALL= virtualbox-ose-additions-devel-[3,4]* virtualbox-ose-[3,4]* virtualbox-ose-devel-[3,4]* virtualbox-ose-legacy-[3,4]*
OPTIONS_DEFINE= DEBUG X11 OPENGL
diff --git a/emulators/virtualbox-ose-kmod-legacy/Makefile b/emulators/virtualbox-ose-kmod-legacy/Makefile
index ce74f55030a4..01bf9ae0220c 100644
--- a/emulators/virtualbox-ose-kmod-legacy/Makefile
+++ b/emulators/virtualbox-ose-kmod-legacy/Makefile
@@ -16,9 +16,7 @@ COMMENT= VirtualBox kernel module for FreeBSD
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm \
- as86:${PORTSDIR}/devel/dev86 \
- kmk:${PORTSDIR}/devel/kBuild
+BUILD_DEPENDS= kmk:${PORTSDIR}/devel/kBuild
UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
WRKSRC= ${WRKDIR}/VirtualBox-${PORTVERSION}
@@ -32,7 +30,6 @@ CONFIGURE_ARGS+=--with-gcc="${CC}" --with-g++="${CXX}" --nofatal \
--disable-alsa --disable-dbus --disable-python \
--build-headless
-CONFLICTS= bcc-[0-9]*
CONFLICTS_INSTALL= virtualbox-ose-kmod-4* virtualbox-ose-kmod-devel-4*
OPTIONS_DEFINE= DEBUG VIMAGE
diff --git a/emulators/virtualbox-ose-kmod/Makefile b/emulators/virtualbox-ose-kmod/Makefile
index 566845ebbe9d..c81abb758e9a 100644
--- a/emulators/virtualbox-ose-kmod/Makefile
+++ b/emulators/virtualbox-ose-kmod/Makefile
@@ -16,9 +16,7 @@ COMMENT= VirtualBox kernel module for FreeBSD
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm \
- as86:${PORTSDIR}/devel/dev86 \
- kmk:${PORTSDIR}/devel/kBuild
+BUILD_DEPENDS= kmk:${PORTSDIR}/devel/kBuild
USES= kmod
UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
@@ -34,7 +32,6 @@ CONFIGURE_ARGS+=--with-gcc="${CC}" --with-g++="${CXX}" --nofatal \
--disable-alsa --disable-dbus --disable-python \
--build-headless
-CONFLICTS= bcc-[0-9]*
CONFLICTS_INSTALL= virtualbox-ose-kmod-devel-4* virtualbox-ose-kmod-legacy-4*
OPTIONS_DEFINE= DEBUG VIMAGE
diff --git a/emulators/virtualbox-ose-legacy/Makefile b/emulators/virtualbox-ose-legacy/Makefile
index 2fcc25067f89..e6cd914d7904 100644
--- a/emulators/virtualbox-ose-legacy/Makefile
+++ b/emulators/virtualbox-ose-legacy/Makefile
@@ -19,7 +19,6 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm \
- as86:${PORTSDIR}/devel/dev86 \
xsltproc:${PORTSDIR}/textproc/libxslt \
kmk:${PORTSDIR}/devel/kBuild \
gtar:${PORTSDIR}/archivers/gtar \
@@ -47,7 +46,6 @@ HAS_CONFIGURE= yes
CONFIGURE_ARGS+=--with-gcc="${CC}" --with-g++="${CXX}" --passive-mesa
USE_LDCONFIG= ${PREFIX}/lib/virtualbox
-CONFLICTS= bcc-[0-9]*
CONFLICTS_INSTALL= virtualbox-ose-4* virtualbox-ose-devel-4* virtualbox-ose-additions-4* virtualbox-ose-additions-devel-4*
VBOXUSER?= vboxusers
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index 2274d54e411e..06a7399e9e81 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -18,7 +18,6 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm \
- as86:${PORTSDIR}/devel/dev86 \
xsltproc:${PORTSDIR}/textproc/libxslt \
kmk:${PORTSDIR}/devel/kBuild \
gtar:${PORTSDIR}/archivers/gtar \
@@ -41,7 +40,6 @@ HAS_CONFIGURE= yes
CONFIGURE_ARGS+=--with-gcc="${CC}" --with-g++="${CXX}" --passive-mesa
USE_LDCONFIG= ${PREFIX}/lib/virtualbox
-CONFLICTS= bcc-[0-9]*
CONFLICTS_INSTALL= virtualbox-ose-devel-4* virtualbox-ose-legacy-4* virtualbox-ose-additions-4* virtualbox-ose-additions-devel-4*
VBOXUSER?= vboxusers