summaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2023-08-15 15:57:17 +0200
committerTobias C. Berner <tcberner@FreeBSD.org>2023-08-15 21:06:03 +0200
commitdc4e8c040a8b3b544b4cacab693c407f6bcd1d84 (patch)
treed20ee7e8019c01804c91d0f127751510371adba5 /x11
parent4c230fed88cc283e954899005d11ed7995f3c05e (diff)
downloadfreebsd-ports-dc4e8c040a8b3b544b4cacab693c407f6bcd1d84.zip
KDE: make ecm a build-only dependency in KDE Plasma
Diffstat (limited to 'x11')
-rw-r--r--x11/plasma5-kactivitymanagerd/Makefile5
-rw-r--r--x11/plasma5-kwayland-integration/Makefile6
-rw-r--r--x11/plasma5-layer-shell-qt/Makefile3
-rw-r--r--x11/plasma5-plasma-bigscreen/Makefile10
-rw-r--r--x11/plasma5-plasma-integration/Makefile6
5 files changed, 19 insertions, 11 deletions
diff --git a/x11/plasma5-kactivitymanagerd/Makefile b/x11/plasma5-kactivitymanagerd/Makefile
index 4e516519c080..f5865c43f2ce 100644
--- a/x11/plasma5-kactivitymanagerd/Makefile
+++ b/x11/plasma5-kactivitymanagerd/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kactivitymanagerd
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -10,8 +11,8 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/range/algorithm.hpp:devel/boost-libs
USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz xorg
USE_KDE= auth codecs config configwidgets coreaddons crash dbusaddons \
- ecm globalaccel i18n kio service widgetsaddons windowsystem \
- xmlgui
+ globalaccel i18n kio service widgetsaddons windowsystem xmlgui \
+ ecm:build
USE_QT= concurrent core dbus gui network sql widgets xml \
buildtools:build qmake:build
USE_XORG= x11
diff --git a/x11/plasma5-kwayland-integration/Makefile b/x11/plasma5-kwayland-integration/Makefile
index 63f62491f0cb..605754095662 100644
--- a/x11/plasma5-kwayland-integration/Makefile
+++ b/x11/plasma5-kwayland-integration/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kwayland-integration
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -14,8 +15,9 @@ BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto \
USES= cmake compiler:c++11-lib gl kde:5 pkgconfig qt:5 tar:xz xorg
USE_GL= gl
-USE_KDE= ecm guiaddons idletime plasma-wayland-protocols wayland \
- windowsystem
+USE_KDE= guiaddons idletime plasma-wayland-protocols wayland \
+ windowsystem \
+ ecm:build
USE_QT= core gui wayland widgets \
buildtools:build qmake:build
USE_XORG= x11
diff --git a/x11/plasma5-layer-shell-qt/Makefile b/x11/plasma5-layer-shell-qt/Makefile
index 84b7bba624f4..21f6bd65c867 100644
--- a/x11/plasma5-layer-shell-qt/Makefile
+++ b/x11/plasma5-layer-shell-qt/Makefile
@@ -1,5 +1,6 @@
PORTNAME= layer-shell-qt
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -13,7 +14,7 @@ LIB_DEPENDS= libwayland-client.so:graphics/wayland \
USES= cmake compiler:c++11-lang gettext gl kde:5 pkgconfig qt:5 \
tar:xz
USE_GL= gl
-USE_KDE= ecm
+USE_KDE= ecm:build
USE_QT= core gui wayland \
buildtools:build qmake:build
diff --git a/x11/plasma5-plasma-bigscreen/Makefile b/x11/plasma5-plasma-bigscreen/Makefile
index 6fe0ac0c8193..46acf2f8e2ff 100644
--- a/x11/plasma5-plasma-bigscreen/Makefile
+++ b/x11/plasma5-plasma-bigscreen/Makefile
@@ -1,5 +1,6 @@
PORTNAME= plasma-bigscreen
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -9,10 +10,11 @@ WWW= https://www.kde.org/plasma-desktop
USES= cmake compiler:c++11-lib cpe desktop-file-utils gettext kde:5 \
pkgconfig qt:5 tar:xz xorg
USE_KDE= activities activities-stats auth codecs completion config \
- configwidgets coreaddons ecm i18n jobwidgets kcmutils \
- kdeclarative kio kirigami2 notifications package \
- plasma-framework plasma-workspace service solid wayland \
- widgetsaddons windowsystem
+ configwidgets coreaddons i18n jobwidgets kcmutils kdeclarative \
+ kio kirigami2 notifications package plasma-framework \
+ plasma-workspace service solid wayland widgetsaddons \
+ windowsystem \
+ ecm:build
USE_QT= concurrent core dbus declarative gui network widgets xml \
buildtools:build qmake:build
USE_XORG= x11
diff --git a/x11/plasma5-plasma-integration/Makefile b/x11/plasma5-plasma-integration/Makefile
index f1d9148b2237..374b9a4268ab 100644
--- a/x11/plasma5-plasma-integration/Makefile
+++ b/x11/plasma5-plasma-integration/Makefile
@@ -1,5 +1,6 @@
PORTNAME= plasma-integration
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -12,9 +13,10 @@ RUN_DEPENDS= hack-font>=0:x11-fonts/hack-font
USES= cmake compiler:c++11-lib gettext kde:5 pkgconfig qt:5 \
shebangfix tar:xz xorg
USE_KDE= auth bookmarks breeze codecs completion config configwidgets \
- coreaddons ecm i18n iconthemes itemviews jobwidgets kio \
+ coreaddons i18n iconthemes itemviews jobwidgets kio \
notifications service solid wayland widgetsaddons windowsystem \
- xmlgui xdg-desktop-portal-kde \
+ xdg-desktop-portal-kde xmlgui \
+ ecm:build \
qqc2-desktop-style:run
USE_QT= concurrent core dbus declarative gui network quickcontrols2 \
wayland widgets x11extras xml \