summaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-12-21 19:46:37 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-12-21 19:46:37 +0000
commit7cbb15a29fd81b8318f3089d7030fda6a81ade31 (patch)
treeedba6e6bbe79ed1c96108ca3a4b94657add33684 /x11
parentfd94ff56cb055ccb674fa96e79c2f812a746fcb2 (diff)
downloadfreebsd-ports-7cbb15a29fd81b8318f3089d7030fda6a81ade31.zip
New port: Prerelease version of libXtrans from freedesktop.org:
network API translation layer for X applications and libraries Testing is encouraged, but please do not use these ports as dependencies until they are updated to release tarballs and the XFree86 ports have been updated to depend on them.
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/libXtrans/Makefile23
-rw-r--r--x11/libXtrans/distinfo1
-rw-r--r--x11/libXtrans/files/patch-Makefile.in11
-rw-r--r--x11/libXtrans/pkg-descr7
-rw-r--r--x11/libXtrans/pkg-plist12
6 files changed, 55 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 8f31269129cd..b68a61298708 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -72,6 +72,7 @@
SUBDIR += kdelibs3
SUBDIR += keylaunch
SUBDIR += kgamma
+ SUBDIR += libXtrans
SUBDIR += libcapplet
SUBDIR += libdnd
SUBDIR += libgnome
diff --git a/x11/libXtrans/Makefile b/x11/libXtrans/Makefile
new file mode 100644
index 000000000000..e12e8318e853
--- /dev/null
+++ b/x11/libXtrans/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: libXtrans
+# Date Created: 28 Oct, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libXtrans
+PORTVERSION= 0.1.p1
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= network API translation layer for X applications and libraries
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.1
+
+.include <bsd.port.mk>
diff --git a/x11/libXtrans/distinfo b/x11/libXtrans/distinfo
new file mode 100644
index 000000000000..e1082d0330db
--- /dev/null
+++ b/x11/libXtrans/distinfo
@@ -0,0 +1 @@
+MD5 (libXtrans-0.1.p1.tar.bz2) = 0a674f4f5b2197f15b8a80fa35bd4d17
diff --git a/x11/libXtrans/files/patch-Makefile.in b/x11/libXtrans/files/patch-Makefile.in
new file mode 100644
index 000000000000..f4437c5d7003
--- /dev/null
+++ b/x11/libXtrans/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sun Nov 9 22:43:21 2003
++++ Makefile.in Sun Nov 9 22:43:52 2003
+@@ -121,7 +121,7 @@
+ transport.c
+
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = xtrans.pc
+
+ EXTRA_DIST = xtrans.pc.in
diff --git a/x11/libXtrans/pkg-descr b/x11/libXtrans/pkg-descr
new file mode 100644
index 000000000000..5c55568029db
--- /dev/null
+++ b/x11/libXtrans/pkg-descr
@@ -0,0 +1,7 @@
+This package contains the code for a network API translation layer to insulate X
+applications and libraries from OS network vagaries
+
+WWW: http://www.freedesktop.org/Software/xlibs
+
+- Eric Anholt
+anholt@FreeBSD.org
diff --git a/x11/libXtrans/pkg-plist b/x11/libXtrans/pkg-plist
new file mode 100644
index 000000000000..611055bb90fd
--- /dev/null
+++ b/x11/libXtrans/pkg-plist
@@ -0,0 +1,12 @@
+include/X11/Xtrans/Xtrans.c
+include/X11/Xtrans/Xtrans.h
+include/X11/Xtrans/Xtransdef.h
+include/X11/Xtrans/Xtransdnet.c
+include/X11/Xtrans/Xtransint.h
+include/X11/Xtrans/Xtranslcl.c
+include/X11/Xtrans/Xtransos2.c
+include/X11/Xtrans/Xtranssock.c
+include/X11/Xtrans/Xtranstli.c
+include/X11/Xtrans/Xtransutil.c
+include/X11/Xtrans/transport.c
+libdata/pkgconfig/xtrans.pc